oneAPI Registration, Download, Licensing and Installation
Support for Getting Started questions related to download, Installation and licensing for Intel oneAPI Toolkits and software development tools.



Hi everyone please assist,

Recently acquired an L515 LIDAR to aid with computer vision research.

First-time use connected it to the computer and the drivers were automatically installed and the device was identified by windows successfully. I then proceed to download the Intel.RealSense.Viewer.exe just to verify the lidar is working properly and I can see the depth information. Upon the first launch of the above-named program, there was a prompt to update the firmware in order to proceed. I clicked update, the updating firmware process was showed on the top right-hand corner of the screen, it seemed to progress through the update successfully. Consequently, there was an error message saying the device took longer to reconnect to the software than expected or something similar to that effect. I allowed it to stand for a few minutes but no response from the camera. I have since then disconnected and reconnected the camera to the computer too many times to compatible USB3 ports. I have even installed the SDK and retired connecting but the device is not being identified by windows. I later connected the device to the next computer and repeat the process of installing the SDK but all attempts proved futile. 


Below is attached the last driver events from the system I was using when the device failed to be detected by windows after the update?


I have so many questions?

1. How can official intel software prompt to update on first use and the device fail immediately?

2. Is the device faulty?

3. I have been consumed in searching the internet and the community for similar reported issues. I have seen a lot of similar issues but none of the recommendations there have been helpful.

4. I Have tried using the update firmware tool following the instructions provided on GITHUB. However, the console provided in Intel.RealSense.Viewer.exe does not identify any commands. I tried navigating directly to the installation directory to load the update firmware tool (Intel.RealSense.FW.Update.exe) and it starts for a second display some writing on the screen and closed much too quickly for you to see or interact with the writing on the screen.

4. I have read about DFU mode, But since then have not been able to find any useful info to assist on that topic. 

5. The device was purchased on amazon by the Electrical Engineering Department at the university. Should I immediately report the issues as a faulty device or is this a really simple resolvable issue?

0 Kudos
3 Replies


Thanks for reaching out to us!

As this thread is related to Intel® graphics drivers and software, compatibility, troubleshooting, performance and optimization, we are moving this thread to the dedicated forum which handles these issues for faster response.

Have a nice day!

0 Kudos

Please provide a link for the new location.

I am eagerly awaiting assistance with the issue

Thank you.

0 Kudos

Hello TkLowe

Thank you for posting on the Intel️® communities. 

For any request related to Intel RealSense products, it is recommended that you go through the website directly. You can post your questions on the RealSense community forums.

Please keep in mind that this thread will no longer be monitored by Intel. Thank you for your understanding. 


David G.   

Intel Customer Support Technician  

0 Kudos