oneAPI Registration, Download, Licensing and Installation
Support for Getting Started questions for Intel oneAPI Toolkits, Intel Parallel Studio XE and Intel System Studio

Obtaining license files for older versions

Dankomaister
Novice
1,739 Views

Hi!

I have recently become in charge of maintain a local HPC cluster at work and am currently in the process of installing software via easybuild.

I have successfully installed the Intel 2019a toolchain using our named-user academic license (????-????????).

However certain software requires older versions of the intel compilers (icc, ifort) to be installed.

But when I try and install for example the Intel 2018 compilers I get an error saying that the license file is not valid for this product.

Looking at the license file it says INTEL 2019.0325 so that kind of makes sense, however I don't find anywhere to download license files for older version of Intel Parallel Studio.

So my question is, how do I obtain license files for older versions ?

/Daniel

Labels (1)
12 Replies
Soumya_M_Intel
Moderator
1,716 Views

Hi Dankomaister,


Thanks for posting the concern. However, please know this is a public forum and information provided in your post would be publicly available. For private information such as email id, login id, serial number, etc our team would contact you via forum private messages. However, in this case, we have saved the serial number to the case information at our end and removed it from the forum post.


Please note the INTEL 2019.0325 refers to your product's support expiration date: 3/25/2019 (mm/dd/yyyy). The licenses of our product suites and toolkits are backward compatible in nature i.e. they work with older product versions as well.


To understand the issue better, we would be requiring the below information.


  • The complete name of the product (along with edition and update number) that you are trying to install
  • The operating system name and version on which it is being installed.
  • A screenshot of the error during the installation. Kindly cross out the serial number or license information from it.


The above details would provide us a better understanding of the issue.


Regards,

Soumya


Dankomaister
Novice
1,708 Views

Hi Soumya!

 

Thanks for the information, I also thought the licenses are backward compatible that's why I'm confused that its not working...

So I'm trying to install intel-2018b.eb using the easybuild system, which when I look in detail is trying to install the intel compilers (icc, ifort) version 2018.3.222.

This is on a Linux HPC system running CentOS 7 and the error I'm getting is "The license server you provided does not have a valid license for this product." when running env INTEL_LICENSE_FILE=/cmcm/eb/licenses/intel/COM_L___????-???????? eb intel-2018b.eb --robot

Can you confirm that our license is valid for version 2018.3.222 of the intel compilers.

 

/Daniel

Soumya_M_Intel
Moderator
1,690 Views

Hi Dankomaister,


Thanks for the details. Please check the below license paths and delete any unused license files.


  • /opt/intel/licenses 
  • $HOME/intel/licenses
  • /cmcm/eb/licenses/intel/COM_L___????-???????? eb intel-2018b.eb --robot (the mentioned license path)


We have sent a separate email with a fresh copy of the license file to you (at license owner email id). Please move the existing license file to a different directory and paste the new license file to the mentioned license path before retrying the installation. 


However, do let us know if the issue persists. Have a nice day ahead.


Regards,

Soumya


Dankomaister
Novice
1,671 Views

Hi!

The license file you sent is identical to the one I'm already using and replacing it made no difference.
If this license file is indeed valid for version 2018.3.222 of the intel compilers than this makes not sense

This is the silent.cfg file I'm using with the license information removed.

ACTIVATION_TYPE=license_file
ACTIVATION_LICENSE_FILE=/cmcm/eb/licenses/intel/COM_L___????-????????.lic
PSET_INSTALL_DIR=/cmcm/eb/software/icc/2018.3.222-GCC-7.3.0-2.30
ACCEPT_EULA=accept
INSTALL_MODE=NONRPM
CONTINUE_WITH_OPTIONAL_ERROR=yes
COMPONENTS=intel-comp__x86_64;intel-comp-32bit__x86_64;intel-comp-doc__noarch;intel-comp-l-all-common__noarch;intel-comp-l-all-vars__noarch;intel-comp-nomcu-vars__noarch;intel-comp-ps-32bit__x86_64;intel-comp-ps__x86_64;intel-comp-ps-ss__x86_64;intel-comp-ps-ss-bec__x86_64;intel-comp-ps-ss-bec-32bit__x86_64;intel-compxe__noarch;intel-compxe-doc__noarch;intel-ccompxe__noarch;intel-ccompxe-doc__noarch;intel-icc__x86_64;intel-icc-32bit__x86_64;intel-icc-common__noarch;intel-icc-common-ps__noarch;intel-icc-common-ps-ss-bec__noarch;intel-icc-doc__noarch;intel-icc-doc-ps__noarch;intel-icc-ps__x86_64;intel-icc-ps-ss__x86_64;intel-icc-ps-ss-bec__x86_64;intel-icc-ps-ss-bec-32bit__x86_64;intel-openmp__x86_64;intel-openmp-32bit__x86_64;intel-openmp-common__noarch;intel-openmp-common-icc__noarch;intel-openmp-common-ifort__noarch;intel-openmp-ifort__x86_64;intel-openmp-ifort-32bit__x86_64;intel-ips__noarch;intel-ipsc__noarch;intel-gdb-gt__x86_64;intel-gdb-gt-src__noarch;intel-gdb-gt-doc__noarch;intel-gdb-gt-doc-ps__noarch;intel-gdb__x86_64;intel-gdb-source__noarch;intel-gdb-python-source__noarch;intel-gdb-common__noarch;intel-gdb-doc__noarch;intel-gdb-doc-ps__noarch

 

Soumya_M_Intel
Moderator
1,661 Views

Hi Dankomaister,


Thanks for trying the workaround and providing the silent installation details. It allows us to be sure and eliminate certain causes that might reflect the mentioned error.


We have recently emailed you requesting a few details. Among them are certain details that have the serial number in them. We need these details without any modification so please provide them by replying to the email to keep them private. 


Regards,

Soumya


Prasoongarg
Novice
1,643 Views

Hi, 

 

I'm a Ph.D. student at Colorado School of Mines and have been using Intel Parallel Studio XE 2013  for compiling and running the Fortran code in Abaqus (Software by Dassault Systems)  since last year. The code is written in Fortran77 and only works with the older intel compilers . The license expired this month.  Due to this problem, my research has come to halt entirely. Is there any way to renew the license? I also tried Intel oneAPI compilers but it doesn't seem to support the various intrinsic functions of Fortran77.

Soumya_M_Intel
Moderator
1,629 Views

Hi Dankomaister,


Thanks for the details. We are currently checking on the issue with our internal team. Kindly wait for 2-3 business days. We will get back to you as soon as possible.


Regards,

Soumya


Soumya_M_Intel
Moderator
1,625 Views

Hi Prasoongarg,


Thanks for posting your concern. However, we would suggest you post your query as a new separate thread in our forum topic. We assure you, our internal team would get back to you there in a timely manner. Please find the forum topic link below.


Link: https://community.intel.com/t5/Registration-Download-Licensing/bd-p/registration-download-licensing-...


Regards,

Soumya


Prasoongarg
Novice
1,613 Views

Hi,

Thanks for the fast reply.  As per your suggestion, I have already posted my query in a new separate thread (Link below). Is there any other means of contact as this might take long time?

 

Link: https://community.intel.com/t5/Registration-Download-Licensing/Renew-the-license-of-older-versions-o...

Soumya_M_Intel
Moderator
1,546 Views

Hi Dankomaister,


I am still following up with the concerned team regarding the issue. I will get back to you as soon as I receive any update from them regarding the same.


Regards,

Soumya


Soumya_M_Intel
Moderator
1,504 Views

Hi,


Thanks for your patience while we were checking with the higher team. Please know we have just got back to you with a solution regarding the concern via email. Looking forward to your update.


Regards,

Soumya


Soumya_M_Intel
Moderator
1,410 Views

Hi Dankomaister,


I have not heard back from you regarding the requested details. Proceeding further, this thread will no longer be monitored by Intel®. However, if you need any further assistance, please post a new question. Have a nice day ahead.


Regards,

Soumya


Reply