oneAPI Registration, Download, Licensing and Installation
Support for Getting Started questions for Intel oneAPI Toolkits, Intel Parallel Studio XE and Intel System Studio
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.
738 Discussions

Segmentation fault when using update alternatives on ubuntu 20.04

Michael_3
Beginner
1,485 Views

I'm trying to use to install install mkl version 2021.1.1 in a singularity instance, but I'm running into a segmentation error when trying to execute `/opt/intel/oneapi/mkl/latest/lib/intel64/libmkl_rt.so`. Here's the def file:

Bootstrap: docker
From: rocker/geospatial:4.1.0
Stage: build

############################################
%post
############################################

##intel mkl###
apt update
apt install -y gnupg2

wget https://apt.repos.intel.com/intel-gpg-keys/GPG-PUB-KEY-INTEL-SW-PRODUCTS.PUB -O - > key_stored2file
apt-key add key_stored2file
rm key_stored2file
echo "deb https://apt.repos.intel.com/oneapi all main" | tee /etc/apt/sources.list.d/oneAPI.list
apt update
apt install -y intel-oneapi-mkl-2021.1.1

/opt/intel/oneapi/mkl/latest/lib/intel64/libmkl_rt.so

update-alternatives --install /usr/lib/x86_64-linux-gnu/libblas.so     \
                    libblas.so-x86_64-linux-gnu      /opt/intel/oneapi/mkl/latest/lib/intel64/libmkl_rt.so 50
update-alternatives --install /usr/lib/x86_64-linux-gnu/libblas.so.3   \
                    libblas.so.3-x86_64-linux-gnu    /opt/intel/oneapi/mkl/latest/lib/intel64/libmkl_rt.so 50
update-alternatives --install /usr/lib/x86_64-linux-gnu/liblapack.so   \
                    liblapack.so-x86_64-linux-gnu    /opt/intel/oneapi/mkl/latest/lib/intel64/libmkl_rt.so 50
update-alternatives --install /usr/lib/x86_64-linux-gnu/liblapack.so.3 \
                    liblapack.so.3-x86_64-linux-gnu  /opt/intel/oneapi/mkl/latest/lib/intel64/libmkl_rt.so 50

echo "/opt/intel/lib/intel64"     >  /etc/ld.so.conf.d/mkl.conf
echo "/opt/intel/mkl/lib/intel64" >> /etc/ld.so.conf.d/mkl.conf
ldconfig

echo "MKL_THREADING_LAYER=GNU" >> /etc/environment

 

Here's the build log:

 

 singularity build --remote mkl.sif mkl.def
INFO:    Access Token Verified!
INFO:    Token stored in /root/.singularity/remote.yaml
INFO:    Remote "default" now in use.
INFO:    Starting build...
Getting image source signatures
Copying blob sha256:16ec32c2132b43494832a05f2b02f7a822479f8250c173d0ab27b3de78b2f058
Copying blob sha256:e031c1a9f2f8981caa2c98eccc68a7f37f276578570815a2a750f1a9a7a26a2b
Copying blob sha256:a70855d85b62f4445418b3403977c218af39b555b9d024b0e34d854b43461a73
Copying blob sha256:ee8d56356e0a287731be50c207130a0960ec541c009ac15613f895f2f2d5278e
Copying blob sha256:5d3c6fe2adc613012e5716756b9ad873b0e98761c70c1f2bbe0c0ab3c92359b4
Copying blob sha256:fc0654371b2f0535df2bda795325c8f2b561f13186a133469562b9685abc6768
Copying blob sha256:8d80cde37ed7f3a04b27909799a1e1c73fe9fafbc38699ecbc7c82d36559d6fd
Copying blob sha256:4cfc1cf5c9b8960e2c477c2273d72febaf6003d9efe46601d484f2876e1193f3
Copying config sha256:7088bb9885c96e3651bac5b55ab97ad5a39f912a837acc7fc72d261107125a21
Writing manifest to image destination
Storing signatures
2021/07/31 16:06:19  info unpack layer: sha256:16ec32c2132b43494832a05f2b02f7a822479f8250c173d0ab27b3de78b2f058
2021/07/31 16:06:20  info unpack layer: sha256:e031c1a9f2f8981caa2c98eccc68a7f37f276578570815a2a750f1a9a7a26a2b
2021/07/31 16:06:20  info unpack layer: sha256:a70855d85b62f4445418b3403977c218af39b555b9d024b0e34d854b43461a73
2021/07/31 16:06:29  info unpack layer: sha256:ee8d56356e0a287731be50c207130a0960ec541c009ac15613f895f2f2d5278e
2021/07/31 16:06:43  info unpack layer: sha256:5d3c6fe2adc613012e5716756b9ad873b0e98761c70c1f2bbe0c0ab3c92359b4
2021/07/31 16:06:43  info unpack layer: sha256:fc0654371b2f0535df2bda795325c8f2b561f13186a133469562b9685abc6768
2021/07/31 16:06:51  info unpack layer: sha256:8d80cde37ed7f3a04b27909799a1e1c73fe9fafbc38699ecbc7c82d36559d6fd
2021/07/31 16:07:10  info unpack layer: sha256:4cfc1cf5c9b8960e2c477c2273d72febaf6003d9efe46601d484f2876e1193f3
INFO:    Running post scriptlet
+ apt update

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

Get:1 http://security.ubuntu.com/ubuntu focal-security InRelease [114 kB]
Get:2 http://archive.ubuntu.com/ubuntu focal InRelease [265 kB]
Get:3 http://security.ubuntu.com/ubuntu focal-security/main amd64 Packages [989 kB]
Get:4 http://security.ubuntu.com/ubuntu focal-security/universe amd64 Packages [785 kB]
Get:5 http://security.ubuntu.com/ubuntu focal-security/restricted amd64 Packages [432 kB]
Get:6 http://security.ubuntu.com/ubuntu focal-security/multiverse amd64 Packages [30.6 kB]
Get:7 http://archive.ubuntu.com/ubuntu focal-updates InRelease [114 kB]
Get:8 http://archive.ubuntu.com/ubuntu focal-backports InRelease [101 kB]
Get:9 http://archive.ubuntu.com/ubuntu focal/universe amd64 Packages [11.3 MB]
Get:10 http://archive.ubuntu.com/ubuntu focal/restricted amd64 Packages [33.4 kB]
Get:11 http://archive.ubuntu.com/ubuntu focal/main amd64 Packages [1,275 kB]
Get:12 http://archive.ubuntu.com/ubuntu focal/multiverse amd64 Packages [177 kB]
Get:13 http://archive.ubuntu.com/ubuntu focal-updates/restricted amd64 Packages [478 kB]
Get:14 http://archive.ubuntu.com/ubuntu focal-updates/universe amd64 Packages [1,055 kB]
Get:15 http://archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 Packages [33.1 kB]
Get:16 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages [1,421 kB]
Get:17 http://archive.ubuntu.com/ubuntu focal-backports/universe amd64 Packages [6,319 B]
Get:18 http://archive.ubuntu.com/ubuntu focal-backports/main amd64 Packages [2,668 B]
Fetched 18.7 MB in 2s (7,519 kB/s)
Reading package lists...
Building dependency tree...
Reading state information...
2 packages can be upgraded. Run 'apt list --upgradable' to see them.
+ apt install -y gnupg2

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

Reading package lists...
Building dependency tree...
Reading state information...
The following additional packages will be installed:
  dirmngr gnupg gnupg-l10n gnupg-utils gpg gpg-agent gpg-wks-client
  gpg-wks-server gpgconf gpgsm libassuan0 libksba8 libnpth0 pinentry-curses
Suggested packages:
  dbus-user-session libpam-systemd pinentry-gnome3 tor parcimonie xloadimage
  scdaemon pinentry-doc
The following NEW packages will be installed:
  dirmngr gnupg gnupg-l10n gnupg-utils gnupg2 gpg gpg-agent gpg-wks-client
  gpg-wks-server gpgconf gpgsm libassuan0 libksba8 libnpth0 pinentry-curses
0 upgraded, 15 newly installed, 0 to remove and 2 not upgraded.
Need to get 2,541 kB of archives.
After this operation, 7,541 kB of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu focal/main amd64 libassuan0 amd64 2.5.3-7ubuntu2 [35.7 kB]
Get:2 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 gpgconf amd64 2.2.19-3ubuntu2.1 [124 kB]
Get:3 http://archive.ubuntu.com/ubuntu focal/main amd64 libksba8 amd64 1.3.5-2 [92.6 kB]
Get:4 http://archive.ubuntu.com/ubuntu focal/main amd64 libnpth0 amd64 1.6-1 [7,736 B]
Get:5 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 dirmngr amd64 2.2.19-3ubuntu2.1 [329 kB]
Get:6 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 gnupg-l10n all 2.2.19-3ubuntu2.1 [51.7 kB]
Get:7 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 gnupg-utils amd64 2.2.19-3ubuntu2.1 [480 kB]
Get:8 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 gpg amd64 2.2.19-3ubuntu2.1 [483 kB]
Get:9 http://archive.ubuntu.com/ubuntu focal/main amd64 pinentry-curses amd64 1.1.0-3build1 [36.3 kB]
Get:10 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 gpg-agent amd64 2.2.19-3ubuntu2.1 [232 kB]
Get:11 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 gpg-wks-client amd64 2.2.19-3ubuntu2.1 [97.6 kB]
Get:12 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 gpg-wks-server amd64 2.2.19-3ubuntu2.1 [90.3 kB]
Get:13 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 gpgsm amd64 2.2.19-3ubuntu2.1 [217 kB]
Get:14 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 gnupg all 2.2.19-3ubuntu2.1 [259 kB]
Get:15 http://archive.ubuntu.com/ubuntu focal-updates/universe amd64 gnupg2 all 2.2.19-3ubuntu2.1 [4,584 B]
debconf: delaying package configuration, since apt-utils is not installed
Fetched 2,541 kB in 1s (3,110 kB/s)
Selecting previously unselected package libassuan0:amd64.
(Reading database ... 58960 files and directories currently installed.)
Preparing to unpack .../00-libassuan0_2.5.3-7ubuntu2_amd64.deb ...
Unpacking libassuan0:amd64 (2.5.3-7ubuntu2) ...
Selecting previously unselected package gpgconf.
Preparing to unpack .../01-gpgconf_2.2.19-3ubuntu2.1_amd64.deb ...
Unpacking gpgconf (2.2.19-3ubuntu2.1) ...
Selecting previously unselected package libksba8:amd64.
Preparing to unpack .../02-libksba8_1.3.5-2_amd64.deb ...
Unpacking libksba8:amd64 (1.3.5-2) ...
Selecting previously unselected package libnpth0:amd64.
Preparing to unpack .../03-libnpth0_1.6-1_amd64.deb ...
Unpacking libnpth0:amd64 (1.6-1) ...
Selecting previously unselected package dirmngr.
Preparing to unpack .../04-dirmngr_2.2.19-3ubuntu2.1_amd64.deb ...
Unpacking dirmngr (2.2.19-3ubuntu2.1) ...
Selecting previously unselected package gnupg-l10n.
Preparing to unpack .../05-gnupg-l10n_2.2.19-3ubuntu2.1_all.deb ...
Unpacking gnupg-l10n (2.2.19-3ubuntu2.1) ...
Selecting previously unselected package gnupg-utils.
Preparing to unpack .../06-gnupg-utils_2.2.19-3ubuntu2.1_amd64.deb ...
Unpacking gnupg-utils (2.2.19-3ubuntu2.1) ...
Selecting previously unselected package gpg.
Preparing to unpack .../07-gpg_2.2.19-3ubuntu2.1_amd64.deb ...
Unpacking gpg (2.2.19-3ubuntu2.1) ...
Selecting previously unselected package pinentry-curses.
Preparing to unpack .../08-pinentry-curses_1.1.0-3build1_amd64.deb ...
Unpacking pinentry-curses (1.1.0-3build1) ...
Selecting previously unselected package gpg-agent.
Preparing to unpack .../09-gpg-agent_2.2.19-3ubuntu2.1_amd64.deb ...
Unpacking gpg-agent (2.2.19-3ubuntu2.1) ...
Selecting previously unselected package gpg-wks-client.
Preparing to unpack .../10-gpg-wks-client_2.2.19-3ubuntu2.1_amd64.deb ...
Unpacking gpg-wks-client (2.2.19-3ubuntu2.1) ...
Selecting previously unselected package gpg-wks-server.
Preparing to unpack .../11-gpg-wks-server_2.2.19-3ubuntu2.1_amd64.deb ...
Unpacking gpg-wks-server (2.2.19-3ubuntu2.1) ...
Selecting previously unselected package gpgsm.
Preparing to unpack .../12-gpgsm_2.2.19-3ubuntu2.1_amd64.deb ...
Unpacking gpgsm (2.2.19-3ubuntu2.1) ...
Selecting previously unselected package gnupg.
Preparing to unpack .../13-gnupg_2.2.19-3ubuntu2.1_all.deb ...
Unpacking gnupg (2.2.19-3ubuntu2.1) ...
Selecting previously unselected package gnupg2.
Preparing to unpack .../14-gnupg2_2.2.19-3ubuntu2.1_all.deb ...
Unpacking gnupg2 (2.2.19-3ubuntu2.1) ...
Setting up libksba8:amd64 (1.3.5-2) ...
Setting up libnpth0:amd64 (1.6-1) ...
Setting up libassuan0:amd64 (2.5.3-7ubuntu2) ...
Setting up gnupg-l10n (2.2.19-3ubuntu2.1) ...
Setting up gpgconf (2.2.19-3ubuntu2.1) ...
Setting up gpg (2.2.19-3ubuntu2.1) ...
Setting up gnupg-utils (2.2.19-3ubuntu2.1) ...
Setting up pinentry-curses (1.1.0-3build1) ...
Setting up gpg-agent (2.2.19-3ubuntu2.1) ...
Setting up gpgsm (2.2.19-3ubuntu2.1) ...
Setting up dirmngr (2.2.19-3ubuntu2.1) ...
Setting up gpg-wks-server (2.2.19-3ubuntu2.1) ...
Setting up gpg-wks-client (2.2.19-3ubuntu2.1) ...
Setting up gnupg (2.2.19-3ubuntu2.1) ...
Setting up gnupg2 (2.2.19-3ubuntu2.1) ...
Processing triggers for libc-bin (2.31-0ubuntu9.2) ...
+ wget https://apt.repos.intel.com/intel-gpg-keys/GPG-PUB-KEY-INTEL-SW-PRODUCTS.PUB -O -
--2021-07-31 16:07:37--  https://apt.repos.intel.com/intel-gpg-keys/GPG-PUB-KEY-INTEL-SW-PRODUCTS.PUB
Resolving apt.repos.intel.com (apt.repos.intel.com)... 184.84.65.68, 2600:1408:8400:5ac::4b23, 2600:1408:8400:58d::4b23
Connecting to apt.repos.intel.com (apt.repos.intel.com)|184.84.65.68|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 3796 (3.7K) [binary/octet-stream]
Saving to: ‘STDOUT’

     0K ...                                                   100%  525M=0s

2021-07-31 16:07:38 (525 MB/s) - written to stdout [3796/3796]

+ apt-key add key_stored2file
Warning: apt-key output should not be parsed (stdout is not a terminal)
OK
+ rm key_stored2file
deb https://apt.repos.intel.com/oneapi all main
+ + tee /etc/apt/sources.list.d/oneAPI.list
echo deb https://apt.repos.intel.com/oneapi all main
+ apt update

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

Hit:1 http://security.ubuntu.com/ubuntu focal-security InRelease
Get:2 https://apt.repos.intel.com/oneapi all InRelease [4,390 B]
Hit:3 http://archive.ubuntu.com/ubuntu focal InRelease
Hit:4 http://archive.ubuntu.com/ubuntu focal-updates InRelease
Hit:5 http://archive.ubuntu.com/ubuntu focal-backports InRelease
Get:6 https://apt.repos.intel.com/oneapi all/main all Packages [16.4 kB]
Get:7 https://apt.repos.intel.com/oneapi all/main amd64 Packages [84.6 kB]
Fetched 105 kB in 0s (238 kB/s)
Reading package lists...
Building dependency tree...
Reading state information...
2 packages can be upgraded. Run 'apt list --upgradable' to see them.
+ apt install -y intel-oneapi-mkl-2021.1.1

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

Reading package lists...
Building dependency tree...
Reading state information...
The following additional packages will be installed:
  intel-oneapi-common-licensing intel-oneapi-common-licensing-2021.3.0
  intel-oneapi-common-vars intel-oneapi-compiler-dpcpp-cpp-runtime
  intel-oneapi-compiler-dpcpp-cpp-runtime-2021.3.0
  intel-oneapi-compiler-shared-common-runtime-2021.3.0
  intel-oneapi-compiler-shared-runtime-2021.3.0 intel-oneapi-condaindex
  intel-oneapi-mkl-common-2021.1.1 intel-oneapi-openmp-2021.3.0
  intel-oneapi-openmp-common-2021.3.0 intel-oneapi-tbb
  intel-oneapi-tbb-2021.3.0 intel-oneapi-tbb-common-2021.3.0
The following NEW packages will be installed:
  intel-oneapi-common-licensing intel-oneapi-common-licensing-2021.3.0
  intel-oneapi-common-vars intel-oneapi-compiler-dpcpp-cpp-runtime
  intel-oneapi-compiler-dpcpp-cpp-runtime-2021.3.0
  intel-oneapi-compiler-shared-common-runtime-2021.3.0
  intel-oneapi-compiler-shared-runtime-2021.3.0 intel-oneapi-condaindex
  intel-oneapi-mkl-2021.1.1 intel-oneapi-mkl-common-2021.1.1
  intel-oneapi-openmp-2021.3.0 intel-oneapi-openmp-common-2021.3.0
  intel-oneapi-tbb intel-oneapi-tbb-2021.3.0 intel-oneapi-tbb-common-2021.3.0
0 upgraded, 15 newly installed, 0 to remove and 2 not upgraded.
Need to get 473 MB of archives.
After this operation, 2,442 MB of additional disk space will be used.
Get:1 https://apt.repos.intel.com/oneapi all/main amd64 intel-oneapi-common-licensing-2021.3.0 all 2021.3.0-261 [35.6 kB]
Get:2 https://apt.repos.intel.com/oneapi all/main amd64 intel-oneapi-common-licensing all 2021.3.0-261 [2,298 B]
Get:3 https://apt.repos.intel.com/oneapi all/main amd64 intel-oneapi-common-vars all 2021.3.0-261 [13.0 kB]
Get:4 https://apt.repos.intel.com/oneapi all/main amd64 intel-oneapi-compiler-shared-common-runtime-2021.3.0 all 2021.3.0-3350 [14.6 MB]
Get:5 https://apt.repos.intel.com/oneapi all/main amd64 intel-oneapi-condaindex amd64 2021.3.0-159 [675 kB]
Get:6 https://apt.repos.intel.com/oneapi all/main amd64 intel-oneapi-openmp-common-2021.3.0 all 2021.3.0-3350 [16.0 kB]
Get:7 https://apt.repos.intel.com/oneapi all/main amd64 intel-oneapi-openmp-2021.3.0 amd64 2021.3.0-3350 [120 MB]
Get:8 https://apt.repos.intel.com/oneapi all/main amd64 intel-oneapi-compiler-shared-runtime-2021.3.0 amd64 2021.3.0-3350 [5,851 kB]
Get:9 https://apt.repos.intel.com/oneapi all/main amd64 intel-oneapi-tbb-common-2021.3.0 all 2021.3.0-511 [21.5 kB]
Get:10 https://apt.repos.intel.com/oneapi all/main amd64 intel-oneapi-tbb-2021.3.0 amd64 2021.3.0-511 [2,167 kB]
Get:11 https://apt.repos.intel.com/oneapi all/main amd64 intel-oneapi-compiler-dpcpp-cpp-runtime-2021.3.0 amd64 2021.3.0-3350 [129 MB]
Get:12 https://apt.repos.intel.com/oneapi all/main amd64 intel-oneapi-compiler-dpcpp-cpp-runtime amd64 2021.3.0-3350 [2,818 B]
Get:13 https://apt.repos.intel.com/oneapi all/main amd64 intel-oneapi-mkl-common-2021.1.1 all 2021.1.1-52 [18.6 kB]
Get:14 https://apt.repos.intel.com/oneapi all/main amd64 intel-oneapi-tbb amd64 2021.3.0-511 [1,840 B]
Get:15 https://apt.repos.intel.com/oneapi all/main amd64 intel-oneapi-mkl-2021.1.1 amd64 2021.1.1-52 [200 MB]
debconf: delaying package configuration, since apt-utils is not installed
Fetched 473 MB in 19s (24.3 MB/s)
Selecting previously unselected package intel-oneapi-common-licensing-2021.3.0.
(Reading database ... 59173 files and directories currently installed.)
Preparing to unpack .../00-intel-oneapi-common-licensing-2021.3.0_2021.3.0-261_all.deb ...
Unpacking intel-oneapi-common-licensing-2021.3.0 (2021.3.0-261) ...
Selecting previously unselected package intel-oneapi-common-licensing.
Preparing to unpack .../01-intel-oneapi-common-licensing_2021.3.0-261_all.deb ...
Unpacking intel-oneapi-common-licensing (2021.3.0-261) ...
Selecting previously unselected package intel-oneapi-common-vars.
Preparing to unpack .../02-intel-oneapi-common-vars_2021.3.0-261_all.deb ...
Unpacking intel-oneapi-common-vars (2021.3.0-261) ...
Selecting previously unselected package intel-oneapi-compiler-shared-common-runtime-2021.3.0.
Preparing to unpack .../03-intel-oneapi-compiler-shared-common-runtime-2021.3.0_2021.3.0-3350_all.deb ...
Unpacking intel-oneapi-compiler-shared-common-runtime-2021.3.0 (2021.3.0-3350) ...
Selecting previously unselected package intel-oneapi-condaindex.
Preparing to unpack .../04-intel-oneapi-condaindex_2021.3.0-159_amd64.deb ...
Unpacking intel-oneapi-condaindex (2021.3.0-159) ...
Selecting previously unselected package intel-oneapi-openmp-common-2021.3.0.
Preparing to unpack .../05-intel-oneapi-openmp-common-2021.3.0_2021.3.0-3350_all.deb ...
Unpacking intel-oneapi-openmp-common-2021.3.0 (2021.3.0-3350) ...
Selecting previously unselected package intel-oneapi-openmp-2021.3.0.
Preparing to unpack .../06-intel-oneapi-openmp-2021.3.0_2021.3.0-3350_amd64.deb ...
Unpacking intel-oneapi-openmp-2021.3.0 (2021.3.0-3350) ...
Selecting previously unselected package intel-oneapi-compiler-shared-runtime-2021.3.0.
Preparing to unpack .../07-intel-oneapi-compiler-shared-runtime-2021.3.0_2021.3.0-3350_amd64.deb ...
Unpacking intel-oneapi-compiler-shared-runtime-2021.3.0 (2021.3.0-3350) ...
Selecting previously unselected package intel-oneapi-tbb-common-2021.3.0.
Preparing to unpack .../08-intel-oneapi-tbb-common-2021.3.0_2021.3.0-511_all.deb ...
Unpacking intel-oneapi-tbb-common-2021.3.0 (2021.3.0-511) ...
Selecting previously unselected package intel-oneapi-tbb-2021.3.0.
Preparing to unpack .../09-intel-oneapi-tbb-2021.3.0_2021.3.0-511_amd64.deb ...
Unpacking intel-oneapi-tbb-2021.3.0 (2021.3.0-511) ...
Selecting previously unselected package intel-oneapi-compiler-dpcpp-cpp-runtime-2021.3.0.
Preparing to unpack .../10-intel-oneapi-compiler-dpcpp-cpp-runtime-2021.3.0_2021.3.0-3350_amd64.deb ...
Unpacking intel-oneapi-compiler-dpcpp-cpp-runtime-2021.3.0 (2021.3.0-3350) ...
Selecting previously unselected package intel-oneapi-compiler-dpcpp-cpp-runtime.
Preparing to unpack .../11-intel-oneapi-compiler-dpcpp-cpp-runtime_2021.3.0-3350_amd64.deb ...
Unpacking intel-oneapi-compiler-dpcpp-cpp-runtime (2021.3.0-3350) ...
Selecting previously unselected package intel-oneapi-mkl-common-2021.1.1.
Preparing to unpack .../12-intel-oneapi-mkl-common-2021.1.1_2021.1.1-52_all.deb ...
Unpacking intel-oneapi-mkl-common-2021.1.1 (2021.1.1-52) ...
Selecting previously unselected package intel-oneapi-tbb.
Preparing to unpack .../13-intel-oneapi-tbb_2021.3.0-511_amd64.deb ...
Unpacking intel-oneapi-tbb (2021.3.0-511) ...
Selecting previously unselected package intel-oneapi-mkl-2021.1.1.
Preparing to unpack .../14-intel-oneapi-mkl-2021.1.1_2021.1.1-52_amd64.deb ...
Unpacking intel-oneapi-mkl-2021.1.1 (2021.1.1-52) ...
Setting up intel-oneapi-common-licensing-2021.3.0 (2021.3.0-261) ...
Setting up intel-oneapi-condaindex (2021.3.0-159) ...
Setting up intel-oneapi-common-vars (2021.3.0-261) ...
Setting up intel-oneapi-openmp-common-2021.3.0 (2021.3.0-3350) ...
Setting up intel-oneapi-common-licensing (2021.3.0-261) ...
Setting up intel-oneapi-mkl-common-2021.1.1 (2021.1.1-52) ...
Setting up intel-oneapi-compiler-shared-common-runtime-2021.3.0 (2021.3.0-3350) ...
Setting up intel-oneapi-tbb-common-2021.3.0 (2021.3.0-511) ...
Setting up intel-oneapi-openmp-2021.3.0 (2021.3.0-3350) ...
Setting up intel-oneapi-tbb-2021.3.0 (2021.3.0-511) ...
Setting up intel-oneapi-tbb (2021.3.0-511) ...
Setting up intel-oneapi-compiler-shared-runtime-2021.3.0 (2021.3.0-3350) ...
Setting up intel-oneapi-compiler-dpcpp-cpp-runtime-2021.3.0 (2021.3.0-3350) ...
Setting up intel-oneapi-compiler-dpcpp-cpp-runtime (2021.3.0-3350) ...
Setting up intel-oneapi-mkl-2021.1.1 (2021.1.1-52) ...
+ /opt/intel/oneapi/mkl/latest/lib/intel64/libmkl_rt.so
Segmentation fault
FATAL:   While performing build: while running engine: exit status 139
FATAL:   While performing build: build image size <= 0

 

0 Kudos
10 Replies
Michael_3
Beginner
1,476 Views

note that I've also tried to build this singularity image locally and gotten the same segmentation fault error, so it's not an issue specific to sylab's remote build environment.

Michael_3
Beginner
1,458 Views

I've now tested this script running directly in an interactive docker image (rocker/geospatial:4.1.0) and get the same segmentation fault running /opt/intel/oneapi/mkl/latest/lib/intel64/libmkl_rt.so, so it's not an issue with singularity.

Michael_3
Beginner
1,457 Views

I also get the same segmentation fault after installing intel-oneapi-mkl-2021.3.0 instead of 2021.1.1

Michael_3
Beginner
1,457 Views

I've also tested this in much more pared down image*, and I get the same segmentation fault in r-base from dockerhub (https://hub.docker.com/_/r-base) which is an official image.

 

note r-base is running debian 11 whereas rocker/geospatial:4.1.0 is ubuntu 20.04.

the rocker geospatial stack also contains a bunch of other software, but that doesn't seem to be the issue.

Michael_3
Beginner
1,457 Views

I've also tested the above script and it works in ubuntu 20.04 running as a VM (rather than a container), so the segmentation fault is related specifically to MKL being installed in a container.

ChrisB_Intel
Moderator
1,318 Views

I have opened a bug on this issue, I will update you as soon as I have more information.


Thanks

Chris



ChrisB_Intel
Moderator
1,087 Views

MIchael_3,


My apologies on the delay, I dropped the ball on this one.


  • Can you please provide information on what script you are using MKL to build? If you want to provide it to me via private message that would be fine as well.


  • Are you attempting to build oneMKL examples?


  • What was the last MKL version where the issue wasn't reproduced


Thanks

Chris



Khang_N_Intel
Employee
961 Views

Hi Michael,

Could you provide information requested by Chris?


Thanks,

Khang


Khang_N_Intel
Employee
911 Views

Hi Michael,


Since we haven't heard from you for quite some time, I would like to close this thread.

Please feel free to open new thread should you have any question relating to oneMKL.


Best regards,

Khang


Michael_3
Beginner
908 Views

All the information Chris requested was in the original post. You'll need a singularity installation to test it out, but other than that you can just copy and paste the above definition file. Please let me know if you have any follow-up questions after actually attempting to build the above definition file.

Reply