oneAPI Registration, Download, Licensing and Installation
Support for Getting Started questions related to download, Installation and licensing for Intel oneAPI Toolkits and software development tools.
1387 Discussions

Unable to use intelpython3_full 2023.2.0 for Linux on Rhel 7 due to glibc version requirement

davidnfox
Beginner
553 Views

We are developing software that must be able to run on rhel/centos7.  For the first time, I'm blocked from doing this due to a glibc version requirement that is in intelpython3_full 2023.2.0, but not intelpython3_full 2023.1.0 *or* intelpython3_core 2023.2.0.  

Was this loss of compatibility unintentional or planned?  In either case, will a future version of intelpython3_full 2023 restore compatibility with rhel/centos7?

 

The specific error i'm getting (and I'm using mamba to install) is ....

mamba create -n intelpython -c intel intelpython3_full=2023.2.0 python=3.9 -y

which results in : 

Looking for: ['intelpython3_full=2023.2.0', 'python=3.9']

Could not solve for environment specs
The following package could not be installed
└─ intelpython3_full 2023.2.0** is uninstallable because it requires
├─ dpctl 0.14.5 py38he78b74f_24, which requires
│ └─ __glibc >=2.28,<3.0.a0 , which is missing on the system;
└─ dpnp [0.12.1 py310hd01b3e2_157|0.12.1 py39hd01b3e2_157], which requires
└─ __glibc >=2.28,<3.0.a0 , which is missing on the system.

 

 

 

0 Kudos
2 Replies
RahulC_Intel
Moderator
510 Views

Hi David, please find the below list of Operating Systems which are compatible with Intel® Python3 2023.2.0.


Operating Systems:


  • 64-bit Linux*: Ubuntu* 20.04, 22.04 (CPU & GPU)
    • Using Microsoft’s Windows Subsystem for Linux 2 (WSL2) in Windows 10, you can install the native Linux distribution of Intel oneAPI toolkits and libraries on Windows for CPU and GPU workflows.
  • Windows* Server 2019, 2022 (CPU & GPU)
  • Red Hat Enterprise Linux 8, 9 (CPU & GPU) 
  • Fedora 36, 37 (CPU only)
  • SUSE Linux Enterprise 15 SP3, 15 SP4 (CPU & GPU)
  • MacOS Monterey 12.x, Ventura 13.x (CPU only)


Regarding your concern related RHEL/Centos 7, we would like to inform that whenever our engineering team test a product, they always make sure to test it with the Operating systems which is in demand and we always recommend our users to try the tested versions of the OS which are listed in the release note.


You may find the below link for further help: https://cdrdv2.intel.com/v1/dl/getContent/783108?explicitVersion=true


0 Kudos
RahulC_Intel
Moderator
481 Views

Hi David, unfortunately we were unable to hear back from you. 


If you have any further query, please post a new question as this thread will no longer be monitored by Intel®. 


0 Kudos
Reply