oneAPI Registration, Download, Licensing and Installation
Support for Getting Started questions for Intel oneAPI Toolkits, Intel Parallel Studio XE and Intel System Studio
733 Discussions

Windows 7 as a supported development platform or as a deployment target

Patrick_H_3
Novice
487 Views

I had previously posted a couple of questions on this, but my posts were closed with no real answer.

The problem I reported was that the 2021 version of IPP (packaged as part of OneApi using Qt) does not install on win7. By "not install" I mean that the installer generates a popup error, requesting that the "program be re-installed" - yet the answer from Intel appears to be that since this is not a supported version of Windows (as of 2021), then the error is fine. However this raises two questions: 1) why is there not a check for the operating system version, so that the user can be warned, rather than being told that there is some error requiring a re-install; and 2) does this also mean that Windows 7 is no longer supported as a target platform for any applications using IPP?

I believe there are workarounds for #1 (so win7 can be used to develop an application), but #2 is more serious if true.

I am posting this as a new message, so that I can get an answer.

0 Kudos
1 Solution
Soumya_M_Intel
Moderator
456 Views

Hi Patrick,


Since we have recently handled the same concern on a support ticket of yours, we are proceeding further and closing this thread. However, please feel free to create a new thread if there are any other queries or concerns. Have a nice day ahead.


Regards,

Soumya


View solution in original post

2 Replies
Patrick_H_3
Novice
469 Views

Further experiments indicate that the only problem seems to be with the Qt-based install that is used with the 2021 release (different to the 2020 releases). This installer (bootstrapper I think) has problems running on win7, but works on win10. So a workaround for the problem appears to be to install on win10, and then use a file share from win7 to reference the installed toolkits. This seems to work for me so that I can build on win7 (and win10), even though it is a bit ugly.

Soumya_M_Intel
Moderator
457 Views

Hi Patrick,


Since we have recently handled the same concern on a support ticket of yours, we are proceeding further and closing this thread. However, please feel free to create a new thread if there are any other queries or concerns. Have a nice day ahead.


Regards,

Soumya


Reply