oneAPI Registration, Download, Licensing and Installation
Support for Getting Started questions related to download, Installation and licensing for Intel oneAPI Toolkits and software development tools.

Yet another installation failure


TBH I've stopped tracking every release and combination over the last 10 months or so, but when I saw oneAPI 2022.3.1 was out I thought I'd give it yet another try. And, well, once again...




At this point I give up. No more "uninstall oneAPI, double-uninstall every version of Visual Studio that's ever been installed on your computer, hey why not consider reinstalling Windows too, then start over from the beginning" for the nth time.


If Intel developers won't or can't talk to Microsoft developers, I guess I'll just cross oneAPI off. It just hasn't proved to be worth the effort.

0 Kudos
8 Replies

Hi Mark, we sincerely apologize for the inconvenience caused. Could you share the following information with us>

  • The OS build on which you are installing the Intel® oneAPI product
  • The version of Visual Studio installed on your system along with their build versions
  • Any other versions of Intel® oneAPI or Intel® Parallel Studio XE installed on that system

We would like to know.

0 Kudos

Hello Arpan


Like EduOak's long and detailed description of problems similar to my own (and numerous other commenters here, plus who knows how many others who didn't post about their experiences), this problem began for me back in February. I have followed multiple steps, as advised, uninstalled and reinstalled VS2019 and VS2022 and oneAPI. The integration with VS breaks it every time. I even (semi)manually removed every reference to oneAPI left over in the registry after uninstalling it. Same result.


Until Intel engineers work more closely with Microsoft's VS team on this integration issue, I have little incentive to spend more time on this.


Windows 10 build 19044

VS2022 17.4.0 (but same problems found with earlier versions)

VS2019 16.11.21 (but same problems found with earlier versions)

0 Kudos

correction, Intel developers, not engineers

0 Kudos

I have been facing a similar issue.

Please don't refer me to Known Microsoft* Visual Studio 2022 and oneAPI Toolkits Installation Issue or Accepted Solution links because neither of them are really a solution.

Here are the steps I've followed in my latest try.

1. Install Windows 10 - Yes, the lack of solution for this issue made start from that point : (


2. Install Visual Studio Enterprise 2022 (v17.4.0)


3. (Try to) Install w_BaseKit_p_2022.3.1.19798_offline


Please notice in all the above steps it was performed a clean/fresh installation for everything. No previous version of anything was installed in the system.

Also, for Windows, after installing it from the scratch, I made sure all the updates from MSFT were also installed, so the Windows is very very updated.

System Information:

Processor Intel(R) Xeon(R) CPU E5-2699 v4 @ 2.20GHz 2.20 GHz
Installed RAM 128 GB
Device ID 4F7DA497-A11C-4CD5-A32A-95C297211E7D
Product ID 00330-80000-00000-AA874
System type 64-bit operating system, x64-based processor

Now, I've tried two different scenarios.

1. Install oneAPI Base Toolkit WITHOUT VS2022 integration.


This scenario WORKS and all the packages are installed with no errors. Of course, in this case I have no access to oneAPI from VS2022.


2. With oneAPI Base Toolkit already installed in the system, I re-run the toolkit installer, select Add/Remove Components and 

CHECKED VS2022 integration. Here is where the issue occurs.



Log file is attached.

I am assuming at this point you guys have already realized all these issues people have been reported during this entire year is related to VS2022 integration, and not the Base Toolkit installer itself. So, here is my suggestion: as I said, Base Toolkit installer runs smoothly whenever VS2022 IDE integration option is unchecked. Isolating the issue is the first step to get it fixed, so instead of referring people to uninstall, re-install, repair, etc, why don't you guys just create a separated script/program/installer/whatever that just runs the VS2022 integration part. 

You would save people a lot of time in this useless re-doing everything and would have a much better understanding about this particular issue.

I hope this information helps and a fix can be provided as soon as possible, because I've seen people having problems since the Toolkit v2022.* have been released, and also because it is sad such a promising tool can't be widely used just because an integration issue can't be fixed.

Thanks for any help you can provide.

0 Kudos

Mark, we found it to be an issue related to a DLL file in the VS2022 install.


You can back up and substitute Microsoft.VisualStudio.Setup.Configuration.Native.dll by the similar library from Microsoft Visual Studio 2019 for the time of installation, modification, or uninstallation of Intel® oneAPI or Intel® Parallel Studio XE products, and then move the original one back.


The path to the .dll file is> C:\ProgramData\Microsoft\VisualStudio\Setup\x86\Microsoft.VisualStudio.Setup.Configuration.Native.dll


Note that this library is being upgraded by Microsoft Visual Studio, so if Microsoft Visual Studio 2022 has ever been installed, the library will most likely be of the new (problematic) version. You need a clean machine to obtain the older version of the library by installing Microsoft Visual Studio 2019.


We tried to collect information of what DLL version cause issues and which do not. When we were testing this solution, version 2.6.2111.5687 worked like a charm for us.


Visual Studio Version DLL Version Does it cause
Intel installer issues?
2019 File version: 2.6.2111.5687
Product Version: 2.6.2111+3716221855
2022 17.0.5 File version: 3.0.4492.23473
Product version: 3.0.4492+b15bd3af75
2022 17.1 File version: 3.1.1126.51066
Product version: 3.1.1126+7ac7de2fa0


Please share your findings with us.

0 Kudos

Hi @ArpanB_Intel ,


Here you have my tries:


1. The latest DLL actually installed with VS2022 - 17.4



2. An older DLL (same as you've mentioned above as being 2022 17.0.5 - File version: 3.0.4492.23473)



3. An even older DLL from the only VS2019 installation I have in another machine (which is not the same one you've mentioned above because I can't figured out how to get that exact one, so I just tried the one I have)



Here you have the result for all the 3 different DLLs:



In my opinion, suggesting people to dig the internet to find older DLLs version as well as recommending people to uninstall software versions and reinstall everything again might be consider as a quick troubleshooting while the real issue is fixed. However, this issue has been occurring since early this year and still there is no fix for it because instead of solving it there is only troubleshoot suggestions that actually don't work.

If MSFT has made changes in the such DLL, the oneAPI Base Toolkit installer developers should make the changes in the installer to be compatible to the new DLL instead of suggesting each users to replace it by an older one. That actually sounds like a joke, not a serious solution.

Anyways, I dare to say the issue is not the DLL at all. I've tried to integrate VS2022 - 17.4 + Intel oneAPI Base Toolkit 2022.3.1 in two different machines. It works fine in one of them and it is not working in the other. So, if the issue was the DLL it wouldn't have worked in any of them.

I really hope you guys can provide a real solution for this almost one year issue.


0 Kudos

Mark, thank you for sharing your valuable feedback with us. We will pass on the feedback to our internal team for further consideration.

Regarding the issue, please share the below information with us. We would need the following information to further investigate on your issue.


  1. List of installed Intel® software currently on your system: all versions of Intel® oneAPI and Intel® Parallel Studio XE.
  2. Versions of the C:\ProgramData\Microsoft\VisualStudio\Setup\x86\Microsoft.VisualStudio.Setup.Configuration.Native.dll before substitution on the problematic system with VS 2022.
  3. Versions of the C:\ProgramData\Microsoft\VisualStudio\Setup\x86\Microsoft.VisualStudio.Setup.Configuration.Native.dll on the clean machine with VS 2019 (or 2017) only.
  4. Exact versions of VS 2019 (or 2017) on the problematic and clean machine with their build version.
  5. Versions of the C:\ProgramData\Microsoft\VisualStudio\Setup\x86\Microsoft.VisualStudio.Setup.Configuration.Native.dll after substitution on the problematic system with VS 2022.
  6. All log files from the %TEMP%\intel_oneapi_installer after unsuccessful old product removal attempt with the substituted DLL.

0 Kudos

Thank you, Mark, EduOak, and others, for providing helpful information and recommendations. We are working with the Microsoft VS team to address this incompatibility issue and will provide updates soon. 

Please continue providing your system configurations (VS version, OS version,  oneAPI product version, etc.) and log files so we can narrow down the root causes if possible.

Thank you,
Ying S
Intel oneAPI Team

0 Kudos