oneAPI Registration, Download, Licensing and Installation
Support for Getting Started questions related to download, Installation and licensing for Intel oneAPI Toolkits and software development tools.
1350 Discussions

failed to install l_BaseKit_p_2022.2.0.262_offline.sh

jacpan
Beginner
1,610 Views

Resetting HOME makes installation move further but encountering an error:

 

/app/jacpan/intel $ export HOME=/app/jacpan/intel

~ $ ./l_BaseKit_p_2022.2.0.262_offline.sh -a -s --eula=accept --install-dir=/app/jacpan/intel

Extract l_BaseKit_p_2022.2.0.262_offline to /app/jacpan/intel/l_BaseKit_p_2022.2.0.262_offline...

[################################################################################################################################]

Extract l_BaseKit_p_2022.2.0.262_offline completed!

Checking system requirements...

Done.

Wait while the installer is preparing...

Done.

Launching the installer...

Intel® Graphics Compute Runtime for OpenCL™ not found.

You have no relevant GPU driver. If you are going to develop and run GPU-accelerated applications on this system, please check the                           installation guide for instructions on the GPU drivers here: https://www.intel.com/content/www/us/en/develop/documentation/instal                          lation-guide-for-intel-oneapi-toolkits-linux/top/prerequisites/install-intel-gpu-drivers.html

Otherwise, you can ignore the warning and continue the installation as is: the product can still be used with CPU.

Libnotify package is not installed

Intel® VTune(TM) Profiler requires Libnotify library for graphical user interface, it can be installed with

sudo apt-get install libnotify4 on Ubuntu / Debian

sudo zypper install libnotify4 on SUSE

sudo dnf install libnotify on CentOS / RHEL / Fedora

Start installation flow...

Installation of component has failed.

Component id: intel.oneapi.lin.python3, name: Intel® Distribution for Python*, version: 2022.1.0-214.

During the execution of the application '/app/jacpan/intel/intel/installercache/downloadcache/intel.oneapi.lin.python3,v=2022.1.0-                          214/exec_script.sh' with arguments '/app/jacpan/intel' errors were received:'    self._abc_registry = extra._abc_registry

AttributeError: type object 'Callable' has no attribute '_abc_registry'

'

Error: Sequence execution failed.

 

Installer completed with code 1

Log file: /tmp/jacpan/intel_oneapi_installer/2022.07.15.12.20.58.529/installer.install.intel.oneapi.lin.basekit.product,v=2022.2.0                          -262.2022.07.15.12.21.03.890119.log

Remove extracted files: /app/jacpan/intel/l_BaseKit_p_2022.2.0.262_offline...

0 Kudos
10 Replies
Soumya_M_Intel
Moderator
1,597 Views

Hi jacpan,


Thanks for posting your concern on the forum and providing us with the error details. Kindly let us know the complete name and version of the Linux operating system. It will allow us to look into the issue better. Looking forward to your update.


Regards,

Soumya


0 Kudos
jacpan
Beginner
1,594 Views

uname -srm
Linux 3.10.0-1160.62.1.el7.x86_64 x86_64


cat /etc/os-release
NAME="Red Hat Enterprise Linux Server"
VERSION="7.9 (Maipo)"
ID="rhel"
ID_LIKE="fedora"
VARIANT="Server"
VARIANT_ID="server"
VERSION_ID="7.9"
PRETTY_NAME="Red Hat Enterprise Linux"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:redhat:enterprise_linux:7.9:GA:server"
HOME_URL="https://www.redhat.com/"
BUG_REPORT_URL="https://bugzilla.redhat.com/"

REDHAT_BUGZILLA_PRODUCT="Red Hat Enterprise Linux 7"
REDHAT_BUGZILLA_PRODUCT_VERSION=7.9
REDHAT_SUPPORT_PRODUCT="Red Hat Enterprise Linux"
REDHAT_SUPPORT_PRODUCT_VERSION="7.9"

0 Kudos
Soumya_M_Intel
Moderator
1,571 Views

Hi jacpan,


Thanks for sharing the requested information on the thread. Kindly try installing bzip2 and trying again. Our engineers' team has documented a known issue with the Intel® Distribution for Python 2022.1 i.e. installation may fail because of missing pkgs/python errors. The workaround to it requires bzip2 to be present.


You may visit the below link for reference.


Link: https://www.intel.com/content/www/us/en/developer/articles/troubleshooting/python-known-issues.html


Please feel free to let us know if the issue persists. Kindly update us if it has been resolved. Looking forward to your response on the thread.

 

Hope you have a wonderful day ahead!


Regards,

Soumya


0 Kudos
jacpan
Beginner
1,562 Views

thanks Soumya

 

still failed with the same error after following yoursteps:

 

downloaded bzip2 from below line

 http://anduin.linuxfromscratch.org/LFS/bzip2-1.0.6.tar.gz

 

~ $ pwd
/app/jacpan/intel
~ $ which bzip2
/bin/bzip2

 

~ $ ./l_BaseKit_p_2022.2.0.262_offline.sh -a -s --eula=accept --install-dir=/app/jacpan/intel
Extract l_BaseKit_p_2022.2.0.262_offline to /app/jacpan/intel/l_BaseKit_p_2022.2.0.262_offline...
[#############################################################################################################]
Extract l_BaseKit_p_2022.2.0.262_offline completed!
Checking system requirements...
Done.
Wait while the installer is preparing...
Done.
Launching the installer...
Libnotify package is not installed
Intel® VTune(TM) Profiler requires Libnotify library for graphical user interface, it can be installed with
sudo apt-get install libnotify4 on Ubuntu / Debian
sudo zypper install libnotify4 on SUSE
sudo dnf install libnotify on CentOS / RHEL / Fedora
Intel® Graphics Compute Runtime for OpenCL™ not found.
You have no relevant GPU driver. If you are going to develop and run GPU-accelerated applications on this system, please check the installation guide for instructions on the GPU drivers here: https://www.intel.com/content/www/us/en/develop/documentation/installation-guide-for-intel-oneapi-toolkits-linux/top/prerequisites/install-intel-gpu-drivers.html
Otherwise, you can ignore the warning and continue the installation as is: the product can still be used with CPU.
Start installation flow...
Installation of component has failed.
Component id: intel.oneapi.lin.python3, name: Intel® Distribution for Python*, version: 2022.1.0-214.
During the execution of the application '/app/jacpan/intel/intel/installercache/downloadcache/intel.oneapi.lin.python3,v=2022.1.0-214/exec_script.sh' with arguments '/app/jacpan/intel' errors were received:' self._abc_registry = extra._abc_registry
AttributeError: type object 'Callable' has no attribute '_abc_registry'
'
Error: Sequence execution failed.

Installer completed with code 1
Log file: /tmp/jacpan/intel_oneapi_installer/2022.07.18.18.32.40.348/installer.install.intel.oneapi.lin.basekit.product,v=2022.2.0-262.2022.07.18.18.32.53.435079.log
Remove extracted files: /app/jacpan/intel/l_BaseKit_p_2022.2.0.262_offline...

0 Kudos
Soumya_M_Intel
Moderator
1,556 Views

Hi jacpan,


Thanks for letting us know the bzip2 version and providing us with the output. However, kindly note that bzip2 version 1.0.8 is the current stable version (released three years ago). Please give it a try with this version. It will allow us to eliminate any possibilities of concern with bzip2 and allow us to check on the issue better.


Looking forward to your findings.


Regards,

Soumya


0 Kudos
jacpan
Beginner
1,544 Views

 bzip2 version 1.0.8 is applied but still the same issue

/app/jacpan/intel $ pwd
/app/jacpan/intel
/app/jacpan/intel $ which bzip2
/app/jacpan/intel/bzip2-1.0.8/bzip2
/app/jacpan/intel $ /app/jacpan/intel/bzip2-1.0.8/bzip2 -V
bzip2, a block-sorting file compressor. Version 1.0.8, 13-Jul-2019.

Copyright (C) 1996-2019 by Julian Seward.

This program is free software; you can redistribute it and/or modify
it under the terms set out in the LICENSE file, which is included
in the bzip2 source distribution.

This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
LICENSE file for more details.

bzip2: I won't write compressed data to a terminal.
bzip2: For help, type: `bzip2 --help'.
/app/jacpan/intel $ export HOME=/app/jacpan/intel
~ $ ./l_BaseKit_p_2022.2.0.262_offline.sh -a -s --eula=accept --install-dir=/app/jacpan/intel
Extract l_BaseKit_p_2022.2.0.262_offline to /app/jacpan/intel/l_BaseKit_p_2022.2.0.262_offline...
[#############################################################################################################]
Extract l_BaseKit_p_2022.2.0.262_offline completed!
Checking system requirements...
Done.
Wait while the installer is preparing...
Done.
Launching the installer...
Libnotify package is not installed
Intel® VTune(TM) Profiler requires Libnotify library for graphical user interface, it can be installed with
sudo apt-get install libnotify4 on Ubuntu / Debian
sudo zypper install libnotify4 on SUSE
sudo dnf install libnotify on CentOS / RHEL / Fedora
Intel® Graphics Compute Runtime for OpenCL™ not found.
You have no relevant GPU driver. If you are going to develop and run GPU-accelerated applications on this syste m, please check the installation guide for instructions on the GPU drivers here: https://www.intel.com/content/ www/us/en/develop/documentation/installation-guide-for-intel-oneapi-toolkits-linux/top/prerequisites/install-in tel-gpu-drivers.html
Otherwise, you can ignore the warning and continue the installation as is: the product can still be used with C PU.
Start installation flow...
Installation of component has failed.
Component id: intel.oneapi.lin.python3, name: Intel® Distribution for Python*, version: 2022.1.0-214.
During the execution of the application '/app/jacpan/intel/intel/installercache/downloadcache/intel.oneapi.lin. python3,v=2022.1.0-214/exec_script.sh' with arguments '/app/jacpan/intel' errors were received:' self._abc_r egistry = extra._abc_registry
AttributeError: type object 'Callable' has no attribute '_abc_registry'
'
Error: Sequence execution failed.

Installer completed with code 1
Log file: /tmp/jacpan/intel_oneapi_installer/2022.07.20.08.05.31.129/installer.install.intel.oneapi.lin.basekit .product,v=2022.2.0-262.2022.07.20.08.05.36.398981.log
Remove extracted files: /app/jacpan/intel/l_BaseKit_p_2022.2.0.262_offline...

0 Kudos
Soumya_M_Intel
Moderator
1,538 Views

Hi jacpan,


Thanks for the prompt response on the thread. Based on it, we are checking on the concern with our internal team. Kindly wait for 2-3 business days. We will get back to you as soon as we have an update regarding it.


Regards,

Soumya


0 Kudos
Soumya_M_Intel
Moderator
1,410 Views

Hi jacpan,


Thanks for your patience while we were checking with our higher team. They have recently got back to us with the below query regarding the issue.


Therefore, kindly let us know if you require the Intel® Distribution for Python component in the Intel® oneAPI Base Toolkit toolkit for your project. If not, you may unselect the component and try installing the toolkit.


Please let us know if the issue persists. Feel free to get back to us even if the component is required for use. We would be glad to assist you.


Looking forward to your update.


Regards,

Soumya


0 Kudos
Soumya_M_Intel
Moderator
1,400 Views

Hi jacpan,


Kindly let us know the requested information and if the issue persists even after trying the provided workaround. It will allow us to assist you better.


Regards,

Soumya


0 Kudos
Soumya_M_Intel
Moderator
1,372 Views

Hi jacpan,


We understand that you might be looking into the issue. However, this is to update you that we have not heard from you on our previous responses. Please reply within the next 24 business hours to keep this thread active.

 

Regards,

Soumya


0 Kudos
Reply