oneAPI Registration, Download, Licensing and Installation
Support for Getting Started questions related to download, Installation and licensing for Intel oneAPI Toolkits and software development tools.

old version of OneAPI for students

wu__zhiyi
Beginner
1,598 Views

I'm a student user who used to enjoy free parallel studio of a specific version of the Intel compiler.

Recently, my yearly licence has expired and I tried to renew my licence. However, it seems that the new OneApi doesn't allow me to choose a specific version of intel compiler. Notably, the current intel compiler will not support CUDA, which is a big problem.

0 Kudos
1 Solution
ArpanB_Intel
Moderator
1,502 Views

Zhiyi, 19.1 is Intel® Parallel Studio XE 2020. However, to install it you would need a license. Since we have stopped generating free licenses anymore since the transition of Intel® Parallel Studio XE to Intel® oneAPI. you would have to purchase a license. Please visit this link: https://software.intel.com/content/www/us/en/develop/tools/resellers.html, to contact your nearest re-sellers to purchase a license.


View solution in original post

0 Kudos
3 Replies
ArpanB_Intel
Moderator
1,537 Views

Hi Zhiyi, the current oneAPI compiler version is 2021.1 or 2021.2. If you want to use an older version of the compiler you would require the legacy software of Intel® Parallel Studio XE. Could you specify which version of the compiler you are looking for?


0 Kudos
wu__zhiyi
Beginner
1,514 Views

Thank you for the reply.

I used to have the licence for Intel® Parallel Studio but since it is a student licence, it has now expired.

According to the cuda documentation (https://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html). The latest intel compiler that is supported is 19.1 

0 Kudos
ArpanB_Intel
Moderator
1,503 Views

Zhiyi, 19.1 is Intel® Parallel Studio XE 2020. However, to install it you would need a license. Since we have stopped generating free licenses anymore since the transition of Intel® Parallel Studio XE to Intel® oneAPI. you would have to purchase a license. Please visit this link: https://software.intel.com/content/www/us/en/develop/tools/resellers.html, to contact your nearest re-sellers to purchase a license.


0 Kudos
Reply