oneAPI Registration, Download, Licensing and Installation
Support for Getting Started questions related to download, Installation and licensing for Intel oneAPI Toolkits and software development tools.
1350 Discussions

one api base tool kit fails to install

hpc_admin1
Beginner
3,278 Views

I'm trying to install the one api base toolkit 2021.3.0.3219 as root on a redhat 7.9 server. I've tried the local and web installers and they both give the same error.

# ./l_BaseKit_p_2021.3.0.3219.sh -a -c

"Critical Pre-requisites: (Must be resolved before Installation can begin) Another program is being installed. Wait until that installation is complete, and then try installing this software again."

 

I tried using the installer to remove the old beta toolkit and that failed as well. I then followed the highlighted box in the installation guide "NOTE Manual removal of the installation folder ...". I cleaned out /var/intel/installercache/ and /opt/intel/oneapi/installer and looked under /root. There is still /opt/intel/licenses/ where the Intel compiler licence lives. I removed a bunch of files belonging to the failed install of the beta toolkit in /var/intel.

The base kit still refuses to install giving the same message about another program being installed.

Does anyone know how clear any remaining old one api state and do a clean install of the latest toolkit?

0 Kudos
1 Solution
Dilanjan_J_Intel
Moderator
3,249 Views

Hi hpc_admin1, 


Thanks for posting your query on the community forum. I would suggest you try the steps given in the below link to uninstall the product properly. You will also find the steps to install the Intel® OneAPI toolkits correctly.


Link - https://software.intel.com/content/www/us/en/develop/documentation/installation-guide-for-intel-oneapi-toolkits-linux/top/uninstall-oneapi-toolkits-and-components.html


Important Note - Make sure to restart your system.


Try the steps and let us know if your issue persists. Have a pleasant day ahead!


Regards,

Dilanjan



View solution in original post

0 Kudos
5 Replies
Dilanjan_J_Intel
Moderator
3,250 Views

Hi hpc_admin1, 


Thanks for posting your query on the community forum. I would suggest you try the steps given in the below link to uninstall the product properly. You will also find the steps to install the Intel® OneAPI toolkits correctly.


Link - https://software.intel.com/content/www/us/en/develop/documentation/installation-guide-for-intel-oneapi-toolkits-linux/top/uninstall-oneapi-toolkits-and-components.html


Important Note - Make sure to restart your system.


Try the steps and let us know if your issue persists. Have a pleasant day ahead!


Regards,

Dilanjan



0 Kudos
hpc_admin1
Beginner
3,233 Views

Hi,

 

Thanks for the reply!

Important Note - Make sure to restart your system.

Unfortunately, this is a server in a HPC system, so our next install attempt would have to wait for the next scheduled facility downtime. Is there any way to avoid taking a downtime? This is a  redhat enterprise 7.9 system. Where is the stale install state stored other than /opt/intel or /var/intel?

0 Kudos
Dilanjan_J_Intel
Moderator
3,203 Views

Hi hpc_admin1,


Thanks for getting back to us. We have sent a Private message requesting further information. Please respond directly to the private message as it may involve sensitive information.


Have a pleasant day ahead!


Regards,

Dilanjan


0 Kudos
Dilanjan_J_Intel
Moderator
3,127 Views

Hi hpc_admin1,


Feel free to get back to us with the requested information through the direct Private message as it may contain sensitive information.


Have a pleasant day ahead!


Regards,

Dilanjan


0 Kudos
Dilanjan_J_Intel
Moderator
3,086 Views

Hi hpc_admin1,


Since we haven't heard from you in a while. We will be closing this thread. Please feel free to post a new question for more information as this thread will be no longer monitored by Intel®.


Have a pleasant day ahead!


Regards,

Dilanjan.



0 Kudos
Reply