oneAPI Registration, Download, Licensing and Installation
Support for Getting Started questions related to download, Installation and licensing for Intel oneAPI Toolkits and software development tools.

oneAPI Installation errors

shraddha10
Beginner
1,745 Views

Hello Team,

 

I am facing issues while installing oneAPI Base Toolkit on our HPC cluster? Attached the error message in the files section. Could someone please guide me?

 

Thank You

Shraddha

0 Kudos
1 Solution
Soumya_M_Intel
Moderator
1,679 Views

Hi shraddha10,

 

Thanks for re-sending the log file. This time we could open and check it. Based on it, we would recommend checking on the below situations (that may have caused the error), their resolutions and trying the installation again.

 

• Corrupted installer database - Make sure there is no file packagemanager.db in $home/intel/installercache (user install) or /var/intel/installercache (root install) before installation

 

• No free space to create (or update) database - Check space in $home/intel/installercache (user install) or /var/intel/installercache (root install)

 

• No write permissions in the paths mentioned above.

 

However, if all the above parameters are already met and still the issue persists, please let us know if Eclipse is currently installed on the system. If yes, please also let us know its version. Looking forward to your response.

 

Regards,

Soumya

 

View solution in original post

0 Kudos
7 Replies
Soumya_M_Intel
Moderator
1,734 Views

Hi shraddha10,


Thanks for posting your concern on the forum. To understand the issue better, we would require the below details.

 

  • The complete name and version of the operating system
  • The installation log (mentioned in the screenshot)


Looking forward to your findings. Have a nice day ahead.

 

Regards,

Soumya


0 Kudos
shraddha10
Beginner
1,723 Views

Hi Soumya,

Posting your answers below:

  • The complete name and version of the operating system

AME="Red Hat Enterprise Linux Server"
VERSION="7.6 (Maipo)"
ID="rhel"
ID_LIKE="fedora"
VARIANT="Server"
VARIANT_ID="server"
VERSION_ID="7.6"
PRETTY_NAME="Red Hat Enterprise Linux"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:redhat:enterprise_linux:7.6:GA:server"
HOME_URL="https://www.redhat.com/"
BUG_REPORT_URL="https://bugzilla.redhat.com/"

REDHAT_BUGZILLA_PRODUCT="Red Hat Enterprise Linux 7"
REDHAT_BUGZILLA_PRODUCT_VERSION=7.6
REDHAT_SUPPORT_PRODUCT="Red Hat Enterprise Linux"
REDHAT_SUPPORT_PRODUCT_VERSION="7.6"

 

  • The installation log (mentioned in the screenshot)  

Attached

 

 

 

 

0 Kudos
Soumya_M_Intel
Moderator
1,709 Views

Hi shraddha10,


Thanks for getting back to us with the details. However, the download of the installation log is failing with a 'forbidden' error. We have tried to download it in different ways. However, it's the same every time. Kindly attach and resend it. Looking forward to your update.


Regards,

Soumya


0 Kudos
shraddha10
Beginner
1,702 Views

Hello Soumya,

 

Attaching the logs again

 

Regards

Shraddha 

0 Kudos
Soumya_M_Intel
Moderator
1,680 Views

Hi shraddha10,

 

Thanks for re-sending the log file. This time we could open and check it. Based on it, we would recommend checking on the below situations (that may have caused the error), their resolutions and trying the installation again.

 

• Corrupted installer database - Make sure there is no file packagemanager.db in $home/intel/installercache (user install) or /var/intel/installercache (root install) before installation

 

• No free space to create (or update) database - Check space in $home/intel/installercache (user install) or /var/intel/installercache (root install)

 

• No write permissions in the paths mentioned above.

 

However, if all the above parameters are already met and still the issue persists, please let us know if Eclipse is currently installed on the system. If yes, please also let us know its version. Looking forward to your response.

 

Regards,

Soumya

 

0 Kudos
shraddha10
Beginner
1,595 Views

Hello Soumya,

 

I was able to successfully install oneapi base tool kit after implementing your above suggestions. Thank you!

However, I have another question,

1. could you tell me if there's an option to install oneapi base tool kit and hpc tool kit using config file?

2. If so, how to export installation configuration to a config file?

3. Is it possible to use one config file for both base and hpc tool kit?

 

 

Regards,

Shraddha 

0 Kudos
ArpanB_Intel
Moderator
1,584 Views

Shraddha, thank you for sharing the confirmation with us. We are glad that the issue is resolved.


We have created a new issue to handle your new query. This thread will no longer be monitored by Intel®.


0 Kudos
Reply