oneAPI Registration, Download, Licensing and Installation
Support for Getting Started questions related to download, Installation and licensing for Intel oneAPI Toolkits and software development tools.
1350 Discussions

oneAPI MKL 2022.2.1 installation on Ubuntu 18.04 LTS

Martin__Paul
New Contributor I
1,649 Views

Hi, I am trying to install MKL on Ububtu 18.04 via apt-get but am presented with a dependency error:

l_onemkl_p_2022.2.1.16993_offline$ sudo sh ./install.sh
/MKL/l_onemkl_p_2022.2.1.16993_offline/bootstrapper: error while loading shared libraries: libQt6Core5Compat.so.6: cannot open shared object file: No such file or directory

How can I proceed here?  The installation notes state 18.04 LTS is supported.  Is there a non-GUI install I can try to bypass the need for speciic Qt libraries?

Thanks. 

0 Kudos
1 Solution
Martin__Paul
New Contributor I
1,593 Views

Worked around this by using the online installer and launching as sudo from the root usr folder.  Original issue not helped by using an Ububtu VM with host-mapped drives leading to permissions problems that sometimes manifest as other issues.

View solution in original post

0 Kudos
2 Replies
Martin__Paul
New Contributor I
1,594 Views

Worked around this by using the online installer and launching as sudo from the root usr folder.  Original issue not helped by using an Ububtu VM with host-mapped drives leading to permissions problems that sometimes manifest as other issues.

0 Kudos
ArpanB_Intel
Moderator
1,584 Views

Hi Paul, thank you for sharing workaround with us. We are glad that the issue was resolved.


If you have any further queries, please post a new question as this thread will no longer be monitored by Intel®.


0 Kudos
Reply