oneAPI Registration, Download, Licensing and Installation
Support for Getting Started questions related to download, Installation and licensing for Intel oneAPI Toolkits and software development tools.
1355 Discussions

oneAPI & Intelpython error - run permission as user denied but as admin, works!

hari_muc
Beginner
5,448 Views

Hello,
I installed oneAPI Base Toolkit (w_BaseKit_p_2022.2.0.252_offline.exe) on Windows 10 recently.  As per the 'Getting Started' guide for Intel Distribution for Python (idp), we need to install a conda environment for idp to begin using it.
Here are the problems:

1. I cannot seem to be able to run python or conda on command line mode from Powershell & cmd. It says access denied due to insufficient permissions (see attachment, in German).

2. But I am able to run the two in cl mode when I start a Powershell as administrator.

3. Installer always asks for admin password to continue installation

4. Installer does not provide an option on the lines of 'install for all users'

5. Default install location is C:\Program Files (x86)\Intel\oneAPI.
But I tried uninstalling and reinstalling in C:\Intel\oneAPI   &  C:\Users\user_name\Intel\oneAPI
I still get the same error when trying to run intelpython.

6. Env vars are set by calling setvars.bat on startup.

7. Path env var has location of python (i.e.
C:\Program Files (x86)\Intel\oneAPI\intelpython\python3.9\
C:\Program Files (x86)\Intel\oneAPI\intelpython\python3.9\Scripts &
C:\Program Files (x86)\Intel\oneAPI\intelpython\python3.9\Library\bin)

8. I also tried maually changing permissions of the folders & sub-folders on the installed path. That doesn't help either.

 

Is it a common bug? Can you please suggest a way around this?

0 Kudos
1 Solution
Huiyan_C_Intel
Moderator
4,870 Views

Hi hari_muc,

  1. On Windows, Intel oneAPI base toolkit can only be installed and run as administrator at the time being, we will check to see if it is possible to give an option that administrator privilege is not needed on Windows. Will update here when we get the answer.
  2. If you want to use Intel Distribution for Python without administrator privilege, please try installing via conda which I suggested above! Here, I mean you download and install a new anaconda (or miniconda) following steps here: https://conda.io/projects/conda/en/latest/user-guide/install/windows.html, which provides an option to Install for Just Me, and then you can create a new environment and install intelpython_full using this new installed conda instead of using conda from oneAPI base toolkit.



View solution in original post

0 Kudos
20 Replies
JaideepK_Intel
Moderator
5,405 Views

Hi,

 

Thank you for posting in Intel communities.

 

Sorry, we were unable to reproduce your issue, but there is a workaround.

Please follow these steps in command prompt:

1. Open File Explorer and navigate to the installation directory of the base toolkit.

example: C:\Program Files (x86)\Intel\oneAPI (default path)

 

2. Open the Intel python directory and there you will see the python3.9 directory. Inside the python3.9 directory, you can find condabin and copy that path.

example: C:\Program Files (x86)\Intel\oneAPI\intelpython\python3.9\condabin

 

3. In Windows search (left-bottom search), search for Edit the system environment variables. At the bottom, click on Environment Variables->System Variables->Path and click on Edit...

JaideepK_Intel_0-1662633091827.png

JaideepK_Intel_1-1662633230763.png

 

4. Now click on new and paste the copied path. Now open a command prompt and run the below commands.

 

conda activate
python

 

JaideepK_Intel_2-1662633477920.png

 

If this resolves your issue, make sure to accept this as a solution. This would help others with similar issue. Thank you!

 

Regards,

Jaideep

 

 

 

 

0 Kudos
hari_muc
Beginner
5,386 Views

Hello Jaideep,
Thanks for the reply. But it didn't work. It's still complaining about the same 'denied permissions' (see attachment)
The fact that most softwares/IDEs tend to have an 'Install for all users' option but oneAPI doesn't is unfortunate.
I have already tried all options on my side, even tried re-installing multiple times. The error is always about the user not having run permissions.

 

Could you please suggest any other way aroun?

regards,

Hari

0 Kudos
JaideepK_Intel
Moderator
5,365 Views

Hi,

 

Could you please confirm that you are getting the same error in the command prompt? I assume I got the same error as you got in powershell. I have attached a screen shot for your reference. Please follow the above steps which I mentioned earlier in command prompt (cmd).

Please add the below path to the environment variables.

C:\Program Files (x86)\Intel\oneAPI\intelpython\python3.9\condabin

JaideepK_Intel_0-1662661573191.png

 

If this resolves your issue, make sure to accept this as a solution. This would help others with similar issue. Thank you!

 

Regards,

Jaideep

 

0 Kudos
hari_muc
Beginner
5,331 Views

Hello Jaideep,
I have followed the steps you have suggested. The error occurs on command prompt as well, as reported in my initial explanation when opening the case.
Only this time the error message was a lot less verbose than on powershell and it is in German, saying "Access denied". I have attached a screenshot.

I hope there is a way to fix this, since code development is fully stopped right now due to this problem.

Thank you

Regards,

Hari

0 Kudos
hari_muc
Beginner
5,235 Views

Hello Jaideep,
Were you able to find a clue why this problem is occuring? 

Meanwhile, I am using a non-configured laptop from work to try & see if this problem can be reproduced. And during this attempt at diagnostics, I found another problem with IntelPython during installation, which is reported in this ticket.

I followed the instruction from Intel to diagnose this second new problem. I have replied to the issue here. Once I can install the Base Toolkit first, I can check if the problem with run permissions is still there. 

Thank you.
Hari

0 Kudos
ArpanB_Intel
Moderator
5,227 Views

Srihari, could you source the setvars script located in the root of your oneAPI installation. For user access level authorization, the command is>


. ~/intel/oneapi/setvars.sh


By default, the Intel® oneAPI Base Toolkit is installed in the /opt/intel/oneapi folder, which requires root privileges to manage it. If you would like to bypass using root access to manage your conda environment, then you can clone your desired conda environment using the following command:


conda create --name usr_intelpython --clone base


Then activate your conda environment with the following command:


source activate usr_intelpython


0 Kudos
hari_muc
Beginner
5,221 Views

Hello Arpan,
Thanks for the reply.
So, the problem I'm having is only on Windows 10, not on Linux.
Sourcing the env vars works without issues on linux.

As mentioned in the description entered while opening this ticket, I have configured it to run setvars.bat during startup. So in the powershell, tba completion identifies conda & python. But it does not let me run as user for some reason.
It runs only in powershell sessions opened as admin, not otherwise, so

conda create --name usr_intelpython --clone base

Doesn't help as it simply says, "Access Denied" (in German, as OS is in German), with some extended debug info.
In cmd prompt, it simply says "Access Denied", that's it.
I have attached screenshots of the problem in the main ticket & in the comments above.

Regards,
Srihari

0 Kudos
ArpanB_Intel
Moderator
5,195 Views

Srihari, could you share the installation log files with us. The default path on Windows would be>

C:\Program Files (x86)\Intel\oneAPI\logs


We would like to know.


0 Kudos
hari_muc
Beginner
5,185 Views

Hello @ArpanB_Intel : I have attached the log file below. 

To test & find out if the permissions error is because of our company's internal windows configurations/permission settings, I tried installing the Base toolkit on a non-configured laptop, but there it wouldn't even install. 

 

The problem that it won't install seems to be common, with diagnostics in the instruction from Intel in a comment. I have replied to the issue there, uploaded the logs generated during installation with a lot more debug info. But it is on a different computer without any of our company-specific configurations.

If I can install the Base Toolkit on this other laptop first, then I can check if the problem with run permissions is still there. 

 

 

 

0 Kudos
ArpanB_Intel
Moderator
5,126 Views

Srihari, we have contacted you internally with some information. Please check your inbox for further updates.


0 Kudos
hari_muc
Beginner
5,040 Views

Hello @ArpanB_Intel :

Now I was trying to diagnose the bug due to permissions on Windows, as reported by me here. To find out what causes the permissions problem, I tried doing a clean install of Base toolkit on a new laptop with Windows 10. 

Now here, I get this "Sequence Execution Failed" error message during installation on Windows & the installation rolls back completely.

A similar issue was opened on 14th July, where I reported in the comments about having similar problem.

In a comment by your colleague @Roy_A_Intel, he suggests we provide certain logs created during installation. I have attached them here. Would you please mind taking a look at it?

Any help in resolving this issue will be greatly helpful.

Thank you.

Regards,
Hari

 

0 Kudos
TomWang_Intel
Employee
4,979 Views

hi hari_muc,

This is Tom from Intel.

Let me make sure we got your status exactly.

>> I installed oneAPI Base Toolkit (w_BaseKit_p_2022.2.0.252_offline.exe) on Windows 10 recently. As per the >> 'Getting Started' guide for Intel Distribution for Python (idp), we need to install a conda environment for idp to begin using it.

You installed w_BaseKit_p_2022.2.0.252_offline.exe successfuly. From the attched picutre, when you run python or conda, it failed, right?

Have you tried it with windows 'command prompt'?

​I set oneAPI environment "setvars.bat" on startup, it succeed to run conda and python.

While I set "setvars.bat" in power shell, I failed to run conda or python in power shell.


It seemed path setting does not take effects in power shell. I have to set path of conda and python path.

​>> Here are the problems:

​>> 1. I cannot seem to be able to run python or conda on command line mode from Powershell & cmd. It says access denied due to insufficient permissions (see attachment, in German).

>> 2. But I am able to run the two in cl mode when I start a Powershell as administrator.

>> 3. Installer always asks for admin password to continue installation

I tried it with 'command prompt', it worked.

BTW, I am user of administraor group. Is your user acount of administrator group?

>> 4. Installer does not provide an option on the lines of 'install for all users'

Could identify which one you installed? "one API base toolkit"?

No, there is no options.

>> 5. Default install location is C:\Program Files (x86)\Intel\oneAPI.

>> But I tried uninstalling and reinstalling in C:\Intel\oneAPI  & C:\Users\user_name\Intel\oneAPI

>> I still get the same error when trying to run intelpython.

If you installed on "C:\Program Files (x86)\\Intel\oneAPI" or "C:\Intel\oneAPI", we suppose you need to run as administrator.

We suppose if it is installed on "C:\Users\user_name\Intel\oneAPI", is should be run without input administrator passwrd (even for users not in administrator group). I'll verify if this works as we expected.

Could you tried it with windows "command prompt" and feedback? Thank you!

Br,​

Tom



0 Kudos
hari_muc
Beginner
4,885 Views

Hallo @TomWang_Intel :
To answer your questions


You installed w_BaseKit_p_2022.2.0.252_offline.exe successfuly. From the attched picutre, when you run python or conda, it failed, right?

Have you tried it with windows 'command prompt'?

 

It seemed path setting does not take effects in power shell. I have to set path of conda and python path.​


I tried running it as normal user (not in administrator group) on powershell & cmd (command prompt), & it doesn't run. The usual user account from which development will happen is not going to be in the administrator group.
I have set python, python scripts & libs location into the PATH environment variable, & from powershell it shows on Tab-based auto-complete. So that's working & is not posing a problem.

 


Could identify which one you installed? "one API base toolkit"?

No, there is no options.

 

If you installed on "C:\Program Files (x86)\\Intel\oneAPI" or "C:\Intel\oneAPI", we suppose you need to run as administrator.

We suppose if it is installed on "C:\Users\user_name\Intel\oneAPI", is should be run without input administrator passwrd (even for users not in administrator group). I'll verify if this works as we expected.

Could you tried it with windows "command prompt" and feedback? Thank you!


I have tried installing both w_BaseKit_p_2022.2.0.252_offline.exe & w_BaseKit_p_2022.3.0.9573_offline.exe (available since 16th Sept). The problem persists with the 2022.3 version as well.

As I have quoted above in my explanation, I was able to run python & conda only as administrator on powershell & command prompt (cmd) regardless of whether the installation was in
C:\Program Files (x86)\Intel\oneAPI  OR 
C:\Intel\oneAPI  OR 
C:\Users\user_name\Intel\oneAPI..

 


>> 5. Default install location is C:\Program Files (x86)\Intel\oneAPI.

>> But I tried uninstalling and reinstalling in C:\Intel\oneAPI  & C:\Users\user_name\Intel\oneAPI

>> I still get the same error when trying to run intelpython.


 

0 Kudos
Huiyan_C_Intel
Moderator
4,978 Views

Hi,

 

We are investigating this issue. Meanwhile if you just want to make Intel Distribution for Python work at the time being, could you try install from conda instead:

let us know if it helps!

 

0 Kudos
Huiyan_C_Intel
Moderator
4,962 Views

Hi hari_muc,


Intel oneAPI base toolkit can only be installed and run as administrator, if you want to use Intel Distribution for Python without administrator privilege, please try installing via conda which I suggested above!


Please try and let us know if you face further issues!


0 Kudos
hari_muc
Beginner
4,885 Views

Hello @Huiyan_C_Intel : Thanks for the reply.

To quote your reply,

 


Intel oneAPI base toolkit can only be installed and run as administrator,


Does that mean we cannot use intel fortran, C++, MKL library & other tools in the basetoolkit without admin rights? All development in the company happens from a user profile (not in administrator group), without administrator rights.. This problem is only on Windows. In linux it works without any problems but not Linux cannot be used for all applications.

 


if you want to use Intel Distribution for Python without administrator privilege, please try installing via conda which I suggested above!

The problem is, even conda won't run without being logged in as administrator. Installing packages should require admin rights & that's understandable but to even run python or conda it not allowed from a user profile.

 

0 Kudos
Huiyan_C_Intel
Moderator
4,871 Views

Hi hari_muc,

  1. On Windows, Intel oneAPI base toolkit can only be installed and run as administrator at the time being, we will check to see if it is possible to give an option that administrator privilege is not needed on Windows. Will update here when we get the answer.
  2. If you want to use Intel Distribution for Python without administrator privilege, please try installing via conda which I suggested above! Here, I mean you download and install a new anaconda (or miniconda) following steps here: https://conda.io/projects/conda/en/latest/user-guide/install/windows.html, which provides an option to Install for Just Me, and then you can create a new environment and install intelpython_full using this new installed conda instead of using conda from oneAPI base toolkit.



0 Kudos
hari_muc
Beginner
4,852 Views

Hi @Huiyan_C_Intel :
Thanks for the clarification. Infact I don't want the Intel Base Toolkit to be able to run as user but even when it is run as administrator, if it can have an option like "Install for all users", that will also be helpful. But in my case, I can't even run python or conda as user.
In linux, conda works as user & anything installed with conda gets installed under the user home by default & it's cleanly managed there

 

The other important point is, there are lots of windows IDEs, compilers & development tools that ask for administrator credentials when installing but do allow users to run the application. If just this minor aspect can be corrected in the Intel toolkit, that would be amazing.

I will in the meanwhile try doing the conda installation method.. Thank you.

0 Kudos
hari_muc
Beginner
4,649 Views

Hi @Huiyan_C_Intel ,


Thanks for this suggestion.

After diagnosis of the problem with a trial laptop having no company-specific security configurations, we found out that our permission settings were the cause of the problem.

Installation still requires admin permissions or at least the user to be in the admin group. Otherwise it does not seem to work. It would be great if the installer let users not in the admin group also used the Toolkit, once it is installed. 

This intermediate suggestion you gave seems to work. Thank you you for the quick response. I request you to close this ticket now.

 

Regards,

Hari

0 Kudos
Huiyan_C_Intel
Moderator
4,742 Views

Hi hari_muc,


Thanks for your good feedback, we are evaluating your suggestion!


0 Kudos
Reply