oneAPI Registration, Download, Licensing and Installation
Support for Getting Started questions related to download, Installation and licensing for Intel oneAPI Toolkits and software development tools.
1349 Discussions

oneAPI installation in windows subsystem for linux

JesseHUT
Beginner
2,031 Views

Hi,

 

I have some trouble installing oneAPI Base Toolkit on windows subystem for linux (WSL) with Ubuntu 20.04LTS.

After the first window, the GUI does not work properly for me (or I don't know how to use it). I am not able to tab through the options as I need to advance the installation. Instead, it just tabs in the command window. Similarly Escape does work. By luck and guess work I managed to finish the installation. However, now I want to remove part of the installation I am again faced with the problem. I added some pictures to show you what I mean. 

What should I do differently?

0 Kudos
1 Solution
ArpanB_Intel
Moderator
1,984 Views

Hi Jesse, please click here> https://www.intel.com/content/www/us/en/developer/articles/system-requirements/intel-oneapi-base-toolkit-system-requirements.html, to check the minimum system requirements for Intel® oneAPI Base Toolkit.


Also note that, with Microsoft* Windows Subsystem for Linux 2 (WSL2), you can use native Linux distribution of Intel® oneAPI tools and libraries on Windows*. For more information on usage, refer here> https://www.intel.com/content/www/us/en/developer/articles/technical/use-oneapi-toolkits-on-wsl-2.html


View solution in original post

0 Kudos
3 Replies
ArpanB_Intel
Moderator
1,985 Views

Hi Jesse, please click here> https://www.intel.com/content/www/us/en/developer/articles/system-requirements/intel-oneapi-base-toolkit-system-requirements.html, to check the minimum system requirements for Intel® oneAPI Base Toolkit.


Also note that, with Microsoft* Windows Subsystem for Linux 2 (WSL2), you can use native Linux distribution of Intel® oneAPI tools and libraries on Windows*. For more information on usage, refer here> https://www.intel.com/content/www/us/en/developer/articles/technical/use-oneapi-toolkits-on-wsl-2.html


0 Kudos
JesseHUT
Beginner
1,973 Views

Hi ArpanB,

 

Thank you for your help! With WSL2 on Ubuntu 20.04 I managed to use the GUI properly.

0 Kudos
ArpanB_Intel
Moderator
1,966 Views

Jesse, thank you for confirming our solution. We are glad that the issue has been resolved.


If you have any further queries, please post a new question as this thread will no longer be monitored by Intel®.


0 Kudos
Reply