oneAPI Registration, Download, Licensing and Installation
Support for Getting Started questions related to download, Installation and licensing for Intel oneAPI Toolkits and software development tools.
1373 Discussions

why still have license issues after installed oneAPI?

LundJing
Beginner
918 Views

Hi, 

I had the student licensed ifort compiler before. A few days ago, I installed oneapi as my previous license is expired. I encountered the issue of expired  ifort license when trying to install netcdf with --enable-separte-fortran flag, although oneapi is free. I don't know how to solve the issue and I have checked a lot on the forum, and it did not give me any answer.
Here is the error message.
Error: A license for Comp-FL could not be obtained. (-1,359,2).

Is your license file in the right location and readable?
The location of your license file should be specified via
the $INTEL_LICENSE_FILE environment variable.

License file(s) used were (in this order):
** 1. /opt/intel/compilers_and_libraries_2019.3.199/linux/bin/intel64/../../Licenses
** 2. /home/xx/Licenses
** 3. /home/xx/intel/licenses
** 4. /opt/intel/licenses/*.lic
** 5. /Users/Shared/Library/Application Support/Intel/Licenses
** 6. /opt/intel/compilers_and_libraries_2019.3.199/linux/bin/intel64/*.lic

Please refer http://software.intel.com/sites/support/ for more information..

ifort: error #10052: could not checkout FLEXlm license
libtool: install: error: relink `libnetcdff.la' with the above command before installing it


looking forward to your reply. Really appreciated!
Jing

0 Kudos
1 Solution
Soumya_M_Intel
Moderator
867 Views

Hi LundJing,


Due to some technical glitch, we previously missed the update that you had provided on our end to close the thread, However, we are closing it now. Please feel free to create a new thread if there are any queries or concerns. Have a nice day ahead.


Regards,

Soumya


View solution in original post

0 Kudos
2 Replies
Soumya_M_Intel
Moderator
898 Views

Hi Jing,


That's quite odd. Intel® oneAPI Toolkit does not require a license to work. As a result, there should not be any Flexlm license checkout unless it is detecting the previous product suite's components. However, to understand the issue better we would require the below details:


  • Has there been a clean uninstallation of the Intel® Fortran Compiler (that was used with the expired license), from the system?
  • Have you found any old product components or libraries (that were used with the previous license) still installed on the system?
  • The version of the Ubuntu OS.
  • The previous product's version and update number


Looking forward to your findings. Have a safe and nice day ahead.


Regards,

Soumya


0 Kudos
Soumya_M_Intel
Moderator
868 Views

Hi LundJing,


Due to some technical glitch, we previously missed the update that you had provided on our end to close the thread, However, we are closing it now. Please feel free to create a new thread if there are any queries or concerns. Have a nice day ahead.


Regards,

Soumya


0 Kudos
Reply