Analyzers
Support for Analyzers (Intel VTune™ Profiler, Intel Advisor, Intel Inspector)
Announcements
Intel Customer Support will be observing the Martin Luther King holiday on Monday, Jan. 17, and will return on Tues. Jan. 18.
For the latest information on Intel’s response to the Log4j/Log4Shell vulnerability, please see Intel-SA-00646
4577 Discussions

How to run memory-access profiling in driverless mode

cutefisher
Novice
556 Views

Hi all,

How to run a memory-access profiling with a driveless mode?
First, i've tried to directly run memory-access using following cmd,

 

amplxe-cl -collect memory-access -target-pid `pidof mysqld` -r /tmp/xxx

 

Error to the screen is 

amplxe: Error: Cannot collect memory bandwidth data. Make sure the sampling driver is installed and enabled on your system. See the Sampling Drivers help topic for more details. Note that memory bandwidth collection is not possible if you are profiling inside a virtualized environment. 

Then, i've tried to install sampling drivers. However, it fails due to PAX load issue.

The PAX service is not loaded anymore.
Checking for PMU arbitration service (PAX) ... not detected.
Attempting to start PAX service ...
Executing: insmod ./pax/pax-x32_64-3.10.107-1-tlinux2-0054smp.ko
insmod: ERROR: could not insert module ./pax/pax-x32_64-3.10.107-1-tlinux2-0054smp.ko: Required key not available

I can not solve this issue. That's why i tried to use driverless mode by setting

 

echo 0 > /proc/sys/kernel/perf_event_paranoid

 

Still, it did not work after rerun 

 

amplxe-cl -collect memory-access -target-pid `pidof mysqld` -r /tmp/xxx

 

The error msg is the same as previous.

Could anyone tell me how to solve the Sampling Driver installation issue or How to use driverless mode to collect memory-access profiling ?

Best Regards

0 Kudos
6 Replies
Soumya_M_Intel
Moderator
539 Views

Hi cutefisher,


Thanks for posting your concern on the forum. Since your query is related to the Intel® VTune™ Profiler, we are moving this topic to the 'Analyzers' community for further assistance.


Have a nice day ahead.


Regards,

Soumya


AlekhyaV_Intel
Moderator
499 Views

Hi,

 

We will work on this issue internally and get back to you with an update. Regarding the driverless mode profiling, please refer this documentation: https://www.intel.com/content/www/us/en/develop/documentation/vtune-cookbook/top/configuration-recip.... Meanwhile we would like you to provide some information to us so that we can debug your issue further:

1) The sample reproducer so that we can try profiling on that application from our side.

2) Your OS details along with version.

3) List of drivers installed along with your VTune Profiler

4) Your VTune version.

5) Self checker logs

6) dmesg logs. Please run the analysis and after it fails, run the below command:

      dmesg > dmesg.log

please share the dmesg.log i.e. generated after running the above command.

 

We have a couple of suggestions for you too. Please check if the drivers are properly installed with the below steps:

1) In this path- cd /opt/intel/oneapi/vtune/latest/sepdk/src

sudo ./insmod-sep -q

2) Try building the drivers once again and check if it solves your issue.

./build-driver -r

 

If this answers your query, Please accept this as solution so that this helps others with similar issue. Thank you!

 

Regards,

Alekhya

 

cutefisher
Novice
490 Views

1) The sample reproducer so that we can try profiling on that application from our side.

amplxe-cl -collect memory-access -target-pid `pidof mysqld` -r /tmp/xxx

shows

Copyright (C) 2009-2019 Intel Corporation. All rights reserved.
Intel(R) VTune(TM) Amplifier 2019 (build 604197)
-bash-4.2$ amplxe-cl -collect memory-access -target-pid `pidof mysqld` -r /tmp/xxx
amplxe: Error: Cannot collect memory bandwidth data. Make sure the sampling driver is installed and enabled on your system. See the Sampling Drivers help topic for more details. Note that memory bandwidth collection is not possible if you are profiling inside a virtualized environment.
amplxe: Warning: Measuring peak bandwidth may be not accurate in the attach mode since the system can be heavily loaded at the time of the measurement. Accurate peak DRAM bandwidth is important for further analysis. When collection is done, check the Bandwidth Utilization Histogram on the Summary view and make sure the Low/Medium/High utilization thresholds are correct for your system and manually adjust them, if required.
-bash-4.2$

2) Your OS details along with version.

It's a Centos variation 3.10.107

3) List of drivers installed along with your VTune Profiler

No Sampling Driver installed due to install failure.

-bash-4.2$ ./insmod-sep -r -g georgezqiao
NOTE:  super-user or "root" privileges are required in order to continue.
Please enter "root" Password: 

Warning:  the following driver(s) were not found loaded in the kernel:  sep5.

Warning:  no vtsspp driver was found loaded in the kernel.

Warning:  the following driver(s) were not found loaded in the kernel:  socperf3.

The PAX service is not loaded anymore.
Checking for PMU arbitration service (PAX) ... not detected.
Attempting to start PAX service ...
Executing: insmod ./pax/pax-x32_64-3.10.107-0054smp.ko
insmod: ERROR: could not insert module ./pax/pax-x32_64-3.10.107-0054smp.ko: Required key not available

Error:  pax driver failed to load!

You may need to build pax driver for your kernel.
Please see the pax driver README for instructions.


Error: failed to start or connect to required PAX service

4) Your VTune version.

Linux-2019Update8

5) Self checker logs

Hangs in 

-bash-4.2$ sudo ./amplxe-self-checker.sh 
Intel(R) VTune(TM) Amplifier Self Check Utility
Copyright (C) 2009-2019 Intel Corporation. All rights reserved.
Build Number: 604197

6) dmesg logs. Please run the analysis and after it fails, run the below command:

     No dmesg here.

AlekhyaV_Intel
Moderator
465 Views

Hi,


From your OS details, we observe that CentOS 3* is not a supported operating system for VTune Profiler. We've provided the system requirements of VTune:https://www.intel.com/content/www/us/en/developer/articles/system-requirements/vtune-profiler-system...

We recommend you to use Vtune in any of the supported operating systems. You could try in Intel DevCloud as well. We have provided a VTune cookbook about how to use VTune in DevCloud for oneapi below: https://www.intel.com/content/www/us/en/develop/documentation/vtune-cookbook/top/configuration-recip...

If you're not a DevCloud user, please enroll here: https://devcloud.intel.com/oneapi/


Regards,

Alekhya


AlekhyaV_Intel
Moderator
379 Views

Hi,


Has the solution provided helped?

Could you please give us an update regarding this issue?


Regards,

Alekhya


AlekhyaV_Intel
Moderator
321 Views

Hi,


We assume that your issue is resolved. If you need any further assistance, please post a new question as this thread will no longer be monitored by Intel.


Regards,

Alekhya


Reply