Analyzers
Talk to fellow users of Intel Analyzer tools (Intel VTune™ Profiler, Intel Advisor)
5034 Discussions

Intel VTune started to crash: gh2::error::FailedTo.Process.The.Paramet

LukasT
Beginner
460 Views

I started to get crashes regularly in phase where VTune tries to resolve symbols. 

It happened after I updated my system, so maybe I suspect some conflict within environment.

WHat I tried: 
a) repair and reinstall w_oneapi_vtune_p_2024.1.0.520_offline

b) downgrade VTune to w_oneapi_vtune_p_2024.0.1.13_offline.exe

c) clean up local symbols cache completely (to avoid problems with corrupted symbols)


Nothing helped. 

 

[Exception]
Address: 0x00007ff98b5c19e7
Code: 0x00000000c0000005
CrashedPID: 25224
CrashedTID: 7092
Description: EXCEPTION_ACCESS_VIOLATION
Module: amplxe_msdia140.dll
Product: Intel(R) VTune(TM) Profiler 2024.0.1; 627177
ReportPath: C:\Users\Lukas\AppData\Local\Temp\amplxe-log-Lukas\2024-05-07-18-38-55-719.vtune-worker.exe\


[Process]
Process Name: vtune-worker.exe
Virtual Memory Size: 6100240K
Working Set Size: 1484552K

[Products]
Package ID: N/A
Package Contents: Intel(R) VTune(TM) Profiler 2024.0.1
Build Number: 627177

 

 

[PremortalLog]
334 [22232] ERROR cfgmgr <> - (outputBag != 0) && (inputBag != 0) && !m_ctx.is_null() 'gh2::error::FailedTo.Process.The.Parameter:'
vcs\cfgmgr2\src\rules.cpp(2020): process
, at file: vcs\cfgmgr2\src\rules.cpp:2020
367 [22232] ERROR cfgmgr <> - Errors happened during transformation
367 [22232] ERROR cfgmgr <> - %ThisAnalysisTypeIsNotApplicable
372 [22232] ERROR cfgmgr <> - Errors happened during transformation
372 [22232] ERROR cfgmgr <> - %ThisAnalysisTypeIsOnlyForLinux
377 [22232] ERROR cfgmgr <> - Errors happened during transformation
377 [22232] ERROR cfgmgr <> - %ThisAnalysisTypeIsNotApplicable
2250 [22232] ERROR cfgmgr <> - Cannot find context value: gpuL3SamplerThroughputAbsMaxValue., at file: vcs\cfgmgr2\src\rules.cpp:377
2250 [22232] ERROR cfgmgr <> - Cannot find context value: gpuL3ShaderThroughputAbsMaxValue., at file: vcs\cfgmgr2\src\rules.cpp:377
2250 [22232] ERROR cfgmgr <> - Cannot find context value: gpuL3_BYTE_READAbsMaxValue., at file: vcs\cfgmgr2\src\rules.cpp:377
2250 [22232] ERROR cfgmgr <> - Cannot find context value: gpuL3_BYTE_WRITEAbsMaxValue., at file: vcs\cfgmgr2\src\rules.cpp:377
2250 [22232] ERROR cfgmgr <> - Cannot find context value: gpuUntypedBytesReadAbsMaxValue., at file: vcs\cfgmgr2\src\rules.cpp:377
2250 [22232] ERROR cfgmgr <> - Cannot find context value: gpuUntypedBytesWrittenAbsMaxValue., at file: vcs\cfgmgr2\src\rules.cpp:377
2250 [22232] ERROR cfgmgr <> - Cannot find context value: gpuSlmBytesReadAbsMaxValue., at file: vcs\cfgmgr2\src\rules.cpp:377
2250 [22232] ERROR cfgmgr <> - Cannot find context value: gpuSlmBytesWrittenAbsMaxValue., at file: vcs\cfgmgr2\src\rules.cpp:377
2250 [22232] ERROR cfgmgr <> - Cannot find context value: gpuTypedBytesReadAbsMaxValue., at file: vcs\cfgmgr2\src\rules.cpp:377
2250 [22232] ERROR cfgmgr <> - Cannot find context value: gpuTypedBytesWrittenAbsMaxValue., at file: vcs\cfgmgr2\src\rules.cpp:377
2250 [22232] ERROR cfgmgr <> - Cannot find context value: gpuGtiReadThroughputAbsMaxValue., at file: vcs\cfgmgr2\src\rules.cpp:377
2250 [22232] ERROR cfgmgr <> - Cannot find context value: gpuGtiWriteThroughputAbsMaxValue., at file: vcs\cfgmgr2\src\rules.cpp:377
2250 [22232] ERROR cfgmgr <> - Cannot find context value: gpuGtiL3ThroughputAbsMaxValue., at file: vcs\cfgmgr2\src\rules.cpp:377
2250 [22232] ERROR cfgmgr <> - Cannot find context value: gpuHOST_TO_GPUMEM_BYTE_READAbsMaxValue., at file: vcs\cfgmgr2\src\rules.cpp:377
2250 [22232] ERROR cfgmgr <> - Cannot find context value: gpuHOST_TO_GPUMEM_BYTE_WRITEAbsMaxValue., at file: vcs\cfgmgr2\src\rules.cpp:377
2250 [22232] ERROR cfgmgr <> - Cannot find context value: gpuSYSMEM_BYTE_READAbsMaxValue., at file: vcs\cfgmgr2\src\rules.cpp:377
2250 [22232] ERROR cfgmgr <> - Cannot find context value: gpuSYSMEM_BYTE_WRITEAbsMaxValue., at file: vcs\cfgmgr2\src\rules.cpp:377
2250 [22232] ERROR cfgmgr <> - Cannot find context value: gpuSTACK_TO_STACK_RECEIVEAbsMaxValue., at file: vcs\cfgmgr2\src\rules.cpp:377
2250 [22232] ERROR cfgmgr <> - Cannot find context value: gpuSTACK_TO_STACK_TRANSMITAbsMaxValue., at file: vcs\cfgmgr2\src\rules.cpp:377
2251 [22232] ERROR dbinterface <> - addColumnV2(): Can't resolve (gpu_data, __bucket_idx): root table is not valid, at file: vcs\dbinterface1\src\sqlite\query.cpp:308
2251 [22232] ERROR dbiproviders <> - bucketIdx != dbi1::InvalidColIdx
vcs\dbiproviders1\src\rule_helpers.cpp(682): call
, at file: vcs\dbiproviders1\src\rule_helpers.cpp:682
2899 [22232] ERROR dicerresolver <> - gh2::is_success(err)
vcs\dicerresolver2\src\impl\resolver_impl.cpp(4593): load_settings
, at file: vcs\dicerresolver2\src\impl\resolver_impl.cpp:4593



Any suggestions what could help?

0 Kudos
8 Replies
yuzhang3_intel
Moderator
419 Views

Could you post the command line and attach the log file?

0 Kudos
LukasT
Beginner
370 Views

I execute the Intel VTune directly from MSVC IDE through the UI integration. I don't know the command line.


command.txt contains: 
C:\Program Files (x86)\Intel\oneAPI\vtune\2024.0\bin64

 

Windows 11: 
OS Name: Microsoft Windows 11 Pro
OS Version: 10.0.22631 N/A Build 22631


Log is attached. 


0 Kudos
yuzhang3_intel
Moderator
363 Views

Is the issue observed only from MSVC? Did you reproduce the issue from VTune directly?

0 Kudos
LukasT
Beginner
356 Views

Yes, also reproducible directly from the VTune GUI: 

 

LukasT_0-1715250120426.png

 

0 Kudos
yuzhang3_intel
Moderator
355 Views

Did you try to attach one simple process instead of the current process? Please attach the VTune data.

0 Kudos
LukasT
Beginner
326 Views

I'm able to profile c:\Qt\5.15.2\msvc2019_64\bin\qdbusviewer.exe just fine for example: 

LukasT_0-1715253026677.png


The Intel VTune symbol resolution process crashes only for our proprietary project. 

0 Kudos
yuzhang3_intel
Moderator
308 Views

Could you post the command line copied from the VTune GUI below? Please attach the VTune data if possible.

yuzhang3_intel_0-1715258101948.png

 

0 Kudos
LukasT
Beginner
272 Views

Hm...the bug is gone. I cannot reproduce it anymore.

I recalled I added symbols for nvidia recently: 
https://driver-symbols.nvidia.com/ 
but when I added it back it still does not crash. 

Command-line: 

"C:\Program Files (x86)\Intel\oneAPI\vtune\2024.0\bin64\vtune" -collect hotspots --app-working-dir=V:\build\product\ -- V:\build\product\bin\RelWithDebInfo\Milo-Product.exe

Not sure what happened, but the crash is not reproducible, I can profile again. 

0 Kudos
Reply