Ethernet Products
Determine ramifications of Intel® Ethernet products and technologies
4986 Discussions

Intel® Ethernet Connection I219-V and fiber

Kevin08
Beginner
462 Views

Hi,

I have an MSI Z20 Gaming Plus Motherboard with onboard Intel® Ethernet Connection I219-V and fiber. Drivers are up to date.

The speed should be 1 GB but when I do the Ookla speedcheck I come out between 600 and 700 Mbs.

Is this a driver issue?

I have these settings now that I found in this video, but surely it can't be that I have to start disabling the ipv6 protokol, as that results after certain time that some websites are no longer reachable.


0 Kudos
5 Replies
Sachinks
Employee
397 Views

Hello Kevin08,



Thank you for posting in Intel community Forum.


May I ask if the Ethernet Connection I219-V is a prebuilt card on the Motherboard or was it manually added later ? Also can you confirm which driver version is it on currently?


If you have questions, please let us know. Thank you.


Regards,

Sachin KS


0 Kudos
Kevin08
Beginner
388 Views

Hello,

The I219-V is a prebuilt card on the Motherboard with the latest drivers. 

connection

0 Kudos
Sazirah
Employee
358 Views

Hi Kevin08,


Thank you for your reply.


Regarding this issue, it most likely built-in with the MSI Z20 Gaming Plus Motherboard. You may try steps in the link below in regards to Intel Ethernet unable to reach gigabit speed:

Intel® Ethernet Connection I219-V Unable to Reach Gigabit Speed

https://www.intel.com/content/www/us/en/support/articles/000058667/ethernet-products/gigabit-ethernet-controllers-up-to-2-5gbe.html


Let us know the outcome.


Regards,

Sazzy_Intel


0 Kudos
Kevin08
Beginner
349 Views

Hi Sazzy,

I tried this already, but got the same result. When I apply these settings in combination with disabling IPV6, I can't access certain websites after a while. It's not only that I can't access websites, but also that streaming services don't work correctly.

Meanwhile, I borrowed a TP-Link card (TG-3468) from a friend, which works without any issue.

I assume it is really an Intel driver issue in combination with an MSI Z270 GAMING PLUS (MS7A75)


Best regards,

Kevin



  


0 Kudos
Sachinks
Employee
347 Views

Hello Kevin08,


Thank you for the update. We are sorry to know that you are still experiencing the issues.


Since this is a prebuilt I219-V ethernet card with MSI Z20 motherboard, may I know if you have tried contacting the OEM regarding this? As this is configured directly from their end, we request you to check with the OEM once regarding this.


Regards,

Sachin KS


0 Kudos
Reply