Ethernet Products
Determine ramifications of Intel® Ethernet products and technologies
4868 Discussions

intel network adapter issue causing game problem

ashish_singh
Beginner
1,457 Views

i got a msi motherboard model name pro z690-A wifi ddr4 comes with 

1x Intel® I225-V 2.5Gbps LAN controller                                                                                                    

i have installed all the drivers from msi website everything works fine atleast what i see , but the drivers provided by site or intel is causing me in game issues . so network doesnt drop or anything but its like my game is getting visual issues whenever i connect to multiplayer game its like network buffer or something, 

i play games like cs2(counter strike), apex legends and tried valorant to test the problem

every single has like offline maps in apex its firing range, in cs2 its practise maps, in valorant their is training map. these offline maps works without any problem my game crosshair movement is perfect but as soon as i jump in multiplayer game, competitive/ranked game. this visual thing like certain mouse movement is not accurate its very unplayable

i checked every single driver for faults or anything i could i am not developer or technical guy

i checked the event viewer i see bluetooth/wifi/ethernet showing some popups i have also checked in some thread of my motherboard one guy also having this issue in cod tell he getting bad ping spikes and the ethernet is causing him unplayable issue. i am posting the necessary screenshot i found during my observation. i have tried things from internet like reverting old driver, installing driver from intel support tool, nothing work at this point , the event viewer doesnt stop popping after every time device is configured. kindly fix this issue i dont want to return this motherboard . 

thanksdevice_manager.pngScreenshot 2024-02-20 153700.pngScreenshot 2024-02-20 153733.pngScreenshot 2024-02-20 153750.png

0 Kudos
15 Replies
Srri
Employee
1,386 Views

Hello Ashish,


Would like to suggest to do this Reset the network using Command Prompt 2 - 3 times repeatedly by following these steps and after reset please try to uninstall and install a fresh driver and try again.


1. Open Start.

2. Search for Command Prompt, right-click the top result, and select the Run as administrator option.

3. Type the following command to reset the component that handles network requests and press Enter:


netsh winsock reset


4. Type the following command to reset the internet protocol stack and press Enter:


netsh int ip reset


5. Type the following command to clear the current networking configuration and press Enter:


ipconfig /release


6. Type the following command to reconfigure the network settings and press Enter:


ipconfig /renew


7. Type the following command to clear the DNS information cached and press Enter:


ipconfig /flushdns


Restart your computer.


Once you complete the steps, launch the web browser and confirm the internet is working.


8. If the steps above still doesn't work, reset all the network adapters, use these steps:


Open Settings.

Click on Network & Internet.

Click on Status.

Under the "Advanced network settings" section, click the Network reset option.

Click the Reset now button.

Click the Yes button.


After you complete the steps, the computer will restart automatically, and on reboot, you should now be able to connect to the internet.


If you have any further questions or queries, please kindly let us know.


Best Regards,

Srri

Intel Customer Support


0 Kudos
ashish_singh
Beginner
1,364 Views

thanks for replying intel support

i have tried the methods u have mentioned the commands , i ran them 2 times didn't changed a thing, i moved on to resetting it didn't work either, so i went for reinstalling which i have tried in past the event timer events increases every time i do the reinstalling , like now its reached 49 events. their is something wrong going with installation , its only generate an error red sign after i install the driver for specific network device.

and for my internet it was working it is working but its causing me unplayable issues, browser,steam downloading these things work, but my game it suffers badly in multiplayer, and the same game with same config works without any issue if i open offline maps/practise map.

as u can see below the number of events have reached 49 now,

thanks.

eventviewer.png

 

0 Kudos
Irwan_Intel
Moderator
1,320 Views

Hello ashish_singh,


Please try to do clean driver installation https://www.intel.com/content/www/us/en/support/articles/000058304/ethernet-products.html

Download driver from your OEM manufacturer website or you can try to use Intel Generic drivers pack.

MSI: https://www.msi.com/Motherboard/PRO-Z690-A-WIFI-DDR4/support#driver

Intel: https://www.intel.com/content/www/us/en/download/15084/intel-ethernet-adapter-complete-driver-pack.html


I would also recommend checking network cable ( Cat6 or better)


Regards,

Irwan_Intel


0 Kudos
ashish_singh
Beginner
1,308 Views

i have ordered another cable to test if it cures the buffering the cable rated as cat7 

Cat7 Ethernet Cable, Pure Copper Flat RJ45 LAN Cable Cable 10 Gigabit 600MHZ 

i will let u know how it performs as soon as it arrives 

thanks 

0 Kudos
ashish_singh
Beginner
1,252 Views

hello intel support

my new cable arrived today it is performing same as my old one, their is no difference. 

thanks

0 Kudos
Irwan_Intel
Moderator
1,231 Views

Hello ashish_singh,


Could we know if you have tried clean driver installation steps? https://www.intel.com/content/www/us/en/support/articles/000058304/ethernet-products.html


Regards,

Irwan_Intel


0 Kudos
ashish_singh
Beginner
1,208 Views

hello intel support

i will like add some observation made during this technical difficulty i am facing 

i plugged another usb to ethernet device to my pc it also produced the same event like intel one . the driver was havng problem starting, the device was working like the same as intel the internet working in windows but in game causing network buffer causing inaccurate mouse movement

in my bios motherboard settings their is integerated peripherals tab-> i disabled onboard LAN controller > restart the device saving bios settings

my mouse and keyboard gone dead in windows, my keyboard light was on , my mouse light was off, no cursor , both devices were not working, 

they were working in bios but not in windows. 

the keyboard and mouse only dont work after the first boot while changes made in bios, after restarting they works, 

i turned the LAN controller ON in bios the keyboard mouse did the same thing and after restarting through button on my pc, they were working again.

these two things i did were done separately ., the usb ethernet were completely uninstalled during LAN controller thing. for assurance i did the changes again in bios after completely removing usb ethernet device driver.

so the other usb to ethernet driver also producing same event and onboard LAN controller in bios doing one time thing where my keyboard and mouse stops responding in windows, one got fixed after restart, other is producing same event as intel ethernet.

thanks 

0 Kudos
Irwan_Intel
Moderator
1,192 Views

Hello ashish_singh,


Have you tried updating the firmware/BIOS for the motherboards? Or installing the latest Windows updates?

Please also share SSU log for further checking.

https://www.intel.com/content/www/us/en/support/articles/000057926/memory-and-storage.html


Regards,

Irwan_Intel


0 Kudos
ashish_singh
Beginner
1,184 Views

windows is upto date nvidia drivers upto date, motherboard drivers are installed through msi center they are up to date, further the bios update has caused much more issue for me while updating so i am currently using 1.B bios as it is most stable for intel 13th gen processor, their are users who has posted about it on the site overclock dot net their is thread about the bios update throwing BSOD bad memory timings application crashing, so i prefer not to update bios as myself have seen much bothering mouse movement issue i have been keeping everything update before that but now i only use specific bios for motherboard, rest about ethernet i dont update driver from intel support tool cause the msi center driver were not dropping in windows while intel support driver installation were causing me some issue, i have also multiple time resetted this windows from cloud download. i am attaching the log file generated through SSU.

thanks

0 Kudos
Irwan_Intel
Moderator
1,071 Views

Hello ashish_singh,


From the checking, Seems the driver that you had is 2.1.3.15. Latest NCX driver version in our complete driver pack is 2.1.4.2. Please try to update with our generic driver and monitor if the issue persists.

https://www.intel.com/content/www/us/en/download/15084/intel-ethernet-adapter-complete-driver-pack.html


Also both onboard LAN and USB driver seems to throw the same event ID 411, this could be bus related issue which perhaps can be resolved by updating the BIOS / NVM (firmware) of the device. Hence please check with your OEM Motherboard, please let us know if you have updated it to the latest version.


Regards,

Irwan_Intel


0 Kudos
ashish_singh
Beginner
1,055 Views

hello intel support,

i have updated my ethernet driver as per link given 

Screenshot 2024-03-01 070246.png

 i updated it on bios version 1.B the ethernet produced the same event message as before

Screenshot 2024-03-01 071431.png

after the installation my first game (deathmatch in counterstrike-2) it runs without any issue as soon as round ends and the map gets loaded again the old problem comes back again. it has also worked with earlier version of ethernet driver , the game works with perfect mouse movement just after installation for 1 round only ,after that it never works. even launching the game again doesn't work, but offline map/practise map works with perfect mouse movement. i am testing this driver for now keeping it to test more if it rings any issue i will let you know.

Second thing i did was updating my motherboard bios to 1.G version latest one

after installing bios device manager showed 2 ethernet device have to delete them and install new driver.

Screenshot 2024-03-01 074638.png

as u can see named #2 it happened only after updating bios from 1.B to 1.G

installation of ethernet driver in 1.G bios made the power management of ethernet option not greyed out(i could change the option allow computer to turn off this device to save power). in 1.B version the power management was greyed out for both msi version ethernet and the link you provided that version too. the driver worked same, 1 round game loaded fine than it got weird again, mouse movement was ultra bad in this(1.G) bios version like ultra ultra bad, i have to revert my bios version to more stable version i reverted it to 1.B to keep things stable for observation. and the #2 ethernet driver popped up again after reverting, i deleted them and updated to the file link u gave me. 

thanks

0 Kudos
Irwan_Intel
Moderator
910 Views

Hello ashish_singh,


If a network adapter has #2 after it, it means that the first network adapter is hidden. This is because the system registry still retains the information of the previous NIC. It’s not a hardware issue and can be solved by removing the hidden device.

 

Please refer to these steps to show the hidden devices and uninstall both

 

a.   on Device Manager.

b.  Click on View and click on Show Hidden Devices.

c.   Expand Network Adapters and check for the network adapter #1.

d.  If both of the adapters are listed, then right-click on them and click on Uninstall.

 

Regarding the network issue during in-game, we advise you to check with MSI if they have updated it to the latest version. The latest version of NVM for I225 is v1.94.


Regards,

Irwan_Intel


0 Kudos
ashish_singh
Beginner
890 Views
hello intel support
how to check my NVM version for I225-v i currently has , idk how to check what version i currently has
thanks
0 Kudos
Hayat
Employee
840 Views

Hello ashish_singh,


We advise you to check with MSI if they have updated it to the latest version. Since MSI provided the NVM Firmware, MSI should be able to update on your current NVM Version.


Kindly let us know if you have further questions or if we can proceed to close the thread.


Regards,

Hayat

Intel Customer Support


0 Kudos
Hayat
Employee
760 Views

Hello ashish_singh,


Since you need to contact MSI for further information. Thus, we will proceed to close the thread.


Kindly open a new thread if you have any questions. We will be more than happy to continue to assist you further.


Thank you.


Regards,

Hayat

Intel Customer Support


0 Kudos
Reply