FPGA, SoC, And CPLD Boards And Kits
FPGA Evaluation and Development Kits
5960 Discussions

Altera cyclone v fpga board not working

PK16
Beginner
774 Views

The board we have altera cyclone v fpga. After giving power supply, only 12v power supply LED is glowing. The rest are not working like normal displaying of 7 segment display, other red, green lEDS. This occurs previously also, but after removing jumper and fixing again, it functions. Now the same I am doing but not working. So please tell me the solution and why this happens.

Labels (1)
0 Kudos
10 Replies
lixy
Employee
703 Views

Hi,


From the picture, this is a Cyclone V starter kit from Terasic, 3.3-V Power LED D6 is not on, suspecting power supply circuit defect.

However, I searched online but didn't found detailed schematic of this board, but only UG. From the UG, I couldn't find exact Power supply tree to understand how to locate the exact failing device. I would suggest you to get support from Terasic directly.

By the way, you may need to explain the jumper you are referring to here:

"This occurs previously also, but after removing jumper and fixing again, it functions".


Best Regards,

XY


0 Kudos
PK16
Beginner
689 Views

Yes,  this is a Cyclone V starter kit from Terasic. Yes, 3.3v power LED is not on. Last time, basically i have removed and fixed again with JP15,JP16,JP13 jumper, then it works.  While working with the board, suddenly the all LED goes to off except D5.

 

 

Thanks

0 Kudos
PK16
Beginner
658 Views

Please provide me further solution for the above issue as soon as possible. 

0 Kudos
lixy
Employee
619 Views

Hi PK16,

 

As mentioned before, I think we need the schematic of the board. Do you have such file of this board?

Also, have you tied to contact Terasic for more help?

 

Best Regards,

XY

0 Kudos
PK16
Beginner
617 Views

No, I did not get any link for contact terasic. I do not have any Board Schematic. The schematic is also not available in terasic site.  On Terasic site, they have given Intel community forum for contact. If you have link for contacting Terasic, then send me.

 
Thanks
0 Kudos
lixy
Employee
608 Views

Hi, 

From the UG, I could find this information. You may try sending Email to support@terasic.com and sales@terasic.com

Terasic Technologies 9F., No.176, Sec.2, Gongdao 5th Rd, East Dist, HsinChu City, 30070. Taiwan, 30070

Email: support@terasic.com

Web: www.terasic.com

Cyclone V GX Starter Kit Web: www.C5G.terasic.com

With the information I got, I could only get the information that the Power Supply circuit might has been defected. But without the schematic, we don't know which unit controls the 3.3-V Power LED D6, and understand the failing component on the board. 

Best Regards,

XY

0 Kudos
PK16
Beginner
587 Views

I got the schematic sheet of C5G. Please go through this,  in page 9, there is power circuit of c5g is there.

 

 

Thanks

0 Kudos
lixy
Employee
577 Views

Hi, 

Thanks for providing this schematic!

From Page 21, we can see that VCC3P3 signal is controlling the 3.3V Power LED D6. 

To understand which component is defected, you can measure some point's Voltage to GND. 

VCC3P3 Test Point Pad,

R57/R60 both sides to GND (Measure the voltage to ground at both ends of the resistor separately),

R184 both sides to GND,

L12 both sides to GND,

R47 both sides to GND.

I think by checking these points, we will at least understand which component is defected. 

lixy_0-1713443799955.png

lixy_1-1713444607610.png

Best Regards,

Xiaoyan

 

 

0 Kudos
PK16
Beginner
568 Views

Thank you. I will check and send the voltage update soon.

0 Kudos
Farabi
Employee
296 Views

Hello,


Just to check do you have update after checking your board?


regards,

Farabi


0 Kudos
Reply