FPGA, SoC, And CPLD Boards And Kits
FPGA Evaluation and Development Kits
5987 Discussions

Cyclone V E Development Kit not generating IP address neither able to boot to factory settings.

New Contributor I

Hi all,
iam very new to the topic of FPGA, recently i bought a Cyclone V E Development Kit, 

i then flashed a sof file (just to blink an led using counter, LED in pin_AK6), the flashed built were not reflected in the kit, (the same sof file worked in Cyclone V 5CEBA4U15C7, note that pin assignments were changed accordingly).

As the changes were not reflected we switch back to factory image and the kit worked perfectly, but after a while, the kit stopped responding(it is not generating any ip address, even though all the DIP switches are in default position the factory image is not getting flashed, even JTAG is not getting detected by the programmer).


Please help me in this, thanks in advance .


note : used Quartus prime 13.1 web edition.

0 Kudos
3 Replies

Hi Sameer-sahu,

I'm sorry to hear that you're having trouble with your Cyclone V E Development Kit. Let me try to help you with some troubleshooting steps:

  1. Check your power supply: Make sure your power supply is properly connected and providing the correct voltage. You can refer to the user manual of your development kit to verify the required voltage.
  2. Check the board connections: Verify all connections between the board and the programmer are correct. Ensure that the USB cable is properly connected and check that the jumper settings are correct.
  3. Check the JTAG settings: Ensure that your JTAG settings are correct. Make sure that the correct device is selected in the programmer and that the JTAG chain is correctly connected.
  4. Check the Quartus settings: Verify that the correct FPGA device is selected in the Quartus project settings. Check that the pin assignments are correct.
  5. Check the sof file: Ensure that the sof file is generated for the correct device and is programmed correctly.
  6. Try resetting the board: Reset the board by disconnecting and reconnecting the power supply.
  7. Try a different USB port: Sometimes, USB ports can malfunction. Try a different USB port and see if it makes any difference.
  8. Try a different development kit: If you have access to a different development kit, try programming it with the same sof file to see if it works. If it does, then the problem may be with the development kit itself.
  9. Try with a later version of Quartus.

Let me know if these works.



0 Kudos
New Contributor I

Hi Fakhrul,

Thanks for your response. I followed the cyclone V E FPGA development guide appendix 5 (A5, page number 35) for factory reset of Max V CPLD. But still I am not able to get the IP address in LCD screen. I made all the DPI switches to default mode. I turned on all DPI switch 2 and then flashed a .sof of blink LED, it was working properly. But with same configuration when I tried to flash default max5.pof file I couldn't success at that time (I tried with default DPI switch configuration also). Can you please tell how to set the DPI switch for factory reset the Max V CPLD so that I will get the IP address in LCD screen?




0 Kudos

Please be advised that due to the absence of a response from you regarding the previous notification we provided, we will be transitioning this thread to community support. If you have any new questions or concerns, we kindly suggest opening a new thread to receive assistance from Intel experts. However, if you do not have any further inquiries, the community users will be available to assist you on this thread. Thank you for your understanding

0 Kudos