Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance and optimization
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
17665 Discussions

Intel HD Graphics Control Panel Displays Wrong Language

SDept1
Novice
10,295 Views

The System Default Language is: English (United States), But the desktop right-click menu shows Intel HD GCP items in Chinese characters. How can I resolve this without changing my language setting for non-Unicode programs?

1 Solution
Bryce__Intel
Employee
4,409 Views

Hi all,

This should be resolved in the latest 15.40 drivers. If you are experiencing this issue, please test 4404 to see if it resolves this for you. Report back for a pass/fail so we confirm if it's working or not for everyone. Appreciate your help!

View solution in original post

22 Replies
Kevin_M_Intel
Employee
4,000 Views

Avis,

I am sorry to hear you are having this problem with the system but let me help you.

The Intel® HD Graphics Control Panel will automatically select the language set for non-Unicode programs and this point there is no option to change at the software level.

I see you know where exactly to change it but in any case here are the steps (may help other users):

1. Go to the Windows* Control Panel.

2. Open the icon Regional and Language Options.

3. Select Administrative tab and select Change system locale.

 

4. Select the language of preference from the drop-down list.

 

 

5. Select the Formats tab and change the Current format to match the language selected from Current system locale.

 

6. Click Apply and restart when prompted to "Restart now".

7. After the restart, open the Intel(R) Graphics Driver's Control Panel by pressing [Ctrl]+[Alt]+[F12].

8. To confirm the Default Language, choose the information icon at the top right.

For the newer interface, select on Options and Support > Information Center to display the Default Language (see samples below for both interfaces).

Instructions for Windows* XP

1. Go to Windows* Control Panel.

2. Open the icon Regional and Language Options.

3. Under the Regional Options tab, select the language of preference.

4. Click Apply and restart when prompted to "Restart now".

Sample older user-interface console displaying Default Language Spanish:

Sample of the new user-interface displaying Default Language English:

 

SDept1
Novice
4,000 Views

Again, thank you for trying to be helpful, but I'd read the first post thoroughly before posting if I were you. This is obviously a silly mistake made by Intel driver development team. and there is no way I would mess with this setting just to amend Intel's twisted understanding of some basic system settings.

MSjös
Beginner
4,000 Views

Intel seems to have changed their drivers once again. There are no .cui nor .lrc files in system32.

 

I've been trying to change parameters in the regestry, and I also tried to remove the language files (except english) from the HD Graphic installer. No success..

 

I've no idea what the F intel is up to. I live and work within the EU, and I work all over the place. Using English win7 pro on all the places... Language, Location and non-unicode is set to US-English.

 

However, Time and Currency is national, and so is the k-board. So every computer I work on has it's own "Intel Language"... NONE of the computers has the Intel HD Graphic panel in English.

 

Please! STOP FORCING AUTOLANGUAGE SETTINGS!
VSuho
Beginner
3,999 Views

grynnan, the .cui files are hidden system files now, so you have to check the corresponding flag in folder options to be able to see and rename them

worked for me

still have to do it again after every update though

annoying as hell

@kevin_intel, is there any chance this can ever be made an user-selectable option in the control panel or at least changed to match the main windows installation language instead of the regional locale?

MSjös
Beginner
3,999 Views

I know they're hidden.. if you got 'em.

I don't. =/

Kevin_M_Intel
Employee
3,999 Views

I will pass your feedback to the corresponding department for them to take this in consideration.

Kevin m

EAvro
Beginner
3,999 Views

Same here.

Fresh install of Windows 10, auto installed latest drivers, can't change language back to English because the cui files don't exist in this version (neither hidden nor system).

Version 10.18.15.4256.

I would also like to join the request to stop forcing us to use the 'default' language.

Anonymous
Not applicable
3,999 Views

Please check post number 1.

Mike C

EAvro
Beginner
3,999 Views

With all due respect, that is not a solution.

I live and work in Israel so I need my time, date and regional settings to match that.

My operating system however is in English because I'm more comfortable using English.

Why does your program assume I prefer Hebrew based on a nearly unrelated setting in the operating system, and forces me to use whatever language it deems appropriate for me?

Just add a drop box with language selection! It's not that hard, almost every program has it!

JMaca1
Beginner
3,998 Views

Based on the latest update (August 5, 2015), it looks like intel didn't care at all. Great work, intel.

AMaru2
Beginner
3,998 Views

Hi Avis.

Intel's menu items on Windows seem to be part of their 'igfxpph.dll' shell extension (can be read from the shell extension's registration in the Windows registry) located in the Windows\System32 folder. The same extension seems to be in charge of the menu displayed when clicking on their system tray icon as well.

The shell extension reads its localized messages (such as those used for their menu item texts) from language resource files located next to the shell extension DLL and named 'igfxr# .lrc'. If the appropriate language resource file is renamed, the extension will fall back to using the English resources which would be exactly what you want.

In my case, I renamed the 'igfxhrv.lrc' file to 'igfxhrv.lrc.disabled' and the menu items started getting displayed in English at once (no reboot required :-D).

Hope this helps.

Best regards,

Ana Marušić

P.S. I agree with you, Intel messed up by using an incorrect regional setting when determining which language to use for its menu items. 🙂

Kevin_M_Intel
Employee
3,998 Views

Hi Ana,

 

Thanks for your feedback. We are sure it will be helpful for other users.

Kevin M

MB14
Beginner
3,998 Views

This is for the new Intel HD Graphics Control Panel

so go to C:\Windows\System32\ find files that end in .cui like this example: resROM.cui (this is language file for romanian), now I don't want to change my System Locale because romanian has special characters like ă,î,ș,ț and so on.

So find the res# .cui file corresponding to your language and remove it...than rename resENU.cui to your language. Example: if you had korean: resKOR.cui remove it and rename resENU.cui to resKOR.cui, and that is it!! No restart needed the changes will take place instantly.

DO NOT FORGET to rename resENU.cui to your language otherwise all comands from Intel Graphics will become: "Cannot load string"

Bryce__Intel
Employee
3,999 Views

Hi all,

If you're experiencing this reported concern, would you please provide screenshots in a zip of the following screens from the control panel? My developer is requesting this to assess the situation. Appreciate it!

  1. Regional and Language Options – Formats
  2. Regional and Language Options - Location
  3. Regional and Language Options – Keyboards and Languages
  4. Regional and Language Options – Administrative
MFox2
Beginner
3,999 Views

I use the japanese system Non UNICODE local because there are some game which i buy from japan that won't work if i dont. It's annoying that the intel graphics control panel doesn't have a way to choose what language to display the panel in instead of defaulting to the system Non UNICODE local. So i will be joining the request for said feature.

JMaca1
Beginner
3,999 Views
AK17
Beginner
3,999 Views
  1. Regional and Language Options – Formats

     

  2. Regional and Language Options - Location

3. Regional and Language Options – Keyboards and Languages

4. Regional and Language Options – Administrative

Of course Intel yields Russian due to locale rather than any other setting. It also thinks I'm using 10 Pro Insider Preview (but I'll look into that later).

 

Just like everyone else I'd like it to at least use system setting rather than locale which is only meant for non-unicode programs.

Bryce__Intel
Employee
4,000 Views

Thanks all,

The dev is looking into this further. I'll circle back when there's more to report.

MFox2
Beginner
4,000 Views

" href="" modifiedtitle="true" title="HD Driver setup language">

This has been brought up here. Your Users want the devs to stop assuming that the program should be installed in whatever language microsoft's os setting say they have set already. Whether or not its the keyboard settings or any other setting brought up in our current discussion. Please give users the right to choose on install what language the program should be in and stop using windows settings to determine the language.

Every other program Asks a user what language to install the program in because it's "user friendly" to do so. By not asking you get dissatisfied users and angry customers which only negatively impacts your market.

As a programmer myself i do not understand why so many people in the programming field make these kinds of mistakes. Heck the other day i saw someone who had a c++ file that was 5000 lines while the rest of the files in the project where 500 or less lines. I told him to either find a way to salvage it by splitting it up or start over from scratch. I also told him that starting over from scratch would be easier.

I understand that people make mistakes but intel is being dumb if they don't correct this mistake as soon as possible.

Bryce__Intel
Employee
4,410 Views

Hi all,

This should be resolved in the latest 15.40 drivers. If you are experiencing this issue, please test 4404 to see if it resolves this for you. Report back for a pass/fail so we confirm if it's working or not for everyone. Appreciate your help!

Reply