Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance and optimization
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
17555 Discussions

Rotation Hotkeys no longer working

JGraf1
Beginner
9,300 Views

I have a Dell Inspiron 5759 with Intel HD Graphics 520. The current driver version is 21.20.16.4590 and until recently, I was able to select a display rotation via hotkey (CTRL-ALT-ARROW). For some unknown reason this has stopped working. The only hotkeys available in the Intel HD Graphica Control Panel now are

CTRL-ALT-F11 for toggle scaling

CTRL-ALT-F12 for show control panel

I use the rotation feature infrequently, but it is now unavailable through hotkey or (presumably) any other means. How do I get it back?

0 Kudos
1 Solution
idata
Community Manager
4,874 Views

Reverend_Jim, Thank you very much for joining the Intel® graphics communities.

In order to recover that feature, what we can try is to re-install the graphics driver, please get into device manager, look for the option "display adapters" then look for "Intel® graphics", right click on it and choose "un-installed". In this case we recommend to use the drivers provided by Dell, not sure if you are using Windows® 10 but on the link below you will be able to select the operating system, look for video:

 

http://www.dell.com/support/home/us/en/19/product-support/product/inspiron-17-5759-laptop/drivers/ad... http://www.dell.com/support/home/us/en/19/product-support/product/inspiron-17-5759-laptop/drivers/ad...

Since the laptop works with Intel HD Graphics 520, if the problem remains after trying the drivers above, we can try the following Intel drivers:

 

4627:

 

https://downloadcenter.intel.com/download/26669/Graphics-Intel-Graphics-Driver-for-Windows-15-45- https://downloadcenter.intel.com/download/26669/Graphics-Intel-Graphics-Driver-for-Windows-15-45-

 

4352:

https://downloadcenter.intel.com/download/25620/Intel-Graphics-Driver-for-Windows-7-8-1-10-15-40-6th...

If the problem persists you can try to install the drivers manually:

http://www.intel.com/content/www/us/en/support/graphics-drivers/000005629.html http://www.intel.com/content/www/us/en/support/graphics-drivers/000005629.html

 

http://www.intel.com/content/www/us/en/support/graphics-drivers/000005474.html http://www.intel.com/content/www/us/en/support/graphics-drivers/000005474.html

Please let me know the results of installing the drivers above.

Any further questions, please let me know.

Regards,

 

Alberto

View solution in original post

18 Replies
idata
Community Manager
4,875 Views

Reverend_Jim, Thank you very much for joining the Intel® graphics communities.

In order to recover that feature, what we can try is to re-install the graphics driver, please get into device manager, look for the option "display adapters" then look for "Intel® graphics", right click on it and choose "un-installed". In this case we recommend to use the drivers provided by Dell, not sure if you are using Windows® 10 but on the link below you will be able to select the operating system, look for video:

 

http://www.dell.com/support/home/us/en/19/product-support/product/inspiron-17-5759-laptop/drivers/ad... http://www.dell.com/support/home/us/en/19/product-support/product/inspiron-17-5759-laptop/drivers/ad...

Since the laptop works with Intel HD Graphics 520, if the problem remains after trying the drivers above, we can try the following Intel drivers:

 

4627:

 

https://downloadcenter.intel.com/download/26669/Graphics-Intel-Graphics-Driver-for-Windows-15-45- https://downloadcenter.intel.com/download/26669/Graphics-Intel-Graphics-Driver-for-Windows-15-45-

 

4352:

https://downloadcenter.intel.com/download/25620/Intel-Graphics-Driver-for-Windows-7-8-1-10-15-40-6th...

If the problem persists you can try to install the drivers manually:

http://www.intel.com/content/www/us/en/support/graphics-drivers/000005629.html http://www.intel.com/content/www/us/en/support/graphics-drivers/000005629.html

 

http://www.intel.com/content/www/us/en/support/graphics-drivers/000005474.html http://www.intel.com/content/www/us/en/support/graphics-drivers/000005474.html

Please let me know the results of installing the drivers above.

Any further questions, please let me know.

Regards,

 

Alberto
JGraf1
Beginner
4,874 Views

That fixed it. Thank you.

idata
Community Manager
4,874 Views

Reverend_Jim, you are welcome, excellent, it is great to hear the problem got fixed.

 

 

Any other inquiry, do not hesitate in contact us again.

 

 

Regards,

 

Alberto

 

JGraf1
Beginner
4,874 Views

Well, it was fixed. Now it's not. Windows update automatically downloaded and installed a driver update and now the new driver has once again killed the rotate feature. Ii can install the olx driver again, but Microsoft will just bloody well overwrite it again. Do you know of any way I can block this?

idata
Community Manager
4,874 Views

Reverend_Jim, We are sorry to hear that.

Sure, please follow the instructions on the link below:

 

For Windows® 10:

 

https://www.howtogeek.com/223864/how-to-uninstall-and-block-updates-and-drivers-on-windows-10/ https://www.howtogeek.com/223864/how-to-uninstall-and-block-updates-and-drivers-on-windows-10/

 

Windows® 8.1:

 

https://technet.microsoft.com/en-us/library/cc730606(v=ws.10).aspx https://technet.microsoft.com/en-us/library/cc730606(v=ws.10).aspx

 

Windows® 7:

 

https://support.microsoft.com/en-us/help/2500967/how-to-stop-windows-7-automatically-installing-driv... https://support.microsoft.com/en-us/help/2500967/how-to-stop-windows-7-automatically-installing-driv...

Please let us know the results of trying the steps on those links.

 

NOTE: These links are being offered for your convenience and should not be viewed as an endorsement by Intel of the content, products, or services offered there.

 

 

Any questions, please let me know.

 

 

Regards,

 

Alberto

 

JGraf1
Beginner
4,874 Views

Thanks again. I had to restore a system image (C drive) from 09:00 today in order to undo the last Microsoft Driver update. I restarted then went into the control panel to disable the driver updates but before I could do this, Windows had updated the driver again. I uninstalled the driver then reinstalled the one you had previously given me (after disabling my wifi). I got the driver working again then enabled the wifi. I checked to make sure the rotation keys were working again before starting this message.

And in the middle of typing, my screen went black for several seconds so I knew the updated driver had one more been forced onto my computer. I have to say I am getting pretty effing pissed off.

Having vented that, I appreciate that you are trying to help me out

idata
Community Manager
4,874 Views

Reverend_Jim, You are welcome. Thank you very much for providing those results, it is unfortunate to hear that after trying the steps provided above the problem remains.

 

 

At this point I think the best thing to do now will be to get in contact directly with Microsoft, just to check if they have another option to stop the driver from installing or if they have further suggestions about this matter:

 

 

Microsoft's contact information:

 

1 877-696-7786

 

https://support.microsoft.com/en-us https://support.microsoft.com/en-us

 

 

Please let us know if they were able to assist you.

 

 

Any questions, please let me know.

 

 

Regards,

 

Alberto

 

JGraf1
Beginner
4,874 Views

I had a couple of long chat sessions with Microsoft and it was only when going through the steps late into the second session that I noticed that the "bad" driver that keeps getting loaded was provided by Intel. So the problem is not so much that Windows Update is breaking my video. It appears that the problem is that Intel is providing an upgraded driver that removes a very useful feature (rotation). So my question has to be, why have you removed this feature? Here is the info from devmgmt.msc:

Driver Provider:Intel CorporationDriver Date:2017-01-18Driver Version:21.20.16.4590
idata
Community Manager
4,874 Views

Reverend_Jim, Thank you very much for letting us know that information.

 

 

We will do further research on this matter in order to try to answer your question.

 

 

Any questions, please let me know.

 

 

Regards,

 

Alberto

 

idata
Community Manager
4,874 Views

Reverend_Jim, I just wanted to let you know that I just received an update on the research we were doing on this matter. First of all we wanted to thank you for sharing your comments in our communities and also I just want to inform you that we are actually gathering all the feedback from our peers on the link below, so if you have the option to post your comments in there that will be highly appreciated in order for us to try to improve the Intel® Graphics Control Panel:

 

/thread/112438 https://communities.intel.com/thread/112438

Any questions, please let me know.

Regards,

 

Alberto
JGraf1
Beginner
4,874 Views

Last night another driver update was forced onto my laptop. Once again it killed my ability to rotate the display. In spite of the fact that an update had just been applied (I assumed the latest and greatest) I went to the device manager, selected Intel(R) HD Graphics 520 and clicked "Update Driver". Prior to this action, the driver date was 2017-01-18. After the update (and after blowing through my daily cap) the date was 2017-03-09 (both said the driver provider was Intel Corporation).

Alas, my rotation was still not working so I reverted to the driver from 2016-09-29 (also Intel Corporation). Rotation is once again working.

Your suggestion to contact Microsoft Support was no help whatsoever. It seems to me that since all three drivers are provided by Intel, and the two versions that Windows seems to want to use are both broke, the problem seems to be on your end and I'm still left wondering what you are going to do to fix it.

Is there a way to alter the 2016-09-29 driver so the system thinks it is newer than the driver(s) it wants to install?

idata
Community Manager
4,874 Views

Reverend_Jim, Thank you very much once again for providing those details.

 

 

We are sorry to hear the problem is happening again with the new drivers.

 

 

In regard to your inquiry, the driver update is a feature that belongs to Microsoft itself, even though the drivers that get installed belong to Intel, the update is done through Windows, our web site do not offer the option to update drivers automatically. I found another link that allows you to stop the automatic driver update, but it might be risky to try it, so in this case, the best thing to do, even though you tried that already, will be to get in contact with Microsoft again to confirm if that is a good option to do or if there is another way to stop the update:

 

https://support.microsoft.com/en-us/help/2500967/how-to-stop-windows-7-automatically-installing-driv... https://support.microsoft.com/en-us/help/2500967/how-to-stop-windows-7-automatically-installing-driv...

 

 

Any questions, please let me know.

 

 

Regards,

 

Alberto
JGraf1
Beginner
4,874 Views

Here's a novel idea. Why don't you fix the new driver so that it supports the rotation feature? Barring that, can you give me any reason why such a useful feature has been removed?

Sorry for sounding snarky but I expected a better response than "it's not our problem".

idata
Community Manager
4,874 Views

Reverend_Jim, No problem at all, we understand that feature is very useful for you. If you submitted this suggestion on the link related to the Intel® Graphics control panel provided above, the proper department will be able to see your feedback in there and they might be able to provide an answer of why the hotkeys function was removed, it seems to be it was a design decision for that specific driver.

 

 

Now, remember that you can always change the rotation of the display on "display settings" under "orientation", we do understand it was easier with the hotkeys, but as a workaround that will the way to use the feature.

 

 

Let me apologize for any inconvenience.

 

 

Any questions, please let me know.

 

 

Regards,

 

Alberto

 

JGraf1
Beginner
4,874 Views

As of 13:45 this afternoon it is no longer a problem. A user on daniweb.com posted a link to http://noeld.com/programs.asp?cat=misc# Display which is a command line utility that does what your driver no longer does. Since I already have AutoHotkey I can easily add a hotkey to

display /rotate:90 /toggle

to toggle between my two orientations.

idata
Community Manager
4,874 Views

Reverend_Jim, Thank you very much for sharing those results, that will be very helpful for all the peers in our communities viewing this thread.

 

 

Perfect, excellent, it is great to hear that the workaround on that link fixed the problem and now you can rotate the display as you previously did.

 

 

Any other inquiry, do not hesitate in contact us again.

 

 

Regards,

 

Alberto

 

apero2
Beginner
4,874 Views

I'm a Dell XPS 12 9350 and I've your same problem. Exactly!

idata
Community Manager
4,874 Views

alexperoni: Please submit your inquiry on a new thread, the reason for that is that every scenario is different even if the same product is being used, so, for us to better assist you to try to fix the problem the computer might have, please submit your inquiry on a new thread:

 

https://communities.intel.com/community/tech https://communities.intel.com/community/tech

 

 

Let me apologize for any inconvenience.

 

 

Regards,

 

Alberto R

 

Reply