Intel® ARC™ Graphics
Get answers to your questions or issues when gaming on the world’s best discrete video cards with the latest news surrounding Intel® ARC™ Graphics
1799 Discussions

Problems with 4:3 resolution in CS2

lein
Novice
13,002 Views

Hello,

 

I recently got my BiFrost Arc A770 and it works just fine with almost everything.

 

I have one little problem which is just my own preference but I would still like to get a solution for this.

 

My problem is the following:

I like to play CS2 with black bars but I just can't get black bars working for the game.

Every other game that I play on 4:3 has black bars but cs2 hasn't.

I tried everything I've read on the internet from trying with IGCC up to changing my native resolution for my monitor to a 4:3 resolution and maintaining the display ratio. But even then CS2 is fully stretched.

 

A little side fact because I read some answers hinting to the following: I can't change the settings for my monitor regarding stretched resolution or not stretched resolution.

 

Is there anything else I can try?
Does someone here with an ARC play CS2 with black bars?

 

Thanks in advance for your answers.

Labels (1)
0 Kudos
11 Replies
Andres_Intel
Employee
12,987 Views

Hello lein,

  

 

Thank you for posting on the Intel communities. I understand how frustrating is not to play a game in the desired resolution, I will be happy to help you.  

 

To understand this issue in a better way, please answer the following questions:


 

  

Regards,  

 

Andres P. 

Intel Customer Support Technician 


0 Kudos
lein
Novice
12,958 Views

Hey Andres,

 

Were you able to play with the black bars before?

Since this is a completely new build where every single part is new, there was no before, forgot to mention that.

 

You can see the screenshots and the SSU report below.

 

In the screenshots I tried with 1024 x 768 while windows will run on blackbars but cs2 will force to be stretched while as I said already, every other game on 4 by 3 will be bordered.

0 Kudos
Andres_Intel
Employee
12,934 Views

Hello lein,

 

 

Thank you for your response and for sharing the information requested.


Let's follow the steps below for testing and let me know the results:


  • In Windows display settings select another resolution than the recommended one, then go to IGCC and under the scale option select Maintain Aspect Ratio, if you still be not able to see the black bars, then select Maintain Display Scaling.
  • If the issue persists, so in Windows display settings select the recommended resolution, then one more time go to IGCC and under the scale option select Maintain Aspect Ratio, if you still be not able to see the black bars, then select Maintain Display Scaling.


Please keep me informed of the results or if something changes with this test.

 

  

Regards,  

 

Andres P. 

Intel Customer Support Technician 


0 Kudos
lein
Novice
12,925 Views

Thanks for your answer!

 

If I'm using the recommended resolution I don't have the opportunity to choose Maintain Aspect Ratio.

 

When I'm using a different resolution then the recommended one I don't have the opportunity to choose Maintain Display Scaling.

 

Anyways, I tried both of your recommendations and still got the stretch.

 

 

0 Kudos
Andres_Intel
Employee
12,916 Views

Hello lein,

 

 

Thank you for your answer, and for completing the steps.


I will start with an investigation to provide you with the next steps, as soon as I have further information I will let you know.

 

  

Regards,  

 

Andres P. 

Intel Customer Support Technician 


0 Kudos
Andres_Intel
Employee
12,855 Views

Hello lein,

 

 

Thank you for your time and patience.


I have been working on the investigation and our best recommendation is to check this with the game developer as the 4:3 aspect ratios are supported in-game but the app is forcing 16:9 aspect ratios.


Please let me know if you have further questions.

 

  

Regards,  

 

Andres P. 

Intel Customer Support Technician 


0 Kudos
Bandit8623
New Contributor II
12,827 Views

why does black bars work with nvidia then?   4:3 non stretched works fine with cs2 on nvidia cards

0 Kudos
Andres_Intel
Employee
12,788 Views

Hello Bandit8623,

 

 

Thank you for your question.


The reason why is better to contact the game developer, it is because we were trying to replicated the issue and as per our investigation we noticed that our driver is working as expected and the app is the one forcing 16:9 aspect ratios, specifically with Intel® Arc™ Graphics.

 

  

Regards,  

 

Andres P. 

Intel Customer Support Technician 


0 Kudos
lein
Novice
12,771 Views

Thanks for the answer!

0 Kudos
Bandit8623
New Contributor II
12,593 Views

Bandit8623_0-1698368991930.png

you cant access this setting for each game by itself. its global

Bandit8623_1-1698369274950.png

 

 

i just tested and i can play on 4:3 black bars this way.  although i wont probly keep it this way.  just wanted to help ya out

0 Kudos
Andres_Intel
Employee
12,768 Views

Hello lein,

 

 

Happy to hear that I have answered your questions, so we will close this thread. If you need any additional information, please submit a new question as this thread will no longer be monitored.  

 

  

Best regards, 

 

Andres P. 

Intel Customer Support Technician 


0 Kudos
Reply