Intel® ARC™ Graphics
Get answers to your questions or issues when gaming on the world’s best discrete video cards with the latest news surrounding Intel® ARC™ Graphics
1712 Discussions

Sega Megadrive & Genesis Classics (Steam), won't run when using the default launcher.

laxesta
New Contributor II
352 Views

Sega Megadrive & Genesis Classics doesn't run well when using the default launcher. When trying to run the game two things can happen:

 

- The most usual one. I am greeted with a black screen. Nothing happens and the screen is always black, I have to manually close the game.

 

- The most unusual one. I get past the developer logos and there is a screen with several options. A Start the Game option and some other options behind. But using a gamepad button the game tries to launch both nothing happens. The sand clock icon of the mouse appears and the game hangs. It may recover later but pressing the button again produces a sound although there is nothing happening on the screen, everything is static and the game is technically hanging.

 

The only way to play a game is using the Simple Launcher. In that case I can launch Sonic 2 normally and set several options.

 

SSU file with the latest drivers attached.

 

 

0 Kudos
5 Replies
Caguicla_Intel
Moderator
245 Views

Hello laxesta,

 

Thank you for posting in Intel Communities.

 

Previously, were you able to play these games with the default launcher? We will attempt to recreate the issue on our side. Could you also share a video of the problem for our reference?

 

Awaiting your reply.

 

Best regards,

 

Caguicla C.

Intel® Customer Support Technician


0 Kudos
laxesta
New Contributor II
226 Views

hello @Caguicla_Intel 

 

Previously, were you able to play these games with the default launcher?

I played this game a few years ago, I didn't have that problem iirc, when I had the GTX 1060 and the GTX 1080. I only purchased Sonic 2 from that collection.

 

Regarding the video, I managed to record this:

 

https://youtu.be/Uj7FHHrhtUw

 

But there is nothing happening, a black screen and the mouse moving.

 

Once or twice a few days ago I managed to see the main screen of the default launcher, but the game was constantly hanging and not responding. Some odd sound of the menus could be heard here and there but the process was hanging as indicated by Windows.

 

 

0 Kudos
Caguicla_Intel
Moderator
204 Views

Hello laxesta,

 

Thanks for your reply.

 

I was initially anticipating a video demonstrating the problem from the moment you launch the game until the issue arises. Nonetheless, there's no issue as the instructions I provided were not clear. I'll discuss this matter with our engineering team but I overlooked obtaining some details; could you kindly share them with me?

 

Minimum Requirements Link:

Distribution Service (example: Steam / Origin / Epic / XboxGamePass / Ubisoft Connect): 

Graphic Quality (Low, Medium, High, Ultra):

Resolution (1920x1080, 3840x2160):

Vsync (On/Off): 

Window Display Configuration (Fullscreen / Windowed/ Borderless Windowed):

 

Hoping to hear from you.

 

Best regards,

 

Caguicla C.

Intel® Customer Support Technician


laxesta
New Contributor II
173 Views

hi @Caguicla_Intel 

 

your instructions were fine. The thing is that I could record the video with the phone, but I used the Xbox Game app (windows key + G) to capture the video. It makes no difference since I just clicked Launch, then the game goes into a totally black screen.

 

Distribution Service (example: Steam / Origin / Epic / XboxGamePass / Ubisoft Connect): 

Steam

Graphic Quality (Low, Medium, High, Ultra):

It doesn't apply.

Resolution (1920x1080, 3840x2160):

1440p

Vsync (On/Off): 

I've seen no option to change it.

Window Display Configuration (Fullscreen / Windowed/ Borderless Windowed):

It seems borderless.

 

Finally managed to get it working like the first time I launched it, where the menus were showing. This time the menus did work -in an odd way, but they worked-, until I clicked on the setting Input Options, as you can see in the video below.

 

SEGA Mega Drive Classics 2024 05 23 00 21 50 (youtube.com)

 

This time I played the game on my 4K TV, with Windows set to 3840x2160 as the native resolution.

 

Gotta add that Auto HDR is always activated when launching the game, whether the menus work or you are greeted with an entirely black screen.

 

There might be a connection between launching the game for the first time on a given display, in this case the menus work. When I launched the game on my 1440p monitor for the first time, the main menu loaded, with issues, but you could see things. After that, every time I tried to launch the game, the menus didn't even show, it was always a black screen.

 

Switching to the TV, the game launched with a visible menu the first time I launched the game, but after that, the times I tried, once the game launched to a perfect pitch black screen, and another time on my TV the design logo loaded, but then the game automatically crashed to the desktop without a warning message, only some kind of Windows error sound. After that, all the times I relaunched the game...there was the black screen.... no menus whatsoever.

 

cheers

 

 

 

0 Kudos
Caguicla_Intel
Moderator
149 Views

Hello laxesta,

 

I appreciate you sending the information needed. We will look into this matter further and inform you as soon as an update is available.

 

Best regards,

 

Caguicla C.

Intel® Customer Support Technician


0 Kudos
Reply