Intel® DevCloud
Help for those needing help starting or connecting to the Intel® DevCloud
1717 Discussions

Re: FPGA Builds Broken on DevCloud

robertszafa
Novice
926 Views

Hi @AlekhyaV_Intel

 

This is a simple reproducer from the OneAPI-samples GitHub repository: github.com/oneapi-src/oneAPI-samples/tree/master/DirectProgramming/C%2B%2BSYCL_FPGA/Tutorials/GettingStarted/fpga_compile 

 

qsub -I -l nodes=fpga_compile:ppn=2 -l walltime=00:20:00 -d .
# Got node s001-n021

cd oneAPI-samples/DirectProgramming/C++SYCL_FPGA/Tutorials/GettingStarted/fpga_compile
mkdir build 
cd build
cmake ..
make fpga

# Error: The board package being used only supports report generation/emulation/runtime, please use the board package shipped in the FPGA addon instead. 
# Error: Exiting.

 

 

Cheers,

Rob

0 Kudos
5 Replies
AlekhyaV_Intel
Moderator
912 Views

Hi,

 

Thank you for posting in Intel Communities. The reason behind the error is that fpga_compile nodes are solely used for FPGA compilation/emulation/report generation/runtime. fpga_compile nodes wouldn't have FPGA cards added on them. You would be able to build only on FPGA nodes. Try accessing FPGA Arria10 or Stratix10 oneapi nodes to build fpga samples with the below commands:

source /data/intel_fpga/devcloudLoginToolSetup.sh
devcloud_login

Pick 2 or 4 as shown in the below picture to get Arria10 or Stratix10 oneapi nodes

AlekhyaV_Intel_0-1680094683764.png

 

Please find below the screenshot where it worked for us. We tried in s001-n084 Arria10 oneapi node:

AlekhyaV_Intel_1-1680095099786.png

 

If this resolves your issue, make sure to accept this as a solution. This helps others with similar issue.

 

Thanks,

Alekhya

 

 

 

0 Kudos
robertszafa
Novice
898 Views

Hi @AlekhyaV_Intel,

 

Thank you for your continued help.

 

The nodes you mention working (e.g. 84) do have FPGA cards attached. If a node is used for compilation then that would block other people from using the cards to run experiments on them (often hours at a time). 

 

What is the purpose of the fpga_compiule nodes if not to run hardware compiles? To me the solution seems simple: configure the fpga_compile nodes in the same way that the working fpga_runtime nodes are configured.

 

Link to the previous thread which was moved for some reason: https://community.intel.com/t5/Intel-DevCloud/FPGA-Builds-Broken-on-DevCloud/td-p/1439447

 

Thanks,

Robert

0 Kudos
AlekhyaV_Intel
Moderator
843 Views

Hi,


The fpga_compile nodes on devcloud are used for running compile jobs which are targeted to FPGA emulator/FPGA hardware. But fpga_runtime jobs are to run jobs targetted to run Emulator or report generation jobs. You must connect to any nodes with Arria10/Stratix10 nodes to run jobs targeted to FPGA Hardware.


Hope this helps resolving your doubts. If so, make sure to accept this as solution. This helps others with similar issues.


Regards,

Alekhya


0 Kudos
AlekhyaV_Intel
Moderator
784 Views

Hi,


Has the solution provided helped? Can we discontinue monitoring this thread? Please give us an update regarding this issue.


Regards,

Alekhya


0 Kudos
AlekhyaV_Intel
Moderator
703 Views

Hi,


We assume that your issue is resolved. If you need any further assistance, please post a new question as this thread will no longer be monitored by Intel.


Regards,

Alekhya


0 Kudos
Reply