Intel® DevCloud
Help for those needing help starting or connecting to the Intel® DevCloud
1596 Discussions

@devcloud: Permission denied (publickey).

nagas
Novice
1,178 Views

Hello,

I am having an issue with connecting to DevCloud over SSH.

Username: u207593
Platform: Windows10

% ssh -vvv devcloud
OpenSSH_for_Windows_8.1p1, LibreSSL 3.0.2
debug1: Reading configuration data C:\\Users\\****/.ssh/config
...
debug1: Trying private key: C:\\Users\\****\\.ssh/devcloud-access-key-207593.txt
debug3: sign_and_send_pubkey: RSA SHA256:DYZ5gNZevVJBFyNA/j+3/FWugZi2auP/hFiAMC22M1I
debug3: sign_and_send_pubkey: signing using rsa-sha2-512
debug3: send packet: type 50
debug2: we sent a publickey packet, wait for reply
debug3: receive packet: type 51
debug1: Authentications that can continue: publickey
debug2: we did not send a packet, disable method
debug1: No more authentication methods to try.
u207593@devcloud: Permission denied (publickey).
%

Thanks

0 Kudos
1 Solution
nagas
Novice
778 Views

Hi,

 

The issue is resolved and I am now able to access the Intel Devcloud.

 

Many thanks.

View solution in original post

0 Kudos
10 Replies
ThasneemV_Intel
Moderator
1,155 Views

Hi,


Good day to you!


Thanks for posting in Intel Communities.


Please refer the following link to troubleshoot the issue:

https://www.intel.com/content/www/us/en/developer/articles/technical/errors-setting-up-developer-cloud-for-oneapi.html#articleparagraph_1223631681


If the issue still persists, reconfigure SSH connection as per the documentation below:

Linux/macOS: https://devcloud.intel.com/oneapi/documentation/connect-with-ssh-linux-macos/

Windows: https://devcloud.intel.com/oneapi/documentation/connect-with-ssh-windows-openssh/


If the provided steps do not resolve the issue, please provide us with the following information:

1) SSH configuration file located in .ssh folder which can be found at the following directories:

Windows: C:\Users\<username>\.ssh\config

Linux: ~/. ssh/config

2) Are you using proxy or VPN? Kindly try connecting after disabling proxy or VPN.

3) Exact steps/commands that you are using to connect to DevCloud.


Regards,

Thasneem Vazim


0 Kudos
nagas
Novice
1,130 Views

Hi,

 

I truly appreciate your quick reply. 

 

> Please refer the following link to troubleshoot the issue:
> https://www.intel.com/content/www/us/en/developer/articles/technical/errors-setting-up-developer-cloud-for-oneapi.html#articleparagraph_1223631681

I tried it, but the result was the same (=u207593@devcloud: Permission denied (publickey).).

 

> If the issue still persists, reconfigure SSH connection as per the documentation below:
> Windows: https://devcloud.intel.com/oneapi/documentation/connect-with-ssh-windows-openssh/
Unfortunately, the result was the same (=u207593@devcloud: Permission denied (publickey).).

 

> 1) SSH configuration file located in .ssh folder which can be found at the following directories:
I have attached the file.

> 2) Are you using proxy or VPN? Kindly try connecting after disabling proxy or VPN.
No proxy.
And I disabled the VPN, but the result was the same.

> 3) Exact steps/commands that you are using to connect to DevCloud.
Yes.
Other people(=except me) at the same workplace were able to connect using the same procedure.

 

Thanks

0 Kudos
nagas
Novice
1,070 Views

I would appreciate it if you would update me on this matter.

0 Kudos
nagas
Novice
988 Views

> Did it solve your problem?
No. I am not able to connect to ssh yet (u207593).

0 Kudos
ThasneemV_Intel
Moderator
935 Views

Hi,


Could you please try out the following steps:


1) Delete known_host file in .ssh folder.


2) Ensure that you have the devcloud key file in .ssh folder.


3) Modify the config file as per the following format:

Host devcloud

   User u207593

   IdentityFile ~/.ssh/devcloud-access-key-207593.txt

   ProxyCommand ssh -T -i ~/.ssh/devcloud-access-key-207593.txt guest@ssh.devcloud.intel.com


Regards,

Thasneem vazim




0 Kudos
nagas
Novice
903 Views

> 1) Delete known_host file in .ssh folder.

Yes.

 

> 2) Ensure that you have the devcloud key file in .ssh folder.

Yes.

 

> 3) Modify the config file as per the following format:

>   Host devcloud

>   User u207593

>   IdentityFile ~/.ssh/devcloud-access-key-207593.txt

>   ProxyCommand ssh -T -i ~/.ssh/devcloud-access-key-207593.txt guest@ssh.devcloud.intel.com

Still, the result was the same(=u207593@devcloud: Permission denied (publickey).).

 

Is it possible that the public key is the problem? (>> devcloud-access-key-207593.txt)

 

Thanks

0 Kudos
ThasneemV_Intel
Moderator
825 Views

Hi,


We have informed the team concerned regarding your issue and we are working on it internally.


Regards,

Thasneem Vazim


0 Kudos
ThasneemV_Intel
Moderator
799 Views

Hi,


Good day to you.


Apologies for the inconvenience caused. The issue was caused due to a mismatch in the public key at the backend. We have fixed the issue from our side. Kindly try connecting using the same process.


Regards,

Thasneem Vazim


0 Kudos
nagas
Novice
779 Views

Hi,

 

The issue is resolved and I am now able to access the Intel Devcloud.

 

Many thanks.

0 Kudos
ThasneemV_Intel
Moderator
743 Views

Hi,

 

Thanks for accepting our solution. If you need any additional information, please post a new question as this thread will no longer be monitored by Intel.

 

Regards,

Thasneem Vazim

 

0 Kudos
Reply