Intel® Distribution of OpenVINO™ Toolkit
Community assistance about the Intel® Distribution of OpenVINO™ toolkit, OpenCV, and all aspects of computer vision-related on Intel® platforms.

High CPU usage

Midnitedestiny
Beginner
1,057 Views

Im trying to create images using Stable Diffusion with the A1111. I was trying to follow along with a video from Intel (https://www.youtube.com/watch?v=5X0RmlH6JI4) to use A1111. I am unable to generate an image with the gpu. If I do not select any script, it does generate very slowly with my CPU. If I select the 'Accelerate with OpenVINO' script, it still only uses my CPU and goes very slow, even with me clicking the GPU option. I am not sure what I am doing wrong because currently it takes me nearly a hour to generate 1 image  im no python expert so hopefully someone can help me 

 

Specs Intel Arc A770

i9-11900K (suppose to have a IGPU but some reason doesn't)

0 Kudos
11 Replies
Hairul_Intel
Moderator
1,016 Views

Hi Midnitedestiny,

Thank you for reaching out to us.

 

Please share with us the config settings for your stable diffusion operation so that we can investigate this issue further.


On another note, try reducing the image size or other config settings and observe whether it affects your performance.

 

 

Regards,

Hairul


0 Kudos
Midnitedestiny
Beginner
962 Views

sorry for my late reply, but where would I find the config settings? I see the config.json is that what you need?

0 Kudos
Hairul_Intel
Moderator
948 Views

Hi Midnitedestiny,

A screenshot of your Stable Diffusion web UI would suffice so that we could replicate the settings from our end.

 

As mentioned previously, have you tried reducing the image size or other settings and observe whether it affects your performance?

 

 

Regards,

Hairul


0 Kudos
Midnitedestiny
Beginner
942 Views

so doing strictly 512x512 its instant but adding a hi res triggers longer wait times and gpu isn't even being touched only CPU also high res shouldnt take that long ive seen youtubers do videos showing it goes fast with openvino and having intel gpu

 

 

 

Screenshot 2024-02-20 015413.pngScreenshot 2024-02-20 015424.pngScreenshot 2024-02-20 015437.png

0 Kudos
Hairul_Intel
Moderator
905 Views

Hi Midnitedestiny,

Thank you for sharing the information.

 

According to the Known Issue section, the regular Stable Diffusion 2.1 has known issues on discrete GPUs at this time. Please use the Stable Diffusion 2.1-base version instead.

 

 

Regards,

Hairul


0 Kudos
Midnitedestiny
Beginner
896 Views

How would switching out a model help? sorry just confused also not sure how to exactly install stuff from hugging face only github. Also it doesnt solve the other issue of it using my cpu and not my gpu

0 Kudos
Hairul_Intel
Moderator
849 Views

Hi Midnitedestiny,

To get the model, you can click on Stable Diffusion 2.1-base and download the v2-1_512-ema-pruned.ckpt. Next, copy the checkpoint file into your stable-diffusion-webui > models > Stable-diffusion directory.

 

On another note, there was a similar issue with A770 GPU being discussed in the following GitHub thread and the solution provided was to run:

pip install --pre openvino

 

Do let us know if the issue persists after running the command.

 

 

Regards,

Hairul

 

 

0 Kudos
Midnitedestiny
Beginner
817 Views

I dont even have the original Ema pruned in my "models" folder.

 

I also already did the pip install --pre openvino command because it was in the github installation directions.

 

Just confused on why exactly it wont work correctly. I know stable diffusion is more for Nvidia drivers. But still is it because im using intel arc thats not really meant for it?

 

Midnitedestiny_0-1708685468900.png

 

0 Kudos
Hairul_Intel
Moderator
768 Views

Hi Midnitedestiny,

Thank you for the confirmation.

 

As mentioned previously, the solution discussed in the following GitHub thread was to run the pip install --pre openvino. However, this is not working on your side.

 

I've escalated this issue to the relevant teams for further investigation and will get back to you as soon as possible.

 

 

Regards,

Hairul


0 Kudos
Hairul_Intel
Moderator
498 Views

Hi Midnitedestiny,

Thank you for your patience.

 

We've just received feedback from the relevant teams regarding this case.

 

Please try out your model with OpenVINO Benchmark Tool using the A770 GPU and share the results with us.

 

Furthermore, do share with us the model files or source for the models (links to their repository) for further investigation on this issue.

 

 

Regards,

Hairul


0 Kudos
Hairul_Intel
Moderator
321 Views

Hi Midnitedestiny,

Thank you for your question. If you need any additional information from Intel, please submit a new question as this thread is no longer being monitored.

 

 

Regards,

Hairul


0 Kudos
Reply