Intel® Distribution of OpenVINO™ Toolkit
Community support and discussions about the Intel® Distribution of OpenVINO™ toolkit, OpenCV, and all things computer vision-related on Intel® platforms.

Not sure where to post a bug

robopp
Beginner
331 Views

If you install running the latest version of python 3.10, you get the following error when installing openvino prerequisites:

Python 3.10.0
ECHO is off.
Unsupported Python version. Please install Python 3.5 (64-bit) or higher from https://www.python.org/downloads/

 

 

0 Kudos
5 Replies
Vladimir_Dudnik
Employee
298 Views

@robopp  Not sure it is a bug. Have you noticed product Release Notes, where it explicitly mentioned that product validated on Python 3.6-3.7 (at maximum 3.8 on Windows only)

robopp
Beginner
279 Views

Sorry, I did not read the release notes. Not a bug then, just a bad error message saying "Please install Python 3.5 (64-bit) or higher". Since 3.10 is higher than 3.5, it seemed like a bug in detecting the current version. Thanks.

Vladimir_Dudnik
Employee
161 Views

@robopp  yeah, reasonable comment, we need to consider improvement for text of error message

IntelSupport
Community Manager
232 Views

Hi robopp,

It is not a bug. Python 3.10 is not supported yet in the OpenVINO toolkit. You can check the prerequisites for OpenVINO installation in this section of the documentation.

https://docs.openvinotoolkit.org/latest/openvino_docs_install_guides_installing_openvino_windows.htm...

 

The supported version is from Python 3.6-Python 3.8 64-bit.

 

Regards,

Aznie


IntelSupport
Community Manager
82 Views

Hi robopp,

This thread will no longer be monitored since this issue has been resolved. If you need any additional information from Intel, please submit a new question. 


Regards,

Aznie


Reply