Intel® Distribution of OpenVINO™ Toolkit
Community assistance about the Intel® Distribution of OpenVINO™ toolkit, OpenCV, and all aspects of computer vision-related on Intel® platforms.
6403 Discussions

openvino detecting igpu only when connected to the montior.

sumbin
Beginner
1,112 Views


Hi ,

I am using Up 7000 board with intel n50 processor https://up-board.org/up-7000/

I have installed ubuntu 22.04 lts .

I have followed these instructiions to install openvino 2023.3

https://docs.openvino.ai/2023.3/openvino_docs_install_guides_installing_openvino_from_archive_linux.html 

I have followed these instruction to configure gpu for openvino https://docs.openvino.ai/2023.3/openvino_docs_install_guides_configurations_for_intel_gpu.html

 

Openvino can detect gpu only when I connect the board to a monitor using hdmi and login otherwise no gpu is detected.

 

Once detected the inference is fine.

 

Please guide me to fix this

Labels (1)
0 Kudos
11 Replies
Wan_Intel
Moderator
1,057 Views

Hi Sumbin,

Thanks for reaching out to us.

 

Could you please install the recommended driver for Intel® iGPU via the following option and see if the issue can be resolved?

 

 

Regards,

Wan


0 Kudos
sumbin
Beginner
1,044 Views

Hi Wan,

 

Thanks for the reply.

 

I have installed the recommended driver using both the options.

 

Only when I install the driver, Openvino can detect gpu when I connect the board to a monitor and login.

 

If I dont install the recommended driver openvino doesent detect gpu at all

 

 

0 Kudos
Wan_Intel
Moderator
1,019 Views

Hi Sumbin,

Thanks for the information.

 

Are you running an inference with the GPU plugin when connecting remotely to the UP 7000 board with remote client software? Could you please share the error code that you encountered when inferencing with the GPU plugin without a monitor?

 

On the other hand, could you please try the following workaround and see if the issue can be resolved?

  • Enable Display Emulation in BIOS.
  • If you are using remote client software, use a different remote access software, such as Microsoft Remote Desktop Connection or 2X RDP Client. 

 


Regards,

Wan


0 Kudos
sumbin
Beginner
995 Views

Are you running an inference with the GPU plugin when connecting remotely to the UP 7000 board with remote client software? Could you please share the error code that you encountered when inferencing with the GPU plugin without a monitor?

  • No I am not using any remote client software.I am doing ssh to UP 7000 from a ubuntu terminal on a pc.
  • when DEVICE=''GPU" error is

    exec_net = ie.load_network(network=net, device_name=DEVICE)
    File "ie_api.pyx", line 427, in openvino.inference_engine.ie_api.IECore.load_network
    File "ie_api.pyx", line 471, in openvino.inference_engine.ie_api.IECore.load_network
    RuntimeError: [ GENERAL_ERROR ] Check 'all_devices.size() > idx' failed at src/plugins/proxy/src/plugin.cpp:523:
    Cannot get fallback device for index: 0. The total number of found devices is 0

 

 

On the other hand, could you please try the following workaround and see if the issue can be resolved?

  • Enable Display Emulation in BIOS. - Not finding this option is BIOS.
  • If you are using remote client software, use a different remote access software, such as Microsoft Remote Desktop Connection or 2X RDP Client. - I have not used any remote access software

 

 I also ran python program to check the available devices using openvino from crontab.

 Still no gpu detected by openvino

0 Kudos
Wan_Intel
Moderator
979 Views

Hi Sumbin,

Thanks for the information.

Let me check with relevant team and I'll update you as soon as possible.



Regards,

Wan

Intel Customer Support


0 Kudos
Wan_Intel
Moderator
918 Views

Hi Sumbin,

Thanks for your patience.

 

For your information, I've SSH into a Ubuntu machine with Intel® Core™ i5-11400 Processor and checked the GPU plugin when the monitor is not connected to the machine. The GPU plugin was able to detect successfully.

ssh.jpg

 

Could you please try the steps as follows and see if the GPU plugin can be detected?

 

  1. Set up Python Virtual Environment
    python3 -m venv openvino_env

  2. Activate Virtual Environment
    source openvino_env/bin/activate

  3. Set up and update PIP to the highest version
    python -m pip install --upgrade pip

  4. Install the OpenVINO™ Development Tools package
    pip install openvino-dev

  5. Paste the following command in Terminal
    python
    from openvino.runtime import Core
    ie = Core()
    ie.available_devices​

 

Regards,

Wan

 

 

 

0 Kudos
sumbin
Beginner
888 Views

Hi Wan,

 

 

Let me know if you need me to check anything

0 Kudos
Wan_Intel
Moderator
882 Views

Hi Sumbin,

Thanks for the information.

Let me check with relevant team and I'll update you as soon as possible.

 

 

Regards,

Wan

0 Kudos
sumbin
Beginner
732 Views

hi Wan,

 

Any update from your side

 

Regards

0 Kudos
Wan_Intel
Moderator
652 Views

Hi Sumbin,

Thanks for your patience. We've received feedback from relevant team.

 

OpenVINO™ toolkit detects GPU using OpenCL™ API. Please try to run clinfo command in both monitor and monitorless config. Please check board features (power or advanced) whether iGPU is switched off in case of monitor is unplugged.

 

 

Regards,

Wan

 

0 Kudos
Wan_Intel
Moderator
524 Views

Hi Sumbin,

Thanks for your question.

If you need additional information from Intel, please submit a new question as this thread will no longer be monitored.

 

 

Regards,

Wan

 

0 Kudos
Reply