Intel® Edge Software Hub
Get answers from community peers to your questions about building Edge Software Hub solutions for edge compute node.
Announcements
Welcome to the Intel Community! If you like the answer to your question, please mark it as 'Accepted Solution' to help others.

The Edge Software Vision Package for Red Hat Enterprise Linux is now available here.

Learn more about developing on Intel® Hardware and Software here.
422 Discussions

[ESDQ-ECI] Network Connection Error in TSN Module Testing

chiao
Beginner
398 Views

Dear Sir,

We are testing ESDQ-ECI, and when executing the TSN module test item "Dual DUT Setup for TSN," we encounter an issue right at the start when executing the case "IEEE 802.1Qbv Time Aware Shaper." The IP address of Board A (192.168.1.1) gets changed, leading to network connection errors. Ultimately, we see the error message "ERROR: Configure Qdisc failed."
The log file has been attached.
Do you have any suggestions for this issue? Thank you!!


Test platform : Ubuntu 22.04

ESDQ for ECI softawre version : 2023.2

Thanks & Regards,

Denise

Labels (1)
0 Kudos
3 Replies
Iffa_Intel
Moderator
352 Views

Hi,


Could you clarify:


  1.  The IP address of Board A (192.168.1.1) gets changed automatically due to network or you manually change it?
  2. Are you using any proxy?
  3. Did you try to configure static IP address on your system? (this is more related to system's network configuration instead of ECI actually)
  4. Did you try to use some other network that is possibly more stable?
  5. Does your Network Adaptors support TSN?: 



Cordially,

Iffa



0 Kudos
chiao
Beginner
221 Views

Hi Iffa,

 

  1.  The IP address of Board A (192.168.1.1) gets changed automatically due to network or you manually change it?
    =>  It gets changed automatically, we didn't manually change it.
  2. Are you using any proxy?
    => No, we didn't use any proxy.
  3. Did you try to configure static IP address on your system? (this is more related to system's network configuration instead of ECI actually)
    => Yes, we configured static IP address
  4. Did you try to use some other network that is possibly more stable?
    => This test directly connects two devices using a network cable, with Board A set to 192.168.1.1 and Board B set to 192.168.1.2. Therefore, I'm not quite sure what you mean by using another more stable network.
  5. Does your Network Adaptors support TSN?
    => Sure, we use I226-IT and I226-LM.

Thanks & Regards,

Denise

0 Kudos
Iffa_Intel
Moderator
193 Views

Thanks for the information.


We'll further investigate this.


Cordially,

Iffa


0 Kudos
Reply