Community
cancel
Showing results for 
Search instead for 
Did you mean: 
sunkim68
Novice
1,030 Views

vsim.exe - System Error

Hello,

When I install Quartus Pro for evaluation, trying to free use, I have issues when I open questa sim 

as attached snapshot, "MSVCR120.dll was not found" would you please let me know how I can fix it?

Thanks in advance,

Sun Kim

0 Kudos
13 Replies
1,006 Views

Hi @sunkim68 

 

May I know which Questa Sim version that you are using? 

Are you using the Questa - Intel FPGA Edition Revision 2021.04 from https://fpgasoftware.intel.com/21.3/?edition=pro 

 

Best Regards,
Richard Tan

p/s: If any answer from the community or Intel support are helpful, please feel free to give Kudos. 

1,003 Views

Try to install the Microsoft Visual C++ Redistributable for Microsoft Visual Studio 2017 and see if the issue resolved. 

 

Best Regards,
Richard Tan

p/s: If any answer from the community or Intel support are helpful, please feel free to give Kudos. 

sunkim68
Novice
997 Views

I think it is install when I install QuartusProSetup-21.3.0.170-windows.exe, so not sure

But I also try to install for QuestaSetup-21.3.0.170-windows.exe and model sim too and they are showing me same error.

If you know free trial version download, please let me know. I need free trial for Quartus and Questa.

sunkim68
Novice
932 Views

I install Visual Studio 2019 and re-install quartus with fee questa_sim, guesta_fse

but when I try running questa sim, it is ask license as attached.

would you please let me know what I need to do for fix?

 

Thank you,

Sun 

879 Views

Hi @sunkim68 

 

Questa*-Intel FPGA Starter Edition is free, but requires zero cost licenses. 

The LM_LICENSE_FILE environment variable specify the location of the license file. Before using Questa*-Intel® FPGA Edition software, you must set an environment variable the location of license.

 

1. You need to have a license.dat file first. Request the license from the Self Service Licensing Center if you haven't done so. 
2. Then, go to "My PC", right click properties
3. Click Advanced System Setting.
4. In the "Advanced" tab, click environment variable
5. In the "System Variable", create a New variable with name= LM_LICENSE_FILE, value= <the path to your license.dat> e.g. C:\license.dat
6. Click Ok and restart the Questa.

 

Or a more straight forward way:
In the command prompt:
setx LM_LICENSE_FILE <the path to your license.dat>

 

For more information, refer to the User Guide below:

https://www.intel.com/content/www/us/en/programmable/documentation/esc1425946071433.html#qrv15169332...

 

Best Regards,
Richard Tan

p/s: If any answer from the community or Intel support are helpful, please feel free to give Kudos. 

 

sunkim68
Novice
828 Views

Hi Richard,

 

Thanks for your information and I am trying to follow-up still I have issues

I generated it, download and set it up as below but I had a error as attached.

C:\Users\sunki>lmutil lmdiag
lmutil - Copyright (c) 1989-2019 Flexera. All Rights Reserved.
FlexNet diagnostics on Mon 10/11/2021 13:05

-----------------------------------------------------
License file: C:\intelFPGA_pro\21.3\1-UXUQF7_License.dat
-----------------------------------------------------

Would you please let me know what I missed?

 

Thanks,

Sun Kim

 

781 Views

Hi @sunkim68 

 

Could you help to share the license .dat file so I could look into it? 

 

Best Regards,
Richard Tan

p/s: If any answer from the community or Intel support are helpful, please feel free to give Kudos. 

753 Views

Hi @sunkim68 

 

There seems to be an issue with the license generator. The installation should be fine. 

Could you try to re-generate the license and run the Questa again?

 

Best Regards,

Richard Tan

 

sunkim68
Novice
742 Views

Hi Richard,

 

Yes, it is license file issues and I didn’t re-generated but Intel sent new one and it works.

But I had a another issue and below.

I think it is tool limitation for free and If you have any good idea, please let me know.  

 

# ** Error: Failure to checkout svverification license feature.

# ** Error: (vsim-1) Unable to checkout verification license - required for testbench features (randomize, randcase, randsequence, covergroup).

#    Time: 0 ns  Iteration: 0  Instance: /top File: top.sv

# Error loading design

Error loading design

# End time: 04:56:33 on Oct 13,2021, Elapsed time: 0:00:00

# Errors: 2, Warnings: 0

 

Thanks,

Sun

722 Views

From what I get from database, I believe the following constructs require svverification license:

  • randomize
  • randcase
  • randsequence

specifying vsim -nocvg will turn off all coverage features.

 

If issue persists, you may share the design files and provide steps to duplicate the error so I can investigate further.

 

Best Regards,
Richard Tan

p/s: If any answer from the community or Intel support are helpful, please feel free to give Kudos. 

550 Views

Hi @sunkim68 

 

May I know does my latest note help in regards to your case?

 

Best Regards,
Richard Tan

p/s: If any answer from the community or Intel support are helpful, please feel free to give Kudos. 

sunkim68
Novice
538 Views

Sorry for late update, yes with that option, can run functional simulation.

Thanks for your help.

Sun KIm

521 Views

I’m glad that your question has been addressed. With that, I will now transition this thread to community support. If you have a new question, feel free to open a new thread to get the support from Intel experts. Otherwise, the community users will continue to help you on this thread. Thank you.

Best Regards,
Richard Tan

p/s: If any answer from the community or Intel support are helpful, please feel free to give Kudos. 

Reply