Intel® FPGA University Program
University Program Material, Education Boards, and Laboratory Exercises
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
1087 Discussions

Intel FPGA Monitor Program 21.1 with Quartus Prime Standard 21.1

MPfaf1
Novice
264 Views

Hi,

just trying to upgrade from 18.1 to 21.1.
Unfortunately the Intel FGPA Monitor Program 21.1 will not work with the current version of Quartus Prime Standard (also 21.1).


I am aware of the missing installation of Cygwin and WSL and used the information found here to add the missing components to Quartus 21.1.

 

The USB connection to the board is active under "Host Connection" in the Connection Settings pane. 

 

When downloading a system from the monitor program to the DE1-SoC the FPGA monitor program stalls in the state as shown in the attached pic. The board stays unconfigured.

0 Kudos
11 Replies
EBERLAZARE_I_Intel
253 Views

Hi,


Are you porting the working design from 18.1 to 21.1 using the IP Upgrade tool?




MPfaf1
Novice
242 Views

Hi,

no, much simpler: I'm just using the design from the ARM tutorial.

It's just the most basic functionality that does not work with Quartus 21.1 Std and the Intel FPGA Monitor Program 21.1.

EBERLAZARE_I_Intel
224 Views

Hi,


I will try to replicate from my side.


EBERLAZARE_I_Intel
200 Views

Hi,


Could you shared your 18.1 design here?


MPfaf1
Novice
188 Views

Hi,

there is no such "18.1" design from my side. All designs come directly from Intel/Altera

 

The problem is already there if you just do the ARM Tutorial:

  • Simply do a fresh install of Quartus Prime Standard 21.1
  • Install the university program installer 21.1 in addition.
  • Then try to do the ARM tutorial you will find in the Help menu of the Intel FPGA Monitor Program

Result: See picture attached to my inital post.

Problems are known since the 19.1 version of Quartus Prime Standard:

https://medium.com/@jpablo.pinilla/intel-quartus-19-1-university-program-extensions-and-nios-ii-comm...

 

Be aware that the Standard version is the one I'm talking about here (not the Pro).

EBERLAZARE_I_Intel
177 Views

Hi,


Yes from my understanding, you need to install WSL and the necessary steps when installing Nios II in Intel® Quartus® Prime Pro Edition version 19.2 and Intel® Quartus® Prime Standard Edition version 19.1


https://www.intel.com/content/www/us/en/docs/programmable/683525/21-3/installing-windows-subsystem-f...


MPfaf1
Novice
165 Views

Hi,

 

to clarify once again:

The problem this thread is about arises when you do the following things:

  • Install Quartus Prime Std. Version 21.1
  • Install Univerisity Program Installer 21.1 on top
  • Error: Try to use the Intel FPGA Monitor Program which will not be able to download anything to the FPGA board (DE1-SoC).

This thread does not deal with NIOS II, or version 19.1. of Quartus in any other way than that the problem already existed there (though there is no such thing like  university program installer for 19.1)

 

Result:

You confirm that the problem first existed in 19.1 still exists in Quartus Prime Std Edition 21.1. Is that correct?

 

In this case I'd propose to give users a warning on this fact when they download the university program installer for version 21.1.

 

Will there be a Quartus Prime Std version in the future that does no longer have this problem?

 

Thanks
Markus

EBERLAZARE_I_Intel
152 Views

Hi,


Thanks for the feedback, I am channeling the info to our internal team.


Regarding the future support, we have yet the information regarding the future support, I will update to you once I have the info.


Is there any additional questions you may have?


EBERLAZARE_I_Intel
142 Views

Hi,


Is it for both NIOS II and ARM that your are not able to download anything?


For checking purposes, can you confirmed that your NIOS II command shell can be open for the 21.1?




MPfaf1
Novice
96 Views

Hi,

 

currently I’m on vacation which slows things down a bit. But as far as I remember I needed to install WSL after installing Quartus 21.1 to make NIOS command shell run. Still not even the Download from FPGA Monitor program to the DE1-SoC board worked. But I’m sure, this is not new to your since you have of course tested this yourself minutely.

 

Since everything is working in Quartus 18.1 and the steps needed to make 21.1 working with the Monitor program need to much effort from our system administrators here at the university the best way seems to be to stay at this version for use of the Intel FPGA Monitor Program and to wait for a working version of Quartus.

 

Thanks

Markus

 

EBERLAZARE_I_Intel
123 Views

Hi,


Do you have update from your side?


Reply