Intel® FPGA University Program
University Program Material, Education Boards, and Laboratory Exercises
1160 Discussions

Setting Up a remote FPGA Farm using DSEII with SSH


Hi, we are trying to set up a remote FPGA Farm using DSEII and SSH to make the connection between a Windows PC and an Arch Linux Server (running on an Intel® Nuc). At the beginning, we were following this video: but we didn't find it useful enough.


We then found this response: and followed the steps.


Both computers have Quartus Prime Software Installed and we have already managed to get an SSH connection via PuTTY using keyfiles without the need of a password. But when we try to make an exploration using DSEII it outputs the following error message:


Info: Loading project D:\Pedro\FIUADY\Servicio\Quartus\ejemplo_1.dse
Info: Processing started: Mon Sep 18 14:48:04 2023
Info: Resolved host: MSI-Pedro to IP address: fe80::cdc:2061:d6c:6f35.
Warning: [Errno 11001] getaddrinfo failed
Warning: [Errno 11001] getaddrinfo failed
Warning: [Errno 11001] getaddrinfo failed
Warning: [Errno 11001] getaddrinfo failed
Error: [Errno 11001] getaddrinfo failed
Error: Traceback (most recent call last):
File "server.p", line 102, in run_impl
File "d:\programas\quartus\quartus\common\python\lib\", line 452, in _init_
File "d:\programas\quartus\quartus\common\python\lib\", line 466, in server_bind
socket.gaierror: [Errno 11001] getaddrinfo failed

Error: Cannot start explorer server.
Info: Processing ended: Mon Sep 18 14:48:38 2023
Info: Elapsed time: 0:00:31
Info: Report written to: D:\Pedro\FIUADY\Servicio\Quartus\ejemplo_1.qpf.dse.rpt
Info: CSV report files written to dse\dse1\output/*.csv
Info: Exploration Server ready to exit

We are not sure if we are setting up the parameters correctly. We have tried from the gui and from the console and both of them display the same error message specified above. We would like to know if we have misunderstood some of the settings or if we have wrote them using a bad syntax.


Here are the settings that we used for both tries:

Hostnames: (IP adress of the Intel® Nuc)

private_key: C:\Private_key\id.rsa.ppk
user: lab
Quartus Root Path: /home/lab/quartus-free/pkg/quartus-free-quartus/opt/intelFPGA/21.1/bin/quartus

SSH Client: C:\Program Files\PuTTY\plink.exe

Farm Operating System: linux

Local to Remote Path Mapping: D:\Pedro\FIUADY\Servicio\Quartus;/home/lab/Codes/FPGA

Initial Working Directory: /home/lab/Codes/FPGA

Labels (1)
0 Kudos
7 Replies


Based on the error message you got, the machine is not able to get the IP address of the local host. In the DSE II Server Settings, go to the Host field and enter the IPv4 address of the local machine.

You may find this useful:



p/s: If any answer from the community or Intel Support are helpful, please feel free to give best answer or rate 4/5 survey.

0 Kudos

Hi, thanks for your response!

I entered my IPv4 Address in additional arguments as "--host" and it worked!


But now I'm having another issue, I would be happy if you could help me with this one too:


Info: Processing started: Wed Sep 20 14:28:04 2023
Info: Resolved host: to IP address:
Traceback (most recent call last):
File "d:\programas\quartus\quartus\common\python\lib\site-packages\", line 3129, in execute_sql
cursor.execute(sql, params or ())
sqlite3.OperationalError: database is locked

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File "<string>", line 22, in <module>
File "", line 1918, in main
File "", line 1790, in main_impl
File "", line 391, in run
File "", line 193, in clear
File "", line 410, in init
File "", line 437, in clear
File "d:\programas\quartus\quartus\common\python\lib\site-packages\", line 3321, in drop_tables
File "d:\programas\quartus\quartus\common\python\lib\site-packages\", line 6657, in drop_table
cls._schema.drop_all(safe, drop_sequences, **options)
File "d:\programas\quartus\quartus\common\python\lib\site-packages\", line 5785, in drop_all
self.drop_table(safe, **options)
File "d:\programas\quartus\quartus\common\python\lib\site-packages\", line 5658, in drop_table
self.database.execute(self._drop_table(safe=safe, **options))
File "d:\programas\quartus\quartus\common\python\lib\site-packages\", line 3142, in execute
return self.execute_sql(sql, params, commit=commit)
File "d:\programas\quartus\quartus\common\python\lib\site-packages\", line 3136, in execute_sql
File "d:\programas\quartus\quartus\common\python\lib\site-packages\", line 2902, in __exit__
reraise(new_type, new_type(exc_value, *exc_args), traceback)
File "d:\programas\quartus\quartus\common\python\lib\site-packages\", line 185, in reraise
raise value.with_traceback(tb)
File "d:\programas\quartus\quartus\common\python\lib\site-packages\", line 3129, in execute_sql
cursor.execute(sql, params or ())
peewee.OperationalError: database is locked
Design Space Explorer finished


What could cause this?

0 Kudos


I'm not a DSE II expert. May I know if this the file is yours/part of your design or something that comes with the DSE II and has to be used by it?



0 Kudos

Hi again, file is totally from DSEII and I have no idea why we are getting this error. I will check out the links you provided and hopefully find out.


Thanks and regards.

0 Kudos

Hi Pedro,

May I know if you manage to work on this issue?

Does previous reply helps?

0 Kudos


We have not received a reply from you. As such, I now transition this thread to community support. If you have a new question, Feel free to open a new thread or login to ‘ ’, view details of the desire request, and post a feed/response within the next 15 days to allow me to continue to support you. After 15 days, this thread will be transitioned to community support. The community users will be able to help you on your follow-up questions.


If any answer from the community or Intel Support are helpful, feel free to rank your support experience by rating 4/5 survey. Please let me know of any inconvenience so that I may improve your future service experience.


Have a great day!

Best regards,

Nurina W.

p/s: If any answer from the community or Intel Support are helpful, please feel free to give best answer or rate 4/5 survey.

0 Kudos