Intel® FPGA University Program
University Program Material, Education Boards, and Laboratory Exercises
1108 Discussions

University Program tcl scripts problem

Altera_Forum
Honored Contributor II
849 Views

Hi, I just installed University Program IP Cores and encountered a problem: 

on QSYS initialization there are errors for every UP IP core like this : 

Error: Factory com.altera.embeddedsw.bsp.elements.tcl.EmbeddedSwTclDriverFactory reading C:\altera\14.1\ip\University_Program\Audio_Video\altera_up_avalon_audio\altera_up_avalon_audio_sw.tc... exception java.lang.NullPointerException 

 

ignoring the error and constructing system with IP core is possible, but BSP created for my NIOS II gen2 lacks drivers, header files etc for UP IP core rendering it unusable for me. 

 

I don't know is it a proper way to look for the bugs but executing one of failing scripts from console shows error: 

invalid command name "create_driver" while executing 

"unknown_original create_driver Altera_UP_SD_Card_Avalon_Interface_driver" ("eval" body line 1) 

invoked from within 

"eval unknown_original $cmd $args" (procedure "::unknown" line 7) invoked from within 

"create_driver Altera_UP_SD_Card_Avalon_Interface_driver" (file "Altera_UP_SD_Card_Avalon_Interface_sw.tcl" line 7) 

 

I use Win7 64 bit Quartus 14.1 64 bit University program IP cores for 14.1
0 Kudos
2 Replies
Altera_Forum
Honored Contributor II
105 Views

Settem, 

 

It's not just you - I had exactly the same problem after installing the university IP, with Quartus 14.1 and Windows 7. I assume its a bug. 

 

I managed to get rid of the errors in qsys by changing the line: 

source "../../lib/aup_version.tcl" 

(which is present near the top of all of the *_sw.tcl & *_hw.tcl files) 

to the full path: 

e.g. source "C:/altera/14.1/ip/University_Program/lib/aup_version.tcl" 

 

That fixed the errors in qsys and eclipse for me. There might be a better way to fix it, but thats what I came up with.
Altera_Forum
Honored Contributor II
105 Views

Apparently this is fixed with Quartus version 15.0 .

Reply