Intel® FPGA University Program
University Program Material, Education Boards, and Laboratory Exercises
1182 Discussions

error when adding and using my own library in modelSim?

TarikTec
New Contributor I
853 Views

Hello,

I have the same problem as the question here but the solutions still not working for me

https://community.intel.com/t5/Programmable-Devices/Modelsim-compiling-error-vcom-11-Could-not-find-work-stratixiv/td-p/176820 

 

SO I have my modelsim files in Desktop/FPGA/Altera/filter

then I added my_lib.all as :use work.my_lib.all and my_lib is in work and also in folder filter but still same error.

I changed it to : use filter.my_lib.all and still says filter is unknown!

 

I feel like I do not know how to manage files in modelsim too, is there a tutorial on it?

 

0 Kudos
1 Solution
Nurina
Employee
833 Views

Hi,


Can you upload a full message of the errors?


On ModelSim, go to Help->PDF Documentation -> User's Manual. You can refer to Chapter 3 Design Libraries.

Or you can go to Help->PDF Documentation -> Tutorial. You can refer to Chapter 5 Working with Multiple Libraries.


Regards,

Nurina


View solution in original post

3 Replies
Nurina
Employee
834 Views

Hi,


Can you upload a full message of the errors?


On ModelSim, go to Help->PDF Documentation -> User's Manual. You can refer to Chapter 3 Design Libraries.

Or you can go to Help->PDF Documentation -> Tutorial. You can refer to Chapter 5 Working with Multiple Libraries.


Regards,

Nurina


TarikTec
New Contributor I
828 Views

Thank you, I have found the problem which was the name where I saved it.

Thank you for the two very important links, very important for beginner like me

0 Kudos
Nurina
Employee
819 Views

Hi, 

I’m glad that your question has been addressed, I now transition this thread to community support. If you have a new question, feel free to open a new thread to get the support from Intel experts. Otherwise, the community users will continue to help you on this thread. Thank you.

Regards,
Nurina

PS: If you find any comment from the community or Intel Support to be helpful, feel free to give Kudos.

Reply