Community
cancel
Showing results for 
Search instead for 
Did you mean: 
AlexiaRegine
Novice
518 Views

Changes to create a *dll with oneAPI

Hello,

 

I'm trying to create a *dll to implement in a program of finite element methods. Everything was working fine with the Intel Parallel studio XE compiler. However, after I changed to oneAPI, my program does not recognize the *dll created. Someones know if can I fix it or come back to use the Intel Parallel studio XE.

Labels (1)
Tags (1)
0 Kudos
7 Replies
NoorjahanSk_Intel
Moderator
479 Views

Hi,

Thanks for reaching out to us.

>> I changed to oneAPI, my program does not recognize the *dll created

could you please confirm whether you have created a dll file with oneAPI compiler? if you have any issues(while creating dll), please share the error log so that it will help us to get some more insights.

Please provide the following environmental details:

Parallel Studio XE version where the dll creation was successful

oneAPI version

OS & version

Compiler version.


Thanks & Regards

Noorjahan.


AlexiaRegine
Novice
472 Views

Hi Noorjahan,

 

Yes, the dll was created with no errors, but isn't recognized by the program I'm using.

Some details:

  • Parallel Studio XE 2017 update 6 cluster edition (student license)
  • oneAPI 2021
  • Windowns 10, version 2004
  • Compiler Intel 64 for Visual Studio 2019

Regards,

Alexia

NoorjahanSk_Intel
Moderator
406 Views

Hi,


Thanks for providing the details.


You can try copying the .dll file to your application location so that the program will be able to recognize it.


In VS you can directly copy the file to the required location by giving a command under

Configuration Properties > Build Events > Post-Build Event option

Command:

xcopy /y /d "..\..\<project>\$(IntDir)*.dll" "$(OutDir)"


You can also try adding the path to the directory containing the specific dll to  %PATH% environment variable in your system.


Hope the provided information helps, if not please provide us a sample reproducer and complete error log to get some more insights regarding your issue.


Thanks & Regards

Noorjahan.


AlexiaRegine
Novice
321 Views

Hi Noorjahan,

 

Sorry for the delay, but I was trying to solve another problem. In my first try to apply your suggestion, the *dll was generated normally, but wasn't regognized yet. After restart the computer and try again, the *dll was no generated because the error #10037 (see the image bellow). Now, I'm trying to fix it to try again.

 

Regards,

Alexia

WhatsApp Image 2021-09-30 at 09.47.08.jpeg

mecej4
Black Belt
221 Views

If you used a CMD window configured for Intel Fortran, and the link step failed because LINK.EXE was not found, you have a basic problem -- probably a faulty installation of Visual Studio or Intel OneAPI/Parallel Studio. Can you compile and run a simple Hello, World! program in that window? If not, that has to be fixed before you try to build a DLL and get it working with another program.

You listed several versions of Parallel Studio and OneAPI. You should use only one of them at a time, since different versions are not 100 percent compatible.

Igor_V_Intel
Employee
204 Views

The link command is not found in this command line shell.

I guess that you don't have required Microsoft* Visual Studio/Build Tools version installed on your machine or need to set the environment (e.g. need to run "Intel oneAPI command prompt for Intel 64 for Visual Studio 2019" to get the command line with set environment). Could you please check the sw prerequisites to use ifort from oneAPI on Windows here: https://software.intel.com/content/www/us/en/develop/articles/oneapi-fortran-compiler-system-require... ?

You need to have Visual Studio 2017/2019 or Build Tools 2017/2019 installed on your machine before installing Intel Fortran compiler version 2021.

 

NoorjahanSk_Intel
Moderator
365 Views

Hi,

Could you please confirm whether your issue is resolved? if not, could you please provide the requested details asked in the previous post?


Thanks & Regards

Noorjahan


Reply