Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.

Configure exe to avoid missing dll

sanjayg0
Novice
233 Views

System: Window 10 Pro, Visual Studio Community 2022 (17.10.0), oneAPI ifx 2024.1.0

I just moved my set up to the VS 2022 and re-installed oneAPI form the VS marketplace.  When I build my code within VS, I can run it just fine with the "Start" button. 

If I want to run it from the command prompt, I get errors regarding missing DLL (libmmd.dll).  I can get rid of this error, if I first run setvar.bat from the oneAPI install directory.

I would like to be able to also click on the exe in the file explorer.  However when I do that I get the error about the missing DLL (libmmd.dll).  Is there a convenient way to avoid this?  somehow force a similar action to running setvar.bat?

With previous versions of VS and older versions of the Intel compiler I never had this issue.

0 Kudos
1 Solution
Steve_Lionel
Honored Contributor III
197 Views

If the oneAPI install went correctly, it should have added the folder containing the DLL to the system PATH environment variable. I know that the 2024.0 version did not (the folders changed in that release and the installer didn't account for that.) I thought that 2024.1 fixed it, though.

The first thing I suggest is to reboot - sometimes I have found that PATH changes didn't get applied until a reboot (or log out and in). 

You can examine the value of the PATH variable - it should contain:

C:\Program Files (x86)\Intel\oneAPI\compiler\latest\bin
C:\Program Files (x86)\Intel\oneAPI\compiler\latest\bin32

Do make sure that it's not actually asking for libmmdd.dll, the debug version, which is available only from within a build environment.

 

View solution in original post

0 Kudos
2 Replies
Steve_Lionel
Honored Contributor III
198 Views

If the oneAPI install went correctly, it should have added the folder containing the DLL to the system PATH environment variable. I know that the 2024.0 version did not (the folders changed in that release and the installer didn't account for that.) I thought that 2024.1 fixed it, though.

The first thing I suggest is to reboot - sometimes I have found that PATH changes didn't get applied until a reboot (or log out and in). 

You can examine the value of the PATH variable - it should contain:

C:\Program Files (x86)\Intel\oneAPI\compiler\latest\bin
C:\Program Files (x86)\Intel\oneAPI\compiler\latest\bin32

Do make sure that it's not actually asking for libmmdd.dll, the debug version, which is available only from within a build environment.

 

0 Kudos
sanjayg0
Novice
97 Views

Thanks.  I went into the system settings and added the two directories to PATH.  This solves the issue for all cases.

0 Kudos
Reply