Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.
27554 Discussions

INTEL_GT_DEBUGGER: Exception in IsRemoteDebugging

AONym
New Contributor II
695 Views

Windows 11; VS 2022 17.4.3; IFORT 2023.0.0

Installation proceeded smoothly, and compiler seems to work properly, but when I start execution of my C++ MFC project + Fortran library, I get hundreds of messages in the output window like

INTEL_GT_DEBUGGER: (36479) Exception thrown in method IsRemoteDebugging: Not implemented (Exception from HRESULT: 0x80004001 (E_NOTIMPL))

What is the meaning of these, and how can I fix the cause so I don't get them. They appear all throughout the pgms's execution.

0 Kudos
19 Replies
AONym
New Contributor II
641 Views

Can anyone help me with this? It causes long delays in debugging.

Devorah_H_Intel
Moderator
628 Views

Can't say much without seeing the project. 

Maybe check these settings in VS. 

 

 

MicrosoftTeams-image (1).png

AONym
New Contributor II
594 Views

@Devorah_H_Intel: Here are my settings. This is VS 2022 17.4.4, so my properties window is slightly different from yours. As you can see, it's set to local (I've never used the remote debugger for this project).

I can't find any info on

INTEL_GT_DEBUGGER: (36479) Exception thrown in method IsRemoteDebugging

 either INTEL_GT_DEBUGGER or IsRemoteDebugging. The 36479 looks like an identifier in the Fortran runtime, and it is different for each message.Project properties.png

Steve_Lionel
Black Belt Retired Employee
592 Views

You could try changing that value to Native Only, but my advice would be to "Modify" the Intel oneAPI Base Toolkit and remove Intel Distribution for GDB.

The message you are seeing is not related to Fortran.

AONym
New Contributor II
536 Views

Steve -

Changing the value to Native Only doesn't get rid of the messages. Leaving the Debugger Type set to Native Only, I then used "Modify" to remove the Intel Distribution for GDB, which also removed the DPC C++ compiler, but after restarting VS, I still get the same stream of messages when I start debugging my executable.

Any other suggestions?

Steve_Lionel
Black Belt Retired Employee
530 Views

Sorry, no. I'm puzzled that you still get this error after my suggestions, but perhaps the problem is elsewhere. FYI, "GT" here refers to the Intel processor's integrated GPU.

AONym
New Contributor II
352 Views

Processor is Intel i9-12900K. Its integrated GPU is UHD Graphics 770.

I changed Tools/Options/Debugging/General/"Ignore GPU memory access exceptions if the data written didn't change the value", but this didn't fix the problem. This was the only VS option I could find that referenced the GPU.

AONym
New Contributor II
340 Views

C:\Program Files\Microsoft Visual Studio\2022\Community\Common7\IDE\Extensions\u1lk5yn5.4ab\Intel.IntelGfxDebug.dll contains the string "INTEL_GT_DEBUGGER:"

Elgot
Beginner
503 Views

I had the same issue, but I think it was caused by old versions of intel libraries. I had some subprojects with nuget references to old versions and when I upgraded them the problems disappeared.

AONym
New Contributor II
443 Views

I don't think this could be my problem, since I installed oneAPI and VS on a new machine. Nonetheless, how can I check for outdated libraries?

Elgot
Beginner
437 Views

In my case the outdated nuget packages put its own dll files (like openmp and mkl) in the application folder.

AONym
New Contributor II
351 Views

I don't find any DLLs in the application, and the only OpenMP files I have are the current versions, 14.34.31933, from VS. The mkl libraries are coming from `C:\Program Files (x86)\Intel\oneAPI\mkl\latest\lib\intel64`.

Steve_Lionel
Black Belt Retired Employee
333 Views

I think you still have Intel Distribution for gdb installed. Please check again - this is part of the oneAPI Base toolkit.

Alternatively, uninstall all the oneAPI toolkits, then install just the Fortran compiler - see Solved: The Easy and Fast Way to Install JUST Fortran with Intel® oneAPI - Intel Communities

AONym
New Contributor II
304 Views

Here is what the oneAPI installer shows. I previously did a Modify and unchecked Intel Distribution for GDB.

GDB not installed.png

I've also attached the logs from the base kit Modify, and the original HPC kit install.

Steve_Lionel
Black Belt Retired Employee
297 Views

Do you use any of those still-checked things? If not, uninstall the Base toolkit entirely.

AONym
New Contributor II
246 Views

I use mkl, and would like to be able to use VTune, TBB, and IPP.

Steve_Lionel
Black Belt Retired Employee
222 Views

Remove the components you don't use. One of them is the cause, I'm fairly certain.

Elgot
Beginner
219 Views

I have all components installed and did somehow manage to get rid of the problems. Perhaps it was the other way around though. Maybe the new nuget packages provide some dll file that wasn't found before?

Elgot
Beginner
213 Views

In that case I think intelopenmp.redist.win and inteltbb.redist.win are the main suspects.

The runtime libraries provided are:
libiomp5md.dll
libiompstubs5md.dll
tbb12.dll
tbbbind.dll
tbbbind_2_0.dll
tbbbind_2_5.dll
tbbmalloc.dll
tbbmalloc_proxy.dll

Reply