Intel® High Level Design
Support for Intel® High Level Synthesis Compiler, DSP Builder, OneAPI for Intel® FPGAs, Intel® FPGA SDK for OpenCL™
Announcements
All support for Intel NUC 7 - 13 systems has transitioned to ASUS. Read latest update.
649 Discussions

Oneapi fpga board error

Chithambarash
Beginner
819 Views

I had previously installed oneapi version 2023.2.0, however due to compatibility issues with my ubuntu version, I downgraded to oneapi version 2021.4.0. I successfully initialized my fpga board but i'm unable to compile or run programs on the fpga.
(I have already tried updating the env variables)
new_error.jpg

0 Kudos
7 Replies
BoonBengT_Intel
Moderator
784 Views

Hi @Chithambarash,


Thank you for posting in Intel community forum and hope all is well.

Based on the screenshot, there seems to be an output from the command sycl-ls.

Perhaps you can also check run the aocl diagnose command to check on the initialization.


As for the error mention it seems to be related to version 2023.2.0.

Hence would suggest to check if the version 2023.2.0 are completely uninstall

Hope that clarify


Best

Regards


0 Kudos
Chithambarash
Beginner
774 Views

This is the aocl diagnose output:

--------------------------------------------------------------------
ICD System Diagnostics
--------------------------------------------------------------------

Using the following location for ICD installation:
/etc/OpenCL/vendors

Found 3 icd entry at that location:
/etc/OpenCL/vendors/Altera.icd
/etc/OpenCL/vendors/intel-cpu.icd
/etc/OpenCL/vendors/Intel_FPGA_SSG_Emulator.icd

The following OpenCL libraries are referenced in the icd files:
libalteracl.so
libintelocl.so
libintelocl_emu.so

Checking LD_LIBRARY_PATH for registered libraries:
WARNING: libintelocl_emu.so NOT FOUND

Using OCL_ICD_FILENAMES to search for ICD clients, it is set to libintelocl_emu.so:libalteracl.so:/opt/intel/oneapi/compiler/2021.4.0/linux/lib/x64/libintelocl.so

Checking LD_LIBRARY_PATH for registered libraries specified by OCL_ICD_FILENAMES
WARNING: libintelocl_emu.so NOT FOUND
libalteracl.so was registered on the system at /opt/intel/oneapi/compiler/2021.4.0/linux/lib/oclfpga/host/linux64/lib
/opt/intel/oneapi/compiler/2021.4.0/linux/lib/x64/libintelocl.so was registered on the system.

Using the following location for fcd installations:
/opt/Intel/OpenCLFPGA/oneAPI/Boards

Found 1 fcd entry at that location:
/opt/Intel/OpenCLFPGA/oneAPI/Boards/intel_a10gx_pac.fcd

The following OpenCL libraries are referenced in the fcd files:
libopae-c.so
/opt/intel/oneapi/compiler/2023.2.0/linux/lib/oclfpga/board/intel_a10gx_pac/linux64/lib/libMPF.so
/opt/intel/oneapi/compiler/2023.2.0/linux/lib/oclfpga/board/intel_a10gx_pac/linux64/lib/libintel_opae_mmd.so

Checking LD_LIBRARY_PATH for registered libraries:
WARNING: libopae-c.so NOT FOUND
WARNING: /opt/intel/oneapi/compiler/2023.2.0/linux/lib/oclfpga/board/intel_a10gx_pac/linux64/lib/libMPF.so NOT FOUND
WARNING: /opt/intel/oneapi/compiler/2023.2.0/linux/lib/oclfpga/board/intel_a10gx_pac/linux64/lib/libintel_opae_mmd.so NOT FOUND
Error: Could not load board library /opt/intel/oneapi/compiler/2023.2.0/linux/lib/oclfpga/board/intel_a10gx_pac/linux64/lib/libMPF.so (error_msg: /opt/intel/oneapi/compiler/2023.2.0/linux/lib/oclfpga/board/intel_a10gx_pac/linux64/lib/libMPF.so: cannot open shared object file: No such file or directory)
Failed to dynamically load board MMD /opt/intel/oneapi/compiler/2023.2.0/linux/lib/oclfpga/board/intel_a10gx_pac/linux64/lib/libMPF.so
Error: Could not load board library /opt/intel/oneapi/compiler/2023.2.0/linux/lib/oclfpga/board/intel_a10gx_pac/linux64/lib/libintel_opae_mmd.so (error_msg: /opt/intel/oneapi/compiler/2023.2.0/linux/lib/oclfpga/board/intel_a10gx_pac/linux64/lib/libintel_opae_mmd.so: cannot open shared object file: No such file or directory)
Failed to dynamically load board MMD /opt/intel/oneapi/compiler/2023.2.0/linux/lib/oclfpga/board/intel_a10gx_pac/linux64/lib/libintel_opae_mmd.so
Error: Could not load board library /opt/intel/oneapi/compiler/2023.2.0/linux/lib/oclfpga/board/intel_a10gx_pac/linux64/lib/libMPF.so (error_msg: /opt/intel/oneapi/compiler/2023.2.0/linux/lib/oclfpga/board/intel_a10gx_pac/linux64/lib/libMPF.so: cannot open shared object file: No such file or directory)
Failed to dynamically load board MMD /opt/intel/oneapi/compiler/2023.2.0/linux/lib/oclfpga/board/intel_a10gx_pac/linux64/lib/libMPF.so
Error: Could not load board library /opt/intel/oneapi/compiler/2023.2.0/linux/lib/oclfpga/board/intel_a10gx_pac/linux64/lib/libintel_opae_mmd.so (error_msg: /opt/intel/oneapi/compiler/2023.2.0/linux/lib/oclfpga/board/intel_a10gx_pac/linux64/lib/libintel_opae_mmd.so: cannot open shared object file: No such file or directory)
Failed to dynamically load board MMD /opt/intel/oneapi/compiler/2023.2.0/linux/lib/oclfpga/board/intel_a10gx_pac/linux64/lib/libintel_opae_mmd.so

Number of Platforms = 2
1. Intel(R) FPGA Emulation Platform for OpenCL(TM) | Intel(R) Corporation | OpenCL 1.2 Intel(R) FPGA SDK for OpenCL(TM), Version 20.3
2. Intel(R) OpenCL | Intel(R) Corporation | OpenCL 3.0 LINUX
ERROR: Failed to find Intel(R) FPGA SDK for OpenCL(TM)

ERROR: OpenCL host failed
--------------------------------------------------------------------
ICD diagnostics FAILED
--------------------------------------------------------------------
--------------------------------------------------------------------
BSP Diagnostics
--------------------------------------------------------------------
--------------------------------------------------------------------
Device Name:
acl0

BSP Install Location:
/opt/intel/oneapi/intelfpgadpcpp/2021.4.0/board/intel_a10gx_pac

Vendor: Intel Corp

Physical Dev Name Status Information

pac_ec00000 Passed Intel PAC Platform (pac_ec00000)
PCIe 134:00.0
USM not supported
FPGA temperature = 58 degrees C.

DIAGNOSTIC_PASSED
--------------------------------------------------------------------

Call "aocl diagnose <device-names>" to run diagnose for specified devices
Call "aocl diagnose all" to run diagnose for all devices



 

0 Kudos
BoonBengT_Intel
Moderator
695 Views

Hi @Chithambarash,


Apologies for the delayed, based on the diagnosed it did show the similar error where compiler are getting some library missing for version 2023.2.0

Hence would recommend to check on the environment variable on the windows machine.

Hope that clarifies.


Best Wishes

BB


0 Kudos
Chithambarash
Beginner
683 Views

We are using Ubuntu 18.04, we do not want to use version 2023. We want to use 2021.4.0 version.
I had previously installed oneapi version 2023.2.0, however due to compatibility issues with my ubuntu version, I downgraded to oneapi version 2021.4.0.
We are not sure how to remove the environment variables for 2023.2.0.

Environment variables for our system:

lsai_nikhil@server1:~$ env
LD_LIBRARY_PATH=:/usr/lib/x86_64-linux-gnu:/opt/intel/oneapi/compiler/2021.4.0/linux/lib:/opt/intel/oneapi/compiler/2021.4.0/linux/lib/oclfpga/board/intel_a10gx_pac/linux64/lib
LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=00:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arc=01;31:*.arj=01;31:*.taz=01;31:*.lha=01;31:*.lz4=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.tzo=01;31:*.t7z=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lrz=01;31:*.lz=01;31:*.lzo=01;31:*.xz=01;31:*.zst=01;31:*.tzst=01;31:*.bz2=01;31:*.bz=01;31:*.tbz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.alz=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.cab=01;31:*.wim=01;31:*.swm=01;31:*.dwm=01;31:*.esd=01;31:*.jpg=01;35:*.jpeg=01;35:*.mjpg=01;35:*.mjpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.webm=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=00;36:*.au=00;36:*.flac=00;36:*.m4a=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:*.oga=00;36:*.opus=00;36:*.spx=00;36:*.xspf=00;36:
quartus_dir=/home/lsai_nikhil/intelFPGA_pro
SSH_CONNECTION=192.168.0.163 52497 192.168.0.125 22
LESSCLOSE=/usr/bin/lesspipe %s %s
QUARTUS_ROOTDIR=/home/lsai_nikhil/intelFPGA_pro/19.3/quartus
WORKON_HOME=/home/lsai_nikhil/.virtualenvs
S_COLORS=auto
USER=lsai_nikhil
PWD=/home/lsai_nikhil
HOME=/home/lsai_nikhil
SSH_CLIENT=192.168.0.163 52497 22
INTELFPGAOCLSDKROOT=/opt/intelFPGA_pro/quartus_19.2.0b57/hld
LIBVIRT_DEFAULT_URI=qemu:///system
IP_ROOTDIR=/home/lsai_nikhil/intelFPGA_pro/19.3/ip/
XDG_DATA_DIRS=/usr/local/share:/usr/share:/var/lib/snapd/desktop
QSYS_ROOTDIR=/opt/intel/oneapi/intelfpgadpcpp/2021.4.0/QuartusPrimePro/19.2/qsys/bin
GTK_MODULES=appmenu-gtk-module
SSH_TTY=/dev/pts/1
VIRTUALENVWRAPPER_PYTHON=/usr/bin/python3
MAIL=/var/mail/lsai_nikhil
UBUNTU_MENUPROXY=1
TERM=xterm-256color
SHELL=/bin/bash
RUNLEVEL=3
SHLVL=1
LOGNAME=lsai_nikhil
XDG_RUNTIME_DIR=/tmp/runtime-lsai_nikhil
PATH=/home/lsai_nikhil/.local/bin:/home/lsai_nikhil/intelFPGA_pro/19.3/quartus/sopc_builder/bin:/home/lsai_nikhil/intelFPGA_pro/19.3/modelsim_ase/linuxaloem:/home/lsai_nikhil/intelFPGA_pro/19.3/quartus/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/snap/bin:/home/lsai_nikhil/test/bin
LESSOPEN=| /usr/bin/lesspipe %s
pigasus_rep_dir=/home/lsai_nikhil/pigasus
_=/usr/bin/env


 Could you please assist us in resolving this issue?

0 Kudos
BoonBengT_Intel
Moderator
643 Views

Hi @Chithambarash,

Noted on the OS version as well as the environment key.

It looks good to me too, hence suspecting the FPGA client driver are still referring to the wrong version.


For that perhaps you recommended to re-install the FPGA board, for more details perhaps can refer to the section 4 in the link below:

- https://www.intel.com/content/www/us/en/docs/programmable/683846/22-4/managing-an-fpga-board.html

Hope that clarify.


Regards

BB


0 Kudos
BoonBengT_Intel
Moderator
584 Views

Hi @Chithambarash,


Greetings, just checking in to see if there is any further doubts in regards to this matter.

Hope your doubts have been clarified.


Best Wishes

BB


0 Kudos
BoonBengT_Intel
Moderator
501 Views

Hi @Chithambarash,


Greetings, as we do not receive any further clarification/updates on the matter, hence would assume challenge are overcome. Please login to ‘https://supporttickets.intel.com’, view details of the desire request, and post a feed/response within the next 15 days to allow me to continue to support you. After 15 days, this thread will be transitioned to community support. For new queries, please feel free to open a new thread and we will be right with you. Pleasure having you here.


Best Wishes

BB



0 Kudos
Reply