Intel® MPI Library
Get help with building, analyzing, optimizing, and scaling high-performance computing (HPC) applications.
2158 Discussions

Intel oneAPI mpirun error in Ubuntu 20.04.3

ousam2023
Beginner
1,736 Views
I have an installation of intel oneAPI version 2021.4 via Ubuntu 20.04.3LTS. Everything used to be run well. but somehow, something bugging me is that I can't run my mpirun.

For instance:

viewfile.png

viewfile.png

What causes this behavior? How do I solve it?

0 Kudos
8 Replies
VarshaS_Intel
Moderator
1,710 Views

Hi,

 

Thanks for posting in Intel Communities.

 

Could you please let us know the output by using the below command?

which mpirun

 

And also, the MPI version you are using with the following command?

mpirun --version

 

Also, try exporting the PATH by using the output of the "which mpirun":

export PATH=<output-of-which-mpirun>:$PATH
Example: export PATH=/opt/intel/oneapi/mpi/2021.4.0//bin/mpirun:$PATH

After that, check and let us know the MPI version using the command:

mpirun --version

 

Thanks & Regards,

Varsha

 

0 Kudos
ousam2023
Beginner
1,697 Views

Hi,

Great thanks for your help!

Here is my screen capture after following your advice:

 

viewfile.png

and I also post my ubuntu kernel which I think will help.

Thanks & Regards,

Ousam

0 Kudos
VarshaS_Intel
Moderator
1,672 Views

Hi,

 

Thanks for providing the details.

 

Could you please try giving the complete path(output of the "which mpirun") while running the mpi code?

 

Example:/opt/intel/oneapi/mpi/2021.4.0//bin/mpirun --version
/opt/intel/oneapi/mpi/2021.4.0//bin/mpirun -n 2 hostname

 

Could you please try and let us know if you are able to run without hanging?

 

If possible, could you please try the latest Intel MPI Library(2021.8)?

 

Thanks & Regards,

Varsha

 

0 Kudos
VarshaS_Intel
Moderator
1,635 Views

Hi,


We have not heard back from you. Could you please provide us with an update on your issue?


Thanks & Regards,

Varsha


0 Kudos
ousam2023
Beginner
1,622 Views

Hi,

 

Sorry for reply you so late,I just finished my vacation.

Here is the screen after following your advise. 

My mpirun used to executed well until something upgrade in my Ubuntu (I guess) .

I have no idea what is happended in my systems.

It seems to jam in the mpiexec.hydra which is mpirun's api, but no mpirun in the system process.

 
 

viewfile.png

 

 

 

Thanks & Regards,

Ou sam

0 Kudos
VarshaS_Intel
Moderator
1,561 Views

Hi,

 

Thanks for the update.

 

As we mentioned before, could you please try using the Intel MPI latest compiler(2021.8) and run the sample hello world code?

Please find the links for the installation of the Intel Base Toolkit and Intel  HPC Toolkit.

 

Please let us know if your issue still persists.

 

Thanks & Regards,

Varsha

 

0 Kudos
ousam2023
Beginner
1,549 Views

Hi,

 

Thanks for the advice.

 

The problem was solved after I installed the latest oneAPI version. 

I don't reinstall it at first because it will make me recompile all my software, which is the toughest task in the world (sigh).

I think it may relate to intel mpi 2021.4.0's weird bug.

Overall, appreciate your help!

 

Thanks & Regards,

Ou sam

 
0 Kudos
VarshaS_Intel
Moderator
1,542 Views

Hi,


>>The problem was solved after I installed the latest oneAPI version.

 Glad to know that your issue is resolved. This thread will no longer be monitored by Intel. If you have any other queries, please start a new thread.


Have a good day!


Thanks & Regards,

Varsha


0 Kudos
Reply