Intel® NUCs
Support for Intel® NUC products
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.
12760 Discussions

NUC5i5MYHE Windows 10 constantly gets BSOD (CRITICAL_PROCESS_DIED), UEFI boot device disappears


As the title says, we have a Intel NUC NUC5i5MYHE with Windows 10 and it suddenly within the last few weeks gets a BSOD with the error CRITICAL_PROCESS_DIED. After it does this it reboots and the UEFI boot device for drive 0 for Windows cannot be found and does not appear in Visual BIOS sometimes. It tries to legacy boot but since it's a GPT partition, it fails. I power cycle it and it'll typically boot and work again for a short time, but will eventually BSOD with the same error.


I have tried all the usual, applied Windows updates, updated from Windows version 1809 to 1903, updated all the drivers from Intel, flashed the latest BIOS (0054). After none of those things worked, I tried running SFC and DISM to refresh the image, it claimed to find corrupt system files and fixed them, yet still BSOD. I ran Windows Memory Diagnostic and installed and ran Intel's SSD tool to test the health of the drive. Memory and drive results appeared fine. Eventually I completely clean installed Windows and yet still get the same BSOD error.


I've almost given up. Could this be a hardware issue with the NUC? It still is under warranty.

0 Kudos
3 Replies
Super User Retired Employee

It is certainly possible that it is a H/W issue, though I have never heard of this particular error occurring as a result of one.


I don't really trust the Windows Memory Diagnostic to find anything, frankly. I suggest that you use MemTest86+ (its freeware) and give the memory a really good 4+ hour test (I also run this for 24+ hours to burn-in new memory before using it in a live system). You can also try running with a (single) replacement SODIMM and see if this changes anything.


Have you run some sort of analyzer on the dump file to see what critical process it is that is dying?



Thanks for the reply. I will try MemTest. The unfortunate thing about the error is that when it happens nothing seems to get written. I’ve encountered these BSOD on Windows 10 machines before and they’ll typically have a percentage operation that ticks up till 100% and writes a dump log before it reboots. On the NUC it just stays at 0% and nothing happens for several seconds then it just restarts to a no boot device found message. After I power cycle and reboot Windows event viewer will show that it had an error attempting to create a dump file. Attached image.

Super User

Since SFC finds corrupted files, the problem could be the SSD. Yes, I know you ran Intel SSD Tool diagnostics. Any way, I would try other drive. In case that you don't have other SSD, you may install Windows (just for test) on HDD.