Intel® Optane™ Solid State Drives
Support for Issues Related to Solid State Drives based on Intel® Optane™ technology, Intel® MAS and Firmware Update Tool
439 Discussions

Disk Manager Doesn't see any of my drives or flash drives, but Device Manager Does.

BWilliams
Beginner
1,326 Views

Hi there,

 

This is a multi-faceted problem that I'm trying to troubleshoot on a new build running on Win11.
Any help or assistance would be fantastic - with a big thank you in advance.

 

To start I've already confirmed with the motherboard creator (MSI) that the problems I'm having aren't a Motherboard related issue - I was working up the chain of command as it were but wanted to include that I've gone looking for help there with no findings. Windows also booted me to Intel since they say that since Device Manager can 'see' the drives it's a driver issue not a Windows issue.

 

SO I have technically 3 problems, but I'm viewing them as 1 or 2 since they all seem related.

#1 - My secondary NVMe drive is seen in BIOS, it's seen on Device Manager - but not under storage, it's under 'Other Devices' & Disk Manager doesn't see it at all. It's a Micron 3400 NVMe 1024GB.
- It has been previously used, but cleaned off after my prior machine's motherboard & CPU bit it big time.

- I have tried to see if CHKDSK see's it, it does not.

#2 & 3 - I have a Samsung USB 3.1 flash drive, as well as a Samsung T7 1TB SSD external drive that work perfectly well on other machines, but on this machine again they are seen under 'Other Devices' on Device Manager, the sound of the PC 'seeing' I've plugged a device in plays, but the disk manager doesn't see them nor is there any way to interact with them nor the files they hold.

- I have tried using Samsung's media to see if it could detect either & no luck for me. And I did reach out to Samsung to ask if they had any drivers I would need to install - they do not & say that it should automatically function without issue.

- I've tried to right-click the drives in Device Manager to 'update drivers' but it can't find any to update, and I know with the T7 in particular that it's software is up-to-date.

 

So yeah I'm stuck on what to do at this point - since I do agree with the MOBO  manufacturer & Windows it has to be something within drivers, but I'm unsure what to do from here.

Let me know if there is information or screen grabs I need to get for y'all to help me figure this maddening problem out, it definitely makes it hard to work when you can't access any of your files.

 

Thank you again in advance.

Britt

0 Kudos
8 Replies
Noiti-Ji
Beginner
1,263 Views

@BWilliams 

 

Try to remove it from Storage Spaces and it should show up in Disk Management.

Check Windows Storage Spaces: Go to Start > Settings > System > Storage > Advanced storage settings > Storage spaces. If the drive is listed there, remove it from the storage pool and delete the storage pool

 

Not_An_Intel_Employee

0 Kudos
BWilliams
Beginner
1,251 Views

I've checked the storage pools, and unfortunately my secondary SSD isn't listed there.

0 Kudos
I_Nawf
Beginner
1,241 Views
Is it working if you try to connect it externally?
Or maybe updating the drive firmware?
0 Kudos
BWilliams
Beginner
1,141 Views

Hi I_Nawf,

 

I don't have an M.2 converter/Case to plug the SSD in as an external.

I've tried updating the drives a few different ways and nothing has worked.
 - Tried to uninstall the devices from Device Manager, restarted PC, and they just return as the same 'other device'.

- I've tried asking Windows to search for drivers & it can't find anything.

- I've gone to the manufacture of both the M.2 SSD, and Samsung for my Flash Drive & External SSD's and asked if there were drivers for firmware I was missing. Micron's manufacturer said there was nothing they could give me - as the drives should automatically connect via Windows/Intel Drivers.
   Samsung told me that there were no drivers on their end, but that I could download their software to see if it would "see" my external SSD & Flash Drive for the computer - it doesn't on this machine, where as my external SSD & Flash Drive work without issue on all other machines I've plugged it into.

 

Specifically with the Flash Drive when I plug it in - it does pop-up in Disk Management however it's an un-lettered drive, when I try to assign it a letter it gives me a 'The operation failed to complete becase the Disk management console view is not up-to-date. Refresh the view by using the refresh task. If the problem persists close the Disk Management console, then restart Disk Management or restart the computer.' When I do follow the prompts of refreshing, restarting disk management, or restarting my pc - it doesn't change.

0 Kudos
Hayat
Employee
1,234 Views

Hello BWilliams,


Thank you for posting in Intel Communities.


Can you please share with us the screenshot you can see from the BIOS, Device Manager, Disk Management and CHKDSK command.


Please let me know the MSI model that you are using.


Please also share with us any events that has happened prior to this issue.


According to your information can you please let me know if you are using any Intel related drive?


Please let us know if you have any questions.


Regards,

Hayat

Intel Customer Support




0 Kudos
BWilliams
Beginner
1,149 Views

Hi Hayat,

I spaced that I should probably put all my PC Build's specs, my apologies for that oversight!

To specifically answer your question the MSI MOBO model I'm using is: MSI MPG Z690 Carbon WiFi, everything else is listed below.

I've attached screenshots/images of the following:
- BIOS showing that it see's the two M.2 SSD's
- Device Manager showing it only sees the WD M.2 SSD as a Disk Drive, and the Micron as an 'other device'
- Device Manager showing a Samsung Flash Drive as BOTH a Disk Drive & an 'Unknown Device'
- Disk Management's view of just the WD SSD
- Disk Management's Error when I try to change my Samsung Flash Drive's Drive Letter to try and make it accessible.
- CHKDSK - hopefully I ran it/got the image you wanted of this, let me know if you need something different!

Here is the entirety of my specs:

CPU: 12th Gen Intel Core i7-12700K 3.60 GHz
CPU cooler: Noctua NH-D15 chromas.Black, Dual-Tower CPU Cooler 140mm
Motherboard: MSI MPG Z690 Carbon WiFi (ATX, 12th Gen Intel Core, LGA 1700 Socket, DDR5, PCIe 4, CFX, M.2 Slots, Wi-Fi 6E)
Ram: G.SKILL Trident Z5 RGB Series (Intel XMP 3.0) DDR5 RAM 64GB (2x32GB) 6400MT/s CL32-39-39-102 1.40V Desktop Computer Memory UDIMM
SSD M.2 MAIN: Western Digital WD_Black 1TB SN770 NVMe, Gen4 PCIe, M.2 2280
SSD M.2 Secondary (Non-accessable currently, was old computer's SSD): Micron 3400 NVMe 1024GB
GPU:NVIDIA GeForce RTX 3080
PSU: Corsair RM850x (2021) Fully Modular ATX Power Supply - 80 PLUS Gold
PSU Age: Purchased Febuary 2024
Chassis: MSI MAG Vampiric 100R, Mid-Tower PC Gaming Case, 1x 120mm aRGB Back of Case Fan - Replaced front singular fan with 2x Noctua NF-P12 redux 1700 PWM
OS: Windows 11 Home 64-bit
Monitor: Asus TUF 27" 2K HDR Gaming Monitor (VG27AQW)

Bios Version: 3.6

 

Please let me know if there is anything else you need me to grab!

Thank you again for the help,
Britt

0 Kudos
Irwan_Intel
Moderator
1,109 Views

Hello @BWilliams 

 

Based on the information, you are using OEM manufacturer system, MSI and the drives also is not from Intel, due to this, we could only give our best effort to help you.

 

1) Please try this step: https://www.kapilarya.com/fix-the-operation-failed-to-complete-because-the-disk-management-console-view-is-not-up-to-date

2) You might need to re-install Windows OS since it may related to the OS issues.

 

If this still does not work for you, we recommend you reach out Samsung and Micron further for warranty support since we unable to provide you with the warranty details.

 

Regards,

Irwan_Intel

0 Kudos
Hayat
Employee
926 Views

Hello BWilliams,


If the previous update still does not work for you, we recommend you reach out Samsung and Micron further for warranty support since we unable to provide you with the warranty details.


Since the issue is related to the OEM, we will proceed to close the thread.


Kindly open a new thread if you have further issues. We will be more than glad to assist you.


Regards,

Hayat_Intel


0 Kudos
Reply