Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
16704 Discussions

Quartus II 14.1 web edition font rendering problem with Windows 7

Altera_Forum
Honored Contributor II
1,676 Views

Hello, 

 

I did not find any mention in user forum about a this kind of problem with fonts on Quartus II 14.1 web edition, but I think this may be useful information in case this problem appears for other users; I consumed some time to find the solution. 

 

I have a Windows 7 on Lenovo laptop with Nvidia display adapter, and fonts in Qsys's GUI were rendered incomplete especially after moving mouse over text, just as in this description on Stackoverflow site; it appears actually to be java 8 related problem: 

http://stackoverflow.com/questions/22737535/swing-rendering-appears-broken-in-jdk-1-8-correct-in-jdk-1-7 

 

The answers in the above page worked in my case, I used control panel to force Nvidia to use different 3-d settings for the Java executable in Quartus installation tree. 

Generally, this probably could be handled by creating a Windows environment variable J2D_D3D set to 'false' before launching the program, like another answer in linked page pointed out. 

 

Regards, 

Jouni
0 Kudos
1 Reply
Marduk
Beginner
638 Views

I found a similar problem with my laptop (windows 10 and Quartus Lite 17.0). There is no Nvidia video board (but Intel).

 

The font rendering issue was related to the windows opened by Megawizard

 

I solved the issue:

  • looking for the program "qmegawiz.exe"
  • right clock on the icon -> properties - > compatibility
  • click on "perform override..." (...) for: System(advanced)

 

Now it works

I hope this would be useful for someone else. I lost a lot of time to find a solution

0 Kudos
Reply