Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
16594 Discussions

Questa install not working

djmohab2
Novice
2,011 Views

I have downloaded the install archive several times, un-installed, and re-installed Questa, and when I start the program, it gives me a command shell and exits out. Here is the install log. I need assistance ASAP as it is for an important deliverable.

 

Sincerely,

David

Labels (1)
0 Kudos
24 Replies
ShengN_Intel
Employee
1,710 Views

Hi,


May I know which operating system you're using?

Have you specify the questa license path with LM_LICENSE_FILE in Environment Variables?


Thanks,

Best Regards,

Sheng


0 Kudos
djmohab2
Novice
1,695 Views

23.4, and yes I have.


I have set the LM_LICENSE_FILE as a System Variable, pointing to the path in which the LR-XXXXXX_License.dat file resides.

Running Questa, I get :

Unable to checkout a license. Make sure your license file environment variable (SALT_LICENSE_SERVER, MGLS_LICENSE_FILE, LM_LICENSE_FILE)
is set correctly and then run 'lmutil lmdiag' to diagnose the problem.

Running the lmdiag utility gives the following:

lmutil lmdiag
lmutil - Copyright (c) 1989-2019 Flexera. All Rights Reserved.
FlexNet diagnostics on Mon 2/19/2024 22:52

Can't fetch the requested Information!!
Kindly re-check the license file path and server details.

Please advise.

-David

0 Kudos
sstrell
Honored Contributor III
1,674 Views

How old is your license file?  Open it in a text editor and check the date.  It's only good for a year.

0 Kudos
djmohab2
Novice
1,656 Views

I generated the license file on Sunday. 

0 Kudos
ShengN_Intel
Employee
1,645 Views

May be try to regenerate the license file and make sure correct NIC ID and computer name.


0 Kudos
djmohab2
Novice
1,586 Views

I tried that, and double checked NIC and computer name. Can I get some actual assistance instead of the equivalent of turning it off and turning it back on again? The testbench I was provided and told to validate is protected and only valid for Questa. Otherwise I have to write my own testbench from scratch. This is ridiculous that I can't get an actual solution to a problem that is clearly the fault of the program's.

0 Kudos
ShengN_Intel
Employee
1,536 Views

Hi,

 

I tested without problem check attached screenshot. May be try download the individual file and install. Make sure using the correct license file which is Questa*-Intel® FPGA Starter Edition (License: SW-QUESTA). One more thing is make sure you're using the supported OS environment.

 

Thanks,

Best Regards,

Sheng

 

0 Kudos
ShengN_Intel
Employee
1,498 Views

Hi,


Do you have any further concern or consideration?


Thanks,

Sheng


0 Kudos
djmohab2
Novice
1,483 Views

Yes, I have concerns as your advice has not actually done anything to help address them. I am running Windows 11, which as far as I know is a compatible OS. What individual file are you talking about? I downloaded QuestaSetup_23.4.0.79-windows directly from your portal. 

The fact that you tested without any issues is irrelevant because that information does not fix or give any help to solving my issue at all.

0 Kudos
ShengN_Intel
Employee
1,454 Views

Hi,


How about using the command setx LM_LICENSE_FILE <path_to_license_file>;%LM_LICENSE_FILE% in command prompt to set the LM_LICENSE_FILE link https://www.intel.com/content/www/us/en/docs/programmable/683472/23-4/and-software-license.html any different?


Thanks,

Sheng


0 Kudos
djmohab2
Novice
1,354 Views

C:\Users\David Mohabir>setx LM_LICENSE_FILE C:\intelFPGA_pro\license.dat; %LM_LICENSE_FILE%
ERROR: Invalid syntax. Default option is not allowed more than '2' time(s).
Type "SETX /?" for usage.

No, nothing different. Can you actually make your product work? This is getting embarrassing.

 

0 Kudos
djmohab2
Novice
1,349 Views

I even installed it on another computer, my laptop, rather than my desktop and I get the same exact problems. And yes, I double checked to make sure I was generating a license against the Starter Edition.

 

lmutil lmdiag
lmutil - Copyright (c) 1989-2019 Flexera. All Rights Reserved.
FlexNet diagnostics on Sun 3/3/2024 20:33

Can't fetch the requested Information!!
Kindly re-check the license file path and server details.


This is ridiculous.

0 Kudos
ShengN_Intel
Employee
1,343 Views

Hi,


The error because of space between LM_LICENSE_FILE C:\intelFPGA_pro\license.dat; and %LM_LICENSE_FILE%.


If setx successfully, the problem still exists. Please provide your computer name and NIC id to me, I'll help to generate the license. I notice that your license name is different compared with mine.


Thanks,

Sheng


0 Kudos
djmohab2
Novice
1,339 Views

setx LM_LICENSE_FILE C:\intelFPGA_pro\license.dat;%LM_LICENSE_FILE%
ERROR: Invalid syntax. Default option is not allowed more than '2' time(s).
Type "SETX /?" for usage.

Don't think it's the space causing the problem there. Can I please get some actual assistance from anyone? Every suggestion you have given me has literally done absolutely nothing to alleviate my issues.

0 Kudos
ShengN_Intel
Employee
1,319 Views

I'm ok without the space one. Check screenshot:

ShengN_Intel_0-1709530183973.png

 

 

0 Kudos
djmohab2
Novice
1,314 Views

Okay, somehow despite the fact I did try it without a space before, I tried it again, and I got the same success dialog you did. However, upon trying to start Questa again:

Unable to checkout a license. Make sure your license file environment variable (SALT_LICENSE_SERVER, MGLS_LICENSE_FILE, LM_LICENSE_FILE)
is set correctly and then run 'lmutil lmdiag' to diagnose the problem.

 

lmutil lmdiag
lmutil - Copyright (c) 1989-2019 Flexera. All Rights Reserved.
FlexNet diagnostics on Sun 3/3/2024 22:36

Can't fetch the requested Information!!
Kindly re-check the license file path and server details.

0 Kudos
ShengN_Intel
Employee
1,311 Views

Can you provide your NIC id and computer name? I help you re-generate a new license file for Questa Starter Edition


0 Kudos
djmohab2
Novice
1,302 Views

DJDEADNUTS

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek USB GbE Family Controller
Physical Address. . . . . . . . . : 64-C9-01-B7-48-DF

0 Kudos
ShengN_Intel
Employee
1,299 Views

Hi,

 

Your Host Name is DJDEADNUTS?

Possible to provide the Host Name like stated in screenshot below:

ShengN_Intel_0-1709531726586.png

 

 

0 Kudos
djmohab2
Novice
1,291 Views

Windows IP Configuration

Host Name . . . . . . . . . . . . : DJDEADNUTS
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Ethernet:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek USB GbE Family Controller
Physical Address. . . . . . . . . : 64-C9-01-B7-48-DF
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : fdf3:3d70:bcf6:c006:4197:b02a:b5c6:ed4f(Preferred)
Temporary IPv6 Address. . . . . . : fdf3:3d70:bcf6:c006:c5d0:80a7:338d:e55f(Preferred)
Link-local IPv6 Address . . . . . : fe80::c845:ba1b:95fd:e140%22(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.68.63(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.252.0
Lease Obtained. . . . . . . . . . : Sunday, March 3, 2024 9:22:45 PM
Lease Expires . . . . . . . . . . : Monday, March 4, 2024 12:22:56 AM
Default Gateway . . . . . . . . . : 192.168.68.1
DHCP Server . . . . . . . . . . . : 192.168.68.1
DHCPv6 IAID . . . . . . . . . . . : 375703809
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-2A-BC-1D-B1-8C-1D-96-CC-3F-3F
DNS Servers . . . . . . . . . . . : 75.75.75.75
75.75.76.76
NetBIOS over Tcpip. . . . . . . . : Enabled

0 Kudos
Reply