Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
15388 Discussions

setting default version of Quartus II in Windows 7

Altera_Forum
Honored Contributor II
2,009 Views

I installed Quartus II 14.0 but I don't want to switch over to it yet. I'm still running 13.0sp1. How do I make 13.0sp1 the default so that when I double-click a .qpf file the project opens in 13.0sp1 vs. 14.0? I changed all of the environment variables to point to 13.0sp1, and I tried to assign 13.0sp1 as the default for .qpf files in Explorer, but the projects still open in 14.0. 

 

Any help appreciated!
0 Kudos
6 Replies
Altera_Forum
Honored Contributor II
283 Views

Here's my "simple" solution, along with how I figured it out. 

 

1. Start Quartus 14.0, and then exit. 

 

2. Start a Cygwin shell (not the NIOS II IDE Shell version) and type 

 

echo $QUARTUS_ROOTDIR 

 

and that points to the 14.0 install 

 

3. Start Quartus 13.1, and then exit. 

 

4. Start a Cygwin shell and type 

 

echo $QUARTUS_ROOTDIR 

 

and that points to the 13.1 install 

 

So, QUARTUS_ROOTDIR is dynamically set by Quartus, and gets left at the last version that ran. 

 

Cheers, 

Dave
Altera_Forum
Honored Contributor II
283 Views

Very interesting, Dave. Instead of using Cygwin I just fired up 13.0 and double-clicked a .qpf file and sure enough, the project opened in a new instance of 13.0. Kind of a screwy work-around but it works. 

 

Thanks! 

 

Bob S.
Altera_Forum
Honored Contributor II
283 Views

The described method worked well for me under Windows XP, but doesn't seem to work any more under 64-Bit Windows 7. Neither does starting a specific Quartus version switch the QUARTUS_ROOTDIR environment variable nor is the environment variable examined when deciding about the actual *.qpf open action. 

 

I'm not yet sure if it's a general 64-Bit Quartus problem or something caused by specific settings on my computer. 

 

I solved the problem temporarily by changing the file association with a file type manager tool but still wonder if I missed a Quartus specific way to switch the file association automatically? 

 

Regards, 

Frank
Altera_Forum
Honored Contributor II
283 Views

Frank, the simple solution described by Dave works also under Windows 7 64-Bit. I use this for switching between multible versions of Quartus (11.1, 14.1, 15.1). 

 

Jens
Altera_Forum
Honored Contributor II
283 Views

For some reason, the behavior is different with my Windows 7 64-Bit version, as already reported 

 

--- Quote Start ---  

Neither does starting a specific Quartus version switch the QUARTUS_ROOTDIR environment variable nor is the environment variable examined when deciding about the actual *.qpf open action. 

--- Quote End ---  

 

I conclude from your post, that the problem is not specific to Windows 7 64-Bit as such. Thanks for clarifying.
JFree1
Novice
283 Views

I re-posted this issue as it was still present with 17.1 while using Windows 10.

https://forums.intel.com/s/question/0D50P000040enaPSAQ/how-do-you-change-the-default-version-of-quar...

 

I got it to work by temporarily removing the quartus.exe for the wrong version is was using from it's respective file folder, then launching a QPF and picking the correct association to the desired version at the windows prompt. Why this wouldn't work through the windows default programs manager is beyond me.

Reply