Intel® oneAPI Base Toolkit
Support for core tools and libraries to build and deploy high-performance data-centric applications
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!

oneAPI VS2019 options error

Erik_T_1
Beginner
586 Views

After having installed oneAPI Base and HPC (2021.4) Toolkit on windows 10 with visual studio 2019 (16.11.4) integration and going into Tools->Options->Intel oneAPI-> Intel Distribution for GDB, I get an error if I don't select an TCP/IP port. I cannot leave this section, because it complains about "Invalid Debugger Port Number. Port number must be greater than 0." It is set to 0 by default and I do not have a GDB distribution. I was just browsing through the different options and got stuck with this. It is only a very annoying problem. The result is that I cannot leave this options section (even if I leave by cancelling and going back into the options, VS2019 goes back to the last shown and since I do not have a TCP/IP port for debugging it doesn't seem to matter what number I enter.  

This hinders me from making ANY changes in visual studio in the options menu (not just intel oneAPI section but everything in VS).

Labels (2)
0 Kudos
1 Solution
VarshaS_Intel
Moderator
490 Views

Hi,

 

Could you please try changing the TCS/IP Port value to 1234 as it is the default for Intel oneAPI using with Microsoft Visual Studio. Please find the below screenshot, update the values and let us know if you are able to get the expected outcome.

VarshaS_Intel_0-1633672657310.png

 

 

 

If your issue still persists then could you please provide the screenshot of your error and the screenshot of the TCS/IP port settings page?

 

For more information regarding the Intel® Distribution for GDB* on Windows* OS Host please refer the below link.

https://software.intel.com/content/www/us/en/develop/documentation/get-started-with-debugging-dpcpp-...

 

Also, we have observed that you are using Microsoft Visual Studio(16.11.4) which is not supported by Intel oneAPI as of now. We recommend using the supported Microsoft Visual Studio versions with Intel oneAPI.

 

Please find the below link for the Microsoft Visual Studio Compatibility with Intel oneAPI:

https://software.intel.com/content/www/us/en/develop/articles/intel-compilers-compatibility-with-mic...

 

 

Thanks & Regards

Varsha

 

View solution in original post

6 Replies
VarshaS_Intel
Moderator
524 Views

Hi,


Thanks for reporting us.


We are working on this internally and will get back to you soon.


Thanks & Regards

Varsha


VarshaS_Intel
Moderator
491 Views

Hi,

 

Could you please try changing the TCS/IP Port value to 1234 as it is the default for Intel oneAPI using with Microsoft Visual Studio. Please find the below screenshot, update the values and let us know if you are able to get the expected outcome.

VarshaS_Intel_0-1633672657310.png

 

 

 

If your issue still persists then could you please provide the screenshot of your error and the screenshot of the TCS/IP port settings page?

 

For more information regarding the Intel® Distribution for GDB* on Windows* OS Host please refer the below link.

https://software.intel.com/content/www/us/en/develop/documentation/get-started-with-debugging-dpcpp-...

 

Also, we have observed that you are using Microsoft Visual Studio(16.11.4) which is not supported by Intel oneAPI as of now. We recommend using the supported Microsoft Visual Studio versions with Intel oneAPI.

 

Please find the below link for the Microsoft Visual Studio Compatibility with Intel oneAPI:

https://software.intel.com/content/www/us/en/develop/articles/intel-compilers-compatibility-with-mic...

 

 

Thanks & Regards

Varsha

 

View solution in original post

Erik_T_1
Beginner
257 Views

Hi @VarshaS_Intel, I didn't get any e-mail notifications about the update and had alot of other things to see to so i forgot about the issue, but inputting all the values as in your screen shot, it seems to have solved the issue. I think it would be good if these values were pre-populated as shown in your screen shot by default.

VarshaS_Intel
Moderator
385 Views

Hi,


We haven't heard back from you. Could you please provide an update on your issue?


Thanks & Regards

Varsha


VarshaS_Intel
Moderator
275 Views

Hi,


We have not heard back from you. This thread will no longer be monitored by Intel. If you need further assistance, please post a new question.


Thanks & Regards

Varsha


VarshaS_Intel
Moderator
218 Views

Hi,


>>I think it would be good if these values were pre-populated as shown in your screen shot by default.

In general, this will happen by default if the integration of Intel oneAPI toolkits and VS happen successfully but in case if you install the Intel® oneAPI toolkits before installing Visual Studio, then this may cause this issue because of unsuccessful integration of VS and toolkits.


Thanks for accepting our solution. If you need any additional information, please post a new question as this thread will no longer be monitored by Intel.


Thanks & Regards

Varsha


Reply