Intel® oneAPI HPC Toolkit
Get help with building, analyzing, optimizing, and scaling high-performance computing (HPC) applications.
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.

Intel Oneapi mpirun issue

jainiltrivedi2022
455 Views

Hello there.

I am using intel oneapi MPI Library to work on one model.

(mpirun version = Intel(R) MPI Library for Linux* OS, Version 2021.2 Build 20210302)

My issue is that when we try to compile any program with mpif90 or any other compiler, it is able to generate the executable file and when we try to run that executable file without using MPI it is able to produce the desired output.

However, when we try to run that executable file using 'mpirun' command with 4 or 8 number of processes it is not producing output as well as not giving any kind of error and program is stuck. Following command I tried to execute after compiling file:

(Command: mpirun -n 4 ./filename)

One noticeable thing is when we run above command it is invoking 'hydra_pmi_proxy'.

Hope to receive valuable help.

Labels (2)
0 Kudos
5 Replies
VarshaS_Intel
Moderator
423 Views

Hi,

 

Thanks for posting in Intel Communities.

 

Could you please provide us with the OS and Hardware details of the machine you are using?

 

Could you let us know if you are able to run the sample hello world code(attached the code)? If you are able to run the sample code without any issues then please provide us with the sample reproducer you are trying to execute.

Please find the below commands for compiling and running MPI code:

Compilation: mpiifort test_mpifortran.f90 -o test
Running:  mpirun -n 3 ./test

And also, could you please provide us with the complete error log(screenshot) you are facing at the time of execution?

 

Thanks & Regards,

Varsha

 

jainiltrivedi2022
409 Views

Thank you for considering my query.

 

Yes, I was trying to execute the same hello world code for testing. Also, I had applied the same set of commands that you suggested.

 

OS Specifications:

$ uname -a

Linux wks08 4.18.0-383.el8.x86_64 #1 SMP Wed Apr 20 15:38:08 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux

 

Hardware Specifications:

$ lscpu

PFA.

 

Executed following commands:

$ which mpiifort
/opt/intel/oneapi/mpi/2021.2.0/bin/mpiifort

$ mpiifort test.f -o prog

$ mpirun -n 3 ./prog

 

It showed no output. However, I had taken the snapshot of 'top' command.

PFA.

VarshaS_Intel
Moderator
109 Views

Hi,

 

Thanks for providing the details.

 

Could you please let us know the output of the below command?

 

cat /etc/os-release

 

And also, could you please provide us with the Trace information by using the below commands?

mpiifort test_mpifortran.f90 -o test
mpirun -gdb -n 3 ./test
Now, type "bt" then please attach the generated result.

Please find the below screenshot for more details:

VarshaS_Intel_0-1673348123166.png

 

 

Thanks & Regards,

Varsha

 

 

VarshaS_Intel
Moderator
83 Views

Hi,


We have not heard back from you. Could you please provide us with an update?


Thanks & Regards,

Varsha


VarshaS_Intel
Moderator
61 Views

Hi,


We have not heard back from you. This thread will no longer be monitored by Intel. If you need additional information, please start a new thread.


Thanks & Regards,

Varsha


Reply