Media (Intel® Video Processing Library, Intel Media SDK)
Access community support with transcoding, decoding, and encoding in applications using media tools like Intel® oneAPI Video Processing Library and Intel® Media SDK
Announcements
The Intel Media SDK project is no longer active. For continued support and access to new features, Intel Media SDK users are encouraged to read the transition guide on upgrading from Intel® Media SDK to Intel® Video Processing Library (VPL), and to move to VPL as soon as possible.
For more information, see the VPL website.
3053 Discussions

CPU load and privete bytes of Quick Sync softwae is ever increasing.

Suzuki__Hidekazu
Beginner
512 Views

Hello.

I have 2 issues on H.264 decoding software using Intel media SDK - Quick Sync hardware decoding.

Issue 1: CPU load of the software is ever-increasing. It reaches to 100% in 5 or 10 hours then keep 100%. We checked using process explorer and found there is many MFXVideoVPP_GetVPPStat threads (150 threads) and CPU load of each thread is ever increasing.


Issue 2: Private bytes of the program is ever-increasing. It seems memory leak.

My environment:
Windows10 Enterprise 1607
16GB memory
SkyLake Xeon E3-1275 v5 (I have same issues on KabyLake Xeon E3-1275 v6)
Driver version on device manager: 22.20.16.4815 (Old version driver didn't have these 2 issues but it had more critical issue so I cannot use the old driver.)


I need solution of these 2 issues ASAP. Kindly give me any advice.

PrivateBytesOfQuickSyncSoftware.pngCPULoadOfQuickSyncSoftware.pngTotalCPULoad.pngThread2.png

0 Kudos
3 Replies
dedisse__daniel
Beginner
512 Views

Hello,

I have exactly the same problem.

Doing H264 decoding, after some time the CPU increase with a lot of MFXVideoVPP_GetVPPStat threads

My environement :  CPU I5 7260U + Iris 650. Driver 23.20.16.4877

The same software works fine with : CPU I5 6300U + HD520. Driver 21.20.16.4550

This is really a big big issue.

HELP NEEDED FROM INTEL DEVELOPERS;

 

0 Kudos
Beese__Erin
Beginner
512 Views

I am having this issue when using software decoding. Are there any updates?

Thanks,

Erin

0 Kudos
Mark_L_Intel1
Moderator
512 Views

Hi Suziki San,

Sorry for the late response, do you have a reproducer?

We might have some issue with clean up the used frame buffer which causes the memory management issue. Could you double check if your issue are the same as following posts:

https://software.intel.com/en-us/node/753665

https://software.intel.com/en-us/forums/media/topic/681913

Mark

0 Kudos
Reply