Media (Intel® Video Processing Library, Intel Media SDK)
Access community support with transcoding, decoding, and encoding in applications using media tools like Intel® oneAPI Video Processing Library and Intel® Media SDK
Announcements
The Intel Media SDK project is no longer active. For continued support and access to new features, Intel Media SDK users are encouraged to read the transition guide on upgrading from Intel® Media SDK to Intel® Video Processing Library (VPL), and to move to VPL as soon as possible.
For more information, see the VPL website.

Can't Play/Pause MP4 Video

gthomaz
Beginner
475 Views
Hi people!

I'm working with Intel Media SDK and DirectShow to develop a MP4 Video Recorder.
I did a "RGB to NV12 Color Converter" and it works ok!
So, I configured my GraphBuilder like this:

AudioSource -> ACC Encoder -> MPEG4Muxer
VideoSource -> Smart Tee (CapturePin) -> H264 Video ENcoder -> MPEG4 Muxer -> File Writer
VideoSource -> Smart Tee (PreviewPin) -> VideoRenderer

It works really fine!
The video has a good quality, good performance, not freeze, audio/video synchronization... everything ok..

But, the problem is:
If I'm recording a video and I execute graphbuilder.Pause(), wait a while and execute graphbuilder.Run() again, my video lose the firts part of the video.
It is, the final video have only the record after the last RUN() command.

I made a test using DirectShow AVI Filters to check if could be some bug with my code.
I change only my connect function, using AVI filters instead MP4 Media Filters...
Like this:
AudioSource -> -> AVI Muxer
VideoSource -> Smart Tee (CapturePin) -> AVI Muxer -> File Writer
VideoSource -> Smart Tee (PreviewPin) -> VideoRenderer
So, the video don't restart. I can PAUSE and RUN again... everything alright


My Question is:
Are there any people here who had this problem too?
It's a Media Filters bug??

I really want to solve this problem... so, if you could help me, please, let me know ;)

Thanks!
Guilherme

0 Kudos
1 Solution
IDZ_A_Intel
Employee
475 Views
Hi again Guilherme,

We have identified an issue in the mp4 muxer filter. The filter does not properly handle the pause event as you stated. Thanks for making us aware of this limitation.

This is something we plan to resolve in future release of Media SDK, but as of now I can unfortunately not commit a date due to internal high priority efforts.

The filters supplied with Media SDK are considered samples and therefore not full featured. You might try to explore finding alternate mp4 muxer filter or explore other workaround until we have a solution in place.

Regards,
Petter


View solution in original post

0 Kudos
4 Replies
IDZ_A_Intel
Employee
475 Views
HiGuilherme,
We will look into this to see if we can reproduce the issue and find a solution.
As soon as we have more info we'll get back you.
Thanks for your feedback,
Regards,
Petter
0 Kudos
gthomaz
Beginner
475 Views
Petter,
Thanks for your answer.
I will wat for your reply..

Regards,
Guilherme
0 Kudos
IDZ_A_Intel
Employee
476 Views
Hi again Guilherme,

We have identified an issue in the mp4 muxer filter. The filter does not properly handle the pause event as you stated. Thanks for making us aware of this limitation.

This is something we plan to resolve in future release of Media SDK, but as of now I can unfortunately not commit a date due to internal high priority efforts.

The filters supplied with Media SDK are considered samples and therefore not full featured. You might try to explore finding alternate mp4 muxer filter or explore other workaround until we have a solution in place.

Regards,
Petter


0 Kudos
gthomaz
Beginner
475 Views
Hi Peter!
I will try another solution until next SDK release.
Maybe I'll save a new file for each 'play/pause' click and try to concatenate these files .... I'm not sure yet..
Thanks again!
0 Kudos
Reply