Media (Intel® Video Processing Library, Intel Media SDK)
Access community support with transcoding, decoding, and encoding in applications using media tools like Intel® oneAPI Video Processing Library and Intel® Media SDK
The Intel Media SDK project is no longer active. For continued support and access to new features, Intel Media SDK users are encouraged to read the transition guide on upgrading from Intel® Media SDK to Intel® Video Processing Library (VPL), and to move to VPL as soon as possible.
For more information, see the VPL website.

Cannot run LA_EXT plugin


Dear Intel Developers

Last night I tried to encode a video using LA_EXT plugin for H264/AVC from Intel Media Server Studio 2016/2017/2017R2 and 

I don't know what I'm doing wrong, here are the log results, can someone from intel help me out?

C:\Users\Administrator\Documents\Samples for Intel Media Server Studio 2017 for Windows\_bin\x64>sample_multi_transcode  -i::h264 E:\VIDEO.264 -o::h264 E:\VIDEO_p.264 -w 1280 -h 720 -hw_d3d11 -async 3 -la_ext -lad 100 -u 3 -gop_size 240 -dist 4 -num_ref 6 -bref -ec::nv12 -dc::nv12
Multi Transcoding Sample Version

OpenCL or chroma conversion is present at least in one session. External memory allocator will be used for all sessions .
plugin_loader.h :166 [ERROR] Failed to load plugin from GUID, sts=-9: { 0x58, 0x8f, 0x11, 0x85, 0xd4, 0x7b, 0x42, 0x96, 0x8d, 0xea, 0x37, 0x7b, 0xb5, 0xd0, 0xdc, 0xb4 } (Intel (R) Media SDK plugin for LA ENC)

[ERROR], sts=MFX_ERR_UNSUPPORTED(-3), TranscodingSample::CTranscodingPipeline::CalculateNumberOfReqFrames, m_pmfxPreENC.get failed at src\pipeline_transcode.cpp:2686

[ERROR], sts=MFX_ERR_UNSUPPORTED(-3), TranscodingSample::CTranscodingPipeline::AllocFrames, CalculateNumberOfReqFrames failed at src\pipeline_transcode.cpp:2526

[ERROR], sts=MFX_ERR_UNSUPPORTED(-3), TranscodingSample::CTranscodingPipeline::Init, AllocFrames failed at src\pipeline_transcode.cpp:3080

[ERROR], sts=MFX_ERR_UNSUPPORTED(-3), TranscodingSample::Launcher::Init, pThreadPipeline->pPipeline->Init failed at src\sample_multi_transcode.cpp:313

[ERROR], sts=MFX_ERR_UNSUPPORTED(-3), wmain, transcode.Init failed at src\sample_multi_transcode.cpp:682

I tried with three different versions of Media Server Studio 2016/2017/2017R2  and all show the same problem, i'm on a 4th generation core i5 4570 processor with HD 4600 IGP



0 Kudos
0 Replies